summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-09-18 08:30:20 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-09-18 08:31:01 +0200
commit1e963ad3f4dad5e68fb4c4571ed70e4735a407a4 (patch)
treecef6831a23c9192af0f952928027c08730d21843 /sys-libs/libunwind
parentdev-python/txrequests: mark ALLARCHES (diff)
downloadgentoo-1e963ad3f4dad5e68fb4c4571ed70e4735a407a4.tar.gz
gentoo-1e963ad3f4dad5e68fb4c4571ed70e4735a407a4.tar.bz2
gentoo-1e963ad3f4dad5e68fb4c4571ed70e4735a407a4.zip
sys-libs/libunwind: Add release candidate for testing (only) on riscv
Closes: https://bugs.gentoo.org/802501 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Huettel <dilfridge@gentoo.org>
Diffstat (limited to 'sys-libs/libunwind')
-rw-r--r--sys-libs/libunwind/Manifest1
-rw-r--r--sys-libs/libunwind/libunwind-1.6.0_rc2.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/sys-libs/libunwind/Manifest b/sys-libs/libunwind/Manifest
index f7df915b2768..a755df1496a0 100644
--- a/sys-libs/libunwind/Manifest
+++ b/sys-libs/libunwind/Manifest
@@ -1 +1,2 @@
DIST libunwind-1.5.0.tar.gz 878355 BLAKE2B ee35441289926ac22a58bedb9f831d8e13bacd663a99b3ce25eed229f25f0423bbbd90e09e3d62b003518d7a620aa6d15b0dd5b93632736a89fa0667b35d5fc2 SHA512 1df20ca7a8cee2f2e61294fa9b677e88fec52e9d5a329f88d05c2671c69fa462f6c18808c97ca9ff664ef57292537a844f00b18d142b1938c9da701ca95a4bab
+DIST libunwind-1.6.0-rc2.tar.gz 900974 BLAKE2B bbf88b6eb0ddf1371a8d69904e7763d2b2892641f88ed985f342962de7b2d19b6201f84422252aa5ca3d6beed7b3af0e2fe1fdb603497dbe68215ebc94942074 SHA512 7b3933c4693595a85182cc11d24527c5ccda3c3af115a3947bdc9877ecb4a77659a2196f559112868b36cd2cdc5623cabef68ad519fd4017c510ee375b97cbe9
diff --git a/sys-libs/libunwind/libunwind-1.6.0_rc2.ebuild b/sys-libs/libunwind/libunwind-1.6.0_rc2.ebuild
new file mode 100644
index 000000000000..2c27a4785c80
--- /dev/null
+++ b/sys-libs/libunwind/libunwind-1.6.0_rc2.ebuild
@@ -0,0 +1,102 @@
+# Copyright 2005-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=${PV/_/-}
+MY_P=${PN}-${MY_PV}
+inherit autotools flag-o-matic libtool multilib-minimal
+
+DESCRIPTION="Portable and efficient API to determine the call-chain of a program"
+HOMEPAGE="https://savannah.nongnu.org/projects/libunwind"
+SRC_URI="mirror://nongnu/libunwind/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/8" # libunwind.so.8
+#KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv -sparc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~riscv"
+IUSE="debug debug-frame doc libatomic lzma static-libs zlib"
+
+RESTRICT="test" # some tests are broken (toolchain version dependent, rely on external binaries)
+
+# We just use the header from libatomic.
+RDEPEND="
+ lzma? ( app-arch/xz-utils[static-libs?,${MULTILIB_USEDEP}] )
+ zlib? ( sys-libs/zlib[static-libs?,${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ libatomic? ( dev-libs/libatomic_ops[${MULTILIB_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/libunwind.h
+
+ # see libunwind.h for the full list of arch-specific headers
+ /usr/include/libunwind-aarch64.h
+ /usr/include/libunwind-arm.h
+ /usr/include/libunwind-hppa.h
+ /usr/include/libunwind-ia64.h
+ /usr/include/libunwind-mips.h
+ /usr/include/libunwind-ppc32.h
+ /usr/include/libunwind-ppc64.h
+ /usr/include/libunwind-riscv.h
+ /usr/include/libunwind-sh.h
+ /usr/include/libunwind-tilegx.h
+ /usr/include/libunwind-x86.h
+ /usr/include/libunwind-x86_64.h
+)
+
+PATCHES=(
+ # needs refresh:
+ #"${FILESDIR}"/${PN}-1.2.1-only-include-execinfo_h-if-avaliable.patch
+)
+
+src_prepare() {
+ default
+ chmod +x src/ia64/mk_cursor_i || die
+ # Since we have tests disabled via RESTRICT, disable building in the subdir
+ # entirely. This works around some build errors too. #484846
+ sed -i -e '/^SUBDIRS/s:tests::' Makefile.in || die
+
+ elibtoolize
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # --enable-cxx-exceptions: always enable it, headers provide the interface
+ # and on some archs it is disabled by default causing a mismatch between the
+ # API and the ABI, bug #418253
+ # conservative-checks: validate memory addresses before use; as of 1.0.1,
+ # only x86_64 supports this, yet may be useful for debugging, couple it with
+ # debug useflag.
+ ECONF_SOURCE="${S}" \
+ ac_cv_header_atomic_ops_h=$(usex libatomic) \
+ econf \
+ --enable-cxx-exceptions \
+ --enable-coredump \
+ --enable-ptrace \
+ --enable-setjmp \
+ $(use_enable debug-frame) \
+ $(use_enable doc documentation) \
+ $(use_enable lzma minidebuginfo) \
+ $(use_enable static-libs static) \
+ $(use_enable zlib zlibdebuginfo) \
+ $(use_enable debug conservative_checks) \
+ $(use_enable debug)
+}
+
+multilib_src_compile() {
+ # Bug 586208
+ CCACHE_NODIRECT=1 default
+}
+
+multilib_src_test() {
+ # Explicitly allow parallel build of tests.
+ # Sandbox causes some tests to freak out.
+ SANDBOX_ON=0 emake check
+}
+
+multilib_src_install_all() {
+ find "${D}" -name "*.la" -type f -delete || die
+}