summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-10-06 15:15:17 +0200
committerMichał Górny <mgorny@gentoo.org>2016-10-06 15:29:01 +0200
commitd55b86576b619fe136ae363749da5b9a873fe48a (patch)
treef07d71779dcf1597c3681653d1f26657ae6bb2ce /sys-libs
parentsys-libs/libcxxabi: Pass libunwind include & (fake) src path, #596340 (diff)
downloadgentoo-d55b86576b619fe136ae363749da5b9a873fe48a.tar.gz
gentoo-d55b86576b619fe136ae363749da5b9a873fe48a.tar.bz2
gentoo-d55b86576b619fe136ae363749da5b9a873fe48a.zip
sys-libs/libcxxabi: Fix running tests against ext libunwind
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcxxabi/files/libcxxabi-3.9.0-test-unwind.patch37
-rw-r--r--sys-libs/libcxxabi/libcxxabi-3.9.0.ebuild2
2 files changed, 39 insertions, 0 deletions
diff --git a/sys-libs/libcxxabi/files/libcxxabi-3.9.0-test-unwind.patch b/sys-libs/libcxxabi/files/libcxxabi-3.9.0-test-unwind.patch
new file mode 100644
index 000000000000..1005cb7d133e
--- /dev/null
+++ b/sys-libs/libcxxabi/files/libcxxabi-3.9.0-test-unwind.patch
@@ -0,0 +1,37 @@
+From fff85c801ae564a09479e1e8e4cf81977536c550 Mon Sep 17 00:00:00 2001
+From: Petr Hosek <phosek@chromium.org>
+Date: Mon, 8 Aug 2016 22:09:54 +0000
+Subject: [PATCH] Do not depend on unwind when building standalone
+
+When libcxxabi is being built standalone, unwind dependency is not
+available, so do not use it even when LLVM unwinder is being
+requested.
+
+Differential Revision: https://reviews.llvm.org/D23228
+
+git-svn-id: https://llvm.org/svn/llvm-project/libcxxabi/trunk@278058 91177308-0d34-0410-b5e6-96231b3b80d8
+---
+ test/CMakeLists.txt | 7 +++----
+ 1 file changed, 3 insertions(+), 4 deletions(-)
+
+diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
+index 31b5d1d..3a489bf 100644
+--- a/test/CMakeLists.txt
++++ b/test/CMakeLists.txt
+@@ -36,10 +36,9 @@ endif()
+
+ if (NOT LIBCXXABI_BUILT_STANDALONE)
+ list(APPEND LIBCXXABI_TEST_DEPS cxx)
+-endif()
+-
+-if (LIBCXXABI_USE_LLVM_UNWINDER)
+- list(APPEND LIBCXXABI_TEST_DEPS unwind)
++ if (LIBCXXABI_USE_LLVM_UNWINDER)
++ list(APPEND LIBCXXABI_TEST_DEPS unwind)
++ endif()
+ endif()
+
+ add_lit_testsuite(check-libcxxabi "Running libcxxabi tests"
+--
+2.10.1
+
diff --git a/sys-libs/libcxxabi/libcxxabi-3.9.0.ebuild b/sys-libs/libcxxabi/libcxxabi-3.9.0.ebuild
index a74a53d98e9f..48c45199c980 100644
--- a/sys-libs/libcxxabi/libcxxabi-3.9.0.ebuild
+++ b/sys-libs/libcxxabi/libcxxabi-3.9.0.ebuild
@@ -48,6 +48,8 @@ src_prepare() {
# backport cmake path fix for llvm-3.9+
eapply "${FILESDIR}/${P}-cmake-path.patch"
+ # kill stray unwind test dep in stand-alone builds
+ eapply "${FILESDIR}/${P}-test-unwind.patch"
}
src_configure() {