summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-24 00:03:08 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-24 00:04:21 +0100
commit0d430b51102b30ae55acf289fabca0cfcabaceed (patch)
tree5b55435dc2105db3ec4801e9d6b22379ad2a7611 /sys-process
parentsys-kernel/gentoo-sources: Linux patch 5.0.4 (diff)
downloadgentoo-0d430b51102b30ae55acf289fabca0cfcabaceed.tar.gz
gentoo-0d430b51102b30ae55acf289fabca0cfcabaceed.tar.bz2
gentoo-0d430b51102b30ae55acf289fabca0cfcabaceed.zip
sys-process/tiptop: Fixed build with sys-libs/ncurses[tinfo]
Closes: https://bugs.gentoo.org/618124 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/tiptop/files/tiptop-2.3.1-tinfo.patch12
-rw-r--r--sys-process/tiptop/tiptop-2.3.1.ebuild21
2 files changed, 29 insertions, 4 deletions
diff --git a/sys-process/tiptop/files/tiptop-2.3.1-tinfo.patch b/sys-process/tiptop/files/tiptop-2.3.1-tinfo.patch
new file mode 100644
index 000000000000..0f6c3c740a1e
--- /dev/null
+++ b/sys-process/tiptop/files/tiptop-2.3.1-tinfo.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/618124
+
+--- tiptop-2.3.1/configure.ac
++++ tiptop-2.3.1/configure.ac
+@@ -24,6 +24,7 @@
+ AC_DEFINE([HAVE_LIBCURSES], [1], [Define to 1 if you have the `curses' library (-lcurses).])
+ LIBS="-lcurses $LIBS"],
+ [have_curses=no])
++AC_CHECK_LIB([tinfo], [keypad], LIBS="-ltinfo $LIBS")
+ fi
+
+ if test ! x$disable_libxml2 = xno; then # check only if not disabled
diff --git a/sys-process/tiptop/tiptop-2.3.1.ebuild b/sys-process/tiptop/tiptop-2.3.1.ebuild
index 0f5fd18600fe..fcbc8c638170 100644
--- a/sys-process/tiptop/tiptop-2.3.1.ebuild
+++ b/sys-process/tiptop/tiptop-2.3.1.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
+inherit autotools
DESCRIPTION="top for performance counters"
HOMEPAGE="http://tiptop.gforge.inria.fr/"
@@ -12,6 +14,17 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND="sys-libs/ncurses
- dev-libs/libxml2"
+RDEPEND="
+ sys-libs/ncurses:0=
+ dev-libs/libxml2:=
+"
DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.3.1-tinfo.patch #618124
+)
+
+src_prepare() {
+ default
+ eautoreconf #618124
+}