summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-04-27 05:38:41 -0500
committerMike Gilbert <floppym@gentoo.org>2018-05-18 11:59:13 -0400
commit92fcc2d2d6ac4294bb9576bbd18b57707a96e73d (patch)
treeb97be54629396556dab1c598f6e102cd57ea6db9 /sys-process
parentsys-devel/gnuconfig: git-2->git-r3 (diff)
downloadgentoo-92fcc2d2d6ac4294bb9576bbd18b57707a96e73d.tar.gz
gentoo-92fcc2d2d6ac4294bb9576bbd18b57707a96e73d.tar.bz2
gentoo-92fcc2d2d6ac4294bb9576bbd18b57707a96e73d.zip
sys-process/numad: git-2->git-r3
Upstream git repo moved to pagure.io; the release files are being pulled from our distfile mirrors anyways. Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/numad/numad-0.5-r1.ebuild16
-rw-r--r--sys-process/numad/numad-0.5-r2.ebuild12
-rw-r--r--sys-process/numad/numad-0.5.ebuild21
-rw-r--r--sys-process/numad/numad-9999.ebuild11
4 files changed, 20 insertions, 40 deletions
diff --git a/sys-process/numad/numad-0.5-r1.ebuild b/sys-process/numad/numad-0.5-r1.ebuild
index e74988408220..6b1dd22c7efb 100644
--- a/sys-process/numad/numad-0.5-r1.ebuild
+++ b/sys-process/numad/numad-0.5-r1.ebuild
@@ -5,14 +5,14 @@ EAPI=5
inherit linux-info toolchain-funcs eutils
-if [[ ${PV} = *9999* ]]; then
- inherit git-2
- EGIT_REPO_URI="git://git.fedorahosted.org/numad.git"
- KEYWORDS="~amd64 -arm -s390 x86"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://pagure.io/numad.git"
+ inherit git-r3
else
- SRC_URI="http://git.fedorahosted.org/git/?p=numad.git;a=snapshot;h=334278ff3d774d105939743436d7378a189e8693;sf=tbz2 -> numad-0.5-334278f.tar.bz2"
+ HASH="334278ff3d774d105939743436d7378a189e8693"
+ SRC_URI="mirror://gentoo/numad-0.5-${HASH:0:7}.tar.bz2"
KEYWORDS="amd64 -arm -s390 x86"
- S="${WORKDIR}/${PN}-334278f"
+ S="${WORKDIR}/${PN}-${HASH:0:7}"
fi
DESCRIPTION="The NUMA daemon that manages application locality"
@@ -31,10 +31,6 @@ src_prepare() {
tc-export CC
}
-src_configure() {
- :
-}
-
src_compile() {
emake CFLAGS="${CFLAGS} -std=gnu99"
}
diff --git a/sys-process/numad/numad-0.5-r2.ebuild b/sys-process/numad/numad-0.5-r2.ebuild
index c3cec523349a..8f4a1088b8a3 100644
--- a/sys-process/numad/numad-0.5-r2.ebuild
+++ b/sys-process/numad/numad-0.5-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -6,11 +6,11 @@ EAPI=5
inherit linux-info toolchain-funcs eutils
if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="git://git.fedorahosted.org/numad.git"
- inherit git-2
+ EGIT_REPO_URI="https://pagure.io/numad.git"
+ inherit git-r3
else
HASH="334278ff3d774d105939743436d7378a189e8693"
- SRC_URI="http://git.fedorahosted.org/git/?p=numad.git;a=snapshot;h=${HASH};sf=tbz2 -> numad-0.5-${HASH:0:7}.tar.bz2"
+ SRC_URI="mirror://gentoo/numad-0.5-${HASH:0:7}.tar.bz2"
KEYWORDS="~amd64 -arm ~arm64 -s390 ~x86"
S="${WORKDIR}/${PN}-${HASH:0:7}"
fi
@@ -30,10 +30,6 @@ src_prepare() {
tc-export CC
}
-src_configure() {
- :
-}
-
src_compile() {
emake CFLAGS="${CFLAGS} -std=gnu99"
}
diff --git a/sys-process/numad/numad-0.5.ebuild b/sys-process/numad/numad-0.5.ebuild
index e243f289db5f..926c416a8be7 100644
--- a/sys-process/numad/numad-0.5.ebuild
+++ b/sys-process/numad/numad-0.5.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=4
inherit linux-info
-if [[ ${PV} = *9999* ]]; then
- inherit git-2
- EGIT_REPO_URI="git://git.fedorahosted.org/numad.git"
- KEYWORDS="-arm -s390"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://pagure.io/numad.git"
+ inherit git-r3
else
- SRC_URI="http://git.fedorahosted.org/git/?p=numad.git;a=snapshot;h=334278ff3d774d105939743436d7378a189e8693;sf=tbz2 -> numad-0.5-334278f.tar.bz2"
+ HASH="334278ff3d774d105939743436d7378a189e8693"
+ SRC_URI="mirror://gentoo/numad-0.5-${HASH:0:7}.tar.bz2"
KEYWORDS="amd64 -arm -s390 x86"
- S="${WORKDIR}/${PN}-334278f"
+ S="${WORKDIR}/${PN}-${HASH:0:7}"
fi
DESCRIPTION="The NUMA daemon that manages application locality"
@@ -22,9 +22,6 @@ LICENSE="LGPL-2.1"
SLOT="0"
IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
-
CONFIG_CHECK="~NUMA ~CPUSETS"
src_prepare() {
@@ -32,10 +29,6 @@ src_prepare() {
epatch
}
-src_configure() {
- :
-}
-
src_install() {
emake prefix="${ED}/usr" install
}
diff --git a/sys-process/numad/numad-9999.ebuild b/sys-process/numad/numad-9999.ebuild
index c44a0fea5cb3..9b9fa1dc7518 100644
--- a/sys-process/numad/numad-9999.ebuild
+++ b/sys-process/numad/numad-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -6,8 +6,8 @@ EAPI=5
inherit linux-info toolchain-funcs eutils
if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="git://git.fedorahosted.org/numad.git"
- inherit git-2
+ EGIT_REPO_URI="https://pagure.io/numad.git"
+ inherit git-r3
else
SRC_URI=""
KEYWORDS="~amd64 ~x86 -arm -s390"
@@ -23,14 +23,9 @@ IUSE=""
CONFIG_CHECK="~NUMA ~CPUSETS"
src_prepare() {
- epatch "${FILESDIR}"/0001-Fix-man-page-directory-creation.patch
tc-export CC
}
-src_configure() {
- :
-}
-
src_compile() {
emake CFLAGS="${CFLAGS} -std=gnu99"
}