summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-02-29 16:44:30 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2016-02-29 16:44:30 -0600
commit1457583300f126ec3756ee369bf6af9c5c9d1d62 (patch)
tree9855239c9ec1c79a2642e99b059d433995ba86b8 /www-apps/icingaweb2/icingaweb2-2.2.0.ebuild
parentdev-perl/IMAP-BodyStructure: Remove old (diff)
downloadgentoo-1457583300f126ec3756ee369bf6af9c5c9d1d62.tar.gz
gentoo-1457583300f126ec3756ee369bf6af9c5c9d1d62.tar.bz2
gentoo-1457583300f126ec3756ee369bf6af9c5c9d1d62.zip
www-apps/icingaweb2: bup
Package-Manager: portage-2.2.26
Diffstat (limited to 'www-apps/icingaweb2/icingaweb2-2.2.0.ebuild')
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.2.0.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/www-apps/icingaweb2/icingaweb2-2.2.0.ebuild b/www-apps/icingaweb2/icingaweb2-2.2.0.ebuild
new file mode 100644
index 000000000000..81d827688cc8
--- /dev/null
+++ b/www-apps/icingaweb2/icingaweb2-2.2.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit depend.apache eutils multilib user
+
+DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
+HOMEPAGE="http://www.icinga.org/"
+SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="apache2 ldap mysql nginx postgres"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ dev-lang/php:5.6[apache2?,cli,gd,json,intl,ldap?,mysql?,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-php/pecl-imagick
+ apache2? ( >=www-servers/apache-2.4.0 )
+ nginx? ( >=www-servers/nginx-1.7.0:* )"
+RDEPEND="${DEPEND}"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+
+ enewgroup icingaweb2
+ enewgroup icingacmd
+ use nginx && usermod -a -G icingacmd,icingaweb2 nginx
+ use apache2 && usermod -a -G icingacmd,icingaweb2 apache2
+}
+
+pkg_config() {
+ if [[ -d /etc/icingaweb2 ]] ; then
+ einfo "Updating existing installation ..."
+ else
+ einfo "Running first time setup ..."
+ einfo "Creating configuration directory ..."
+ /usr/share/${PN}/bin/icingacli setup config directory
+ einfo "Creating authentication token for web setup ..."
+ /usr/share/${PN}/bin/icingacli setup token create
+ if use apache2 ; then
+ einfo "The following might be useful for your Apache2 configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
+ fi
+ if use nginx ; then
+ einfo "The following might be useful for your NGinx configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
+ fi
+ fi
+ einfo "All done."
+}
+
+src_install() {
+ mkdir -p "${D}/usr/share/${PN}"
+ cp -R "${S}"/* "${D}/usr/share/${PN}"
+ chmod -R a+rX "${D}/usr/share/${PN}/public"
+}
+
+pkg_postinst() {
+ einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
+}