summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-01-27 18:05:56 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-01-29 23:59:57 +0100
commitaef7c90bce140f0577c96e888545dccaba94fb86 (patch)
tree7b23f6ccf6310f4145c7f5e33d371976969277fd /www-apps
parentapp-office/moneydance: drop old version. (diff)
downloadgentoo-aef7c90bce140f0577c96e888545dccaba94fb86.tar.gz
gentoo-aef7c90bce140f0577c96e888545dccaba94fb86.tar.bz2
gentoo-aef7c90bce140f0577c96e888545dccaba94fb86.zip
www-apps/cgp: bump to version 1_p20181209.
This release adds support for PHP 7.3. Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Closes: https://github.com/gentoo/gentoo/pull/10917 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/cgp/Manifest1
-rw-r--r--www-apps/cgp/cgp-1_p20181209.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/www-apps/cgp/Manifest b/www-apps/cgp/Manifest
index cde99e2778b3..ce156d63f1ee 100644
--- a/www-apps/cgp/Manifest
+++ b/www-apps/cgp/Manifest
@@ -1 +1,2 @@
DIST cgp-1_p20180620.tar.gz 139549 BLAKE2B 2cc1a416ae1158b5788615b05bf43039049af52eb5296e7fd8136c9895e8ee0a9887e84ad37c6598a4c4387982a2860fbdb7cf9cdff39cfe5bbee598b9ace88f SHA512 acd09bb699af678347dacfc08fee60a86843874543851805f245952e538777d7ccd528c156f7a21b803503c7aac134013a4eb8200d5266cf35541b0dce5839e4
+DIST cgp-1_p20181209.tar.gz 139556 BLAKE2B 0a79ff1974b0ae50db5582121c4fdcc2db0b89ef11ecb001dfa525dd753481f0a454e424d17f24b142fd116a9ea2eeb4ba1dade6f2ffadd63943e5c065323224 SHA512 fcbf81fca2bb14ed143ea414c2f11fe09f4594891507a1ad08482720b104ec62c9986ce25b127d45a7962a8b3db54293a6775dc2359bde41f19b5419606b51eb
diff --git a/www-apps/cgp/cgp-1_p20181209.ebuild b/www-apps/cgp/cgp-1_p20181209.ebuild
new file mode 100644
index 000000000000..60438618d2f6
--- /dev/null
+++ b/www-apps/cgp/cgp-1_p20181209.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PN="${PN^^}"
+MY_PV="72acfcbffd51da1e77a56517618da68252485ed6"
+
+DESCRIPTION="A graphical web-based front-end for visualizing RRD collected by collectd"
+HOMEPAGE="https://github.com/pommi/CGP"
+SRC_URI="https://github.com/pommi/${MY_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC-BY-2.0 GPL-2+ GPL-3 MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php[json]
+ net-analyzer/rrdtool[graph]
+ virtual/httpd-php
+"
+
+need_httpd_cgi
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+DOCS=( "README.md" "doc/CHANGELOG" "doc/nginx.conf" )
+
+src_install() {
+ webapp_src_preinst
+
+ einstalldocs
+
+ # Since the docs are already installed, remove them from htdocs
+ # The file doc/CHANGELOG is needed, as CGP reads from there it's version
+ rm -r .gitignore doc/LICENSE doc/nginx.conf || die
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ einfo "The command shell_exec must not be disabled"
+ einfo "through the disable_functions php.ini directive."
+ einfo "It must allow execution of the rrdtool program."
+ einfo ""
+ einfo "An configuration file for www-servers/nginx"
+ einfo "has been installed as an example."
+}