summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-04-29 07:46:36 +0200
committerHans de Graaff <graaff@gentoo.org>2018-04-29 07:58:09 +0200
commitec1005895c016ecfe2c79605c9732095a4887992 (patch)
tree909408de8c4fb462619de6df3a26af1894fe32ad /www-servers/thin
parentmedia-libs/exiftool: remove old (diff)
downloadgentoo-ec1005895c016ecfe2c79605c9732095a4887992.tar.gz
gentoo-ec1005895c016ecfe2c79605c9732095a4887992.tar.bz2
gentoo-ec1005895c016ecfe2c79605c9732095a4887992.zip
www-servers/thin: cleanup
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'www-servers/thin')
-rw-r--r--www-servers/thin/Manifest2
-rw-r--r--www-servers/thin/thin-1.7.0-r1.ebuild88
-rw-r--r--www-servers/thin/thin-1.7.1.ebuild88
3 files changed, 0 insertions, 178 deletions
diff --git a/www-servers/thin/Manifest b/www-servers/thin/Manifest
index 9398e73fe3bc..9ffd8cf58863 100644
--- a/www-servers/thin/Manifest
+++ b/www-servers/thin/Manifest
@@ -1,3 +1 @@
-DIST thin-1.7.0.tar.gz 180791 BLAKE2B 60b703abae0c359e11f2ed3689f24a99aa5e636dcf308ed56fc9f72cbe2acefca16c456efe1ff80338020c6543a1c1647b1b7c5d5f21f173595d7caea5ebfdee SHA512 a41ffb8792f5dbc732696af4914e5121e83f21d18e5aae64676dc5d035f84c0e13d352565c5004ba7ac2e42c701522a6aa6a9250303877c3ac566c30336df2c3
-DIST thin-1.7.1.tar.gz 179998 BLAKE2B 9d046df2264c139823f8bbbff08387b95295a3a9521746103c85cbd69fdbc5de8830b9546e948dd87e742f67521d1adac7f56eaa8e151f1ec8f4de39242921e4 SHA512 7a5e3ccef263e5ba15cf53f38d7a8ae6ff974a4cfee2844cc15f9e6afb155b73b43e8c2ba49e177cad20eb9a728f4ddbe0d88417ad7f1c11ca2a535745da73ef
DIST thin-1.7.2.tar.gz 180169 BLAKE2B fe902b76cbffbad739327754c14dcc46372d412c607f852a4f52554ec8e41e38a07f211c28751b3528fd53c7eb30eb0f8130e3bc0877996187a3d755ccfbc17f SHA512 2c3c831eed4444d42fc88fc2c46e557284748b6b6bf331d6fd827073918cc3a869e5a60bf7db19ba82add28e07c8a8c92dac609a56cda82b41b37ddfb247e7bf
diff --git a/www-servers/thin/thin-1.7.0-r1.ebuild b/www-servers/thin/thin-1.7.0-r1.ebuild
deleted file mode 100644
index 48f44ec1c598..000000000000
--- a/www-servers/thin/thin-1.7.0-r1.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby21 ruby22 ruby23"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A fast and very simple Ruby web server"
-HOMEPAGE="http://code.macournoyer.com/thin/"
-SRC_URI="https://github.com/macournoyer/thin/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Ruby"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="doc test"
-
-DEPEND="${DEPEND}
- dev-util/ragel"
-RDEPEND="${RDEPEND}"
-
-# The runtime dependencies are used at build-time as well since the
-# Rakefile loads thin!
-mydeps=">=dev-ruby/daemons-1.0.9
- >=dev-ruby/rack-1.0.0:* <dev-ruby/rack-3:*
- >=dev-ruby/eventmachine-1.0.4:0
- virtual/ruby-ssl"
-
-ruby_add_rdepend "${mydeps}"
-ruby_add_bdepend "${mydeps}
- dev-ruby/rake-compiler"
-
-all_ruby_prepare() {
- # Fix Ragel-based parser generation (uses a *very* old syntax that
- # is not supported in Gentoo)
- sed -i -e 's: | rlgen-cd::' Rakefile || die
-
- # Fix specs' dependencies so that the extension is not rebuilt
- # when running tests
- rm tasks/spec.rake || die
-
- # Fix rspec version to allow newer 2.x versions
- sed -i -e '/gem "rspec"/ s/1.2.9/2.0/' spec/spec_helper.rb || die
-
- # Avoid CLEAN since it may not be available and we don't need it.
- sed -i -e '/CLEAN/ s:^:#:' tasks/*.rake || die
-
- # Disable a test that is known for freezing the testsuite,
- # reported upstream. In thin 1.5.1 this just fails.
- sed -i \
- -e '/should force kill process in pid file/,/^ end/ s:^:#:' \
- spec/daemonizing_spec.rb || die
-
- sed -i \
- -e '/tracing routines (with NO custom logger)/,/^ end/ s:^:#:'\
- spec/logging_spec.rb || die
-
- find spec/perf -name "*_spec.rb" -exec \
- sed -i '/be_faster_then/ i \ pending' {} \;
-
- sed -i -e "s/Spec::Runner/Rspec/" spec/spec_helper.rb || die
- # nasty but too complex to fix up for now :(
- use doc || rm tasks/rdoc.rake
-}
-
-each_ruby_compile() {
- ${RUBY} -S rake compile || die "rake compile failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- keepdir /etc/thin
- newinitd "${FILESDIR}"/${PN}.initd-r4 ${PN}
- newconfd "${FILESDIR}"/${PN}.confd-2 ${PN}
-
- einfo
- elog "Thin is now shipped with init scripts."
- elog "The default script (/etc/init.d/thin) will start all servers that have"
- elog "configuration files in /etc/thin/. You can symlink the init script to"
- elog "files of the format 'thin.SERVER' to be able to start individual servers."
- elog "See /etc/conf.d/thin for more configuration options."
- einfo
-}
diff --git a/www-servers/thin/thin-1.7.1.ebuild b/www-servers/thin/thin-1.7.1.ebuild
deleted file mode 100644
index b57be6e1536c..000000000000
--- a/www-servers/thin/thin-1.7.1.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby21 ruby22 ruby23"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A fast and very simple Ruby web server"
-HOMEPAGE="http://code.macournoyer.com/thin/"
-SRC_URI="https://github.com/macournoyer/thin/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Ruby"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="doc test"
-
-DEPEND="${DEPEND}
- dev-util/ragel"
-RDEPEND="${RDEPEND}"
-
-# The runtime dependencies are used at build-time as well since the
-# Rakefile loads thin!
-mydeps=">=dev-ruby/daemons-1.0.9
- >=dev-ruby/rack-1.0.0:* <dev-ruby/rack-3:*
- >=dev-ruby/eventmachine-1.0.4:0
- virtual/ruby-ssl"
-
-ruby_add_rdepend "${mydeps}"
-ruby_add_bdepend "${mydeps}
- dev-ruby/rake-compiler"
-
-all_ruby_prepare() {
- # Fix Ragel-based parser generation (uses a *very* old syntax that
- # is not supported in Gentoo)
- sed -i -e 's: | rlgen-cd::' Rakefile || die
-
- # Fix specs' dependencies so that the extension is not rebuilt
- # when running tests
- rm tasks/spec.rake || die
-
- # Fix rspec version to allow newer 2.x versions
- sed -i -e '/gem "rspec"/ s/1.2.9/2.0/' spec/spec_helper.rb || die
-
- # Avoid CLEAN since it may not be available and we don't need it.
- sed -i -e '/CLEAN/ s:^:#:' tasks/*.rake || die
-
- # Disable a test that is known for freezing the testsuite,
- # reported upstream. In thin 1.5.1 this just fails.
- sed -i \
- -e '/should force kill process in pid file/,/^ end/ s:^:#:' \
- spec/daemonizing_spec.rb || die
-
- sed -i \
- -e '/tracing routines (with NO custom logger)/,/^ end/ s:^:#:'\
- spec/logging_spec.rb || die
-
- find spec/perf -name "*_spec.rb" -exec \
- sed -i '/be_faster_then/ i \ pending' {} \;
-
- sed -i -e "s/Spec::Runner/Rspec/" spec/spec_helper.rb || die
- # nasty but too complex to fix up for now :(
- use doc || rm tasks/rdoc.rake
-}
-
-each_ruby_compile() {
- ${RUBY} -S rake compile || die "rake compile failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- keepdir /etc/thin
- newinitd "${FILESDIR}"/${PN}.initd-r4 ${PN}
- newconfd "${FILESDIR}"/${PN}.confd-2 ${PN}
-
- einfo
- elog "Thin is now shipped with init scripts."
- elog "The default script (/etc/init.d/thin) will start all servers that have"
- elog "configuration files in /etc/thin/. You can symlink the init script to"
- elog "files of the format 'thin.SERVER' to be able to start individual servers."
- elog "See /etc/conf.d/thin for more configuration options."
- einfo
-}