summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-02-13 08:55:25 -0500
committerBrian Evans <grknight@gentoo.org>2019-02-13 08:55:25 -0500
commit17d9ad2f97ea0f2067090b3e00ac2fe25ac05b08 (patch)
tree4b71a3cdbf858cbc97057a688ad3d1b77a81ce65 /www-servers
parentwww-servers/nginx-unit: release 1.7.1 (fixes CVE-2019-7401) (diff)
downloadgentoo-17d9ad2f97ea0f2067090b3e00ac2fe25ac05b08.tar.gz
gentoo-17d9ad2f97ea0f2067090b3e00ac2fe25ac05b08.tar.bz2
gentoo-17d9ad2f97ea0f2067090b3e00ac2fe25ac05b08.zip
www-servers/nginx-unit: Drop PHP 7.0 support
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx-unit/metadata.xml1
-rw-r--r--www-servers/nginx-unit/nginx-unit-1.5.ebuild5
-rw-r--r--www-servers/nginx-unit/nginx-unit-1.6.ebuild5
-rw-r--r--www-servers/nginx-unit/nginx-unit-1.7.1.ebuild3
-rw-r--r--www-servers/nginx-unit/nginx-unit-1.7.ebuild5
5 files changed, 7 insertions, 12 deletions
diff --git a/www-servers/nginx-unit/metadata.xml b/www-servers/nginx-unit/metadata.xml
index 73c93269432b..c8f76efa6ee7 100644
--- a/www-servers/nginx-unit/metadata.xml
+++ b/www-servers/nginx-unit/metadata.xml
@@ -18,7 +18,6 @@
</longdescription>
<use>
<flag name="php5-6">Support for PHP 5.6</flag>
- <flag name="php7-0">Support for PHP 7.0</flag>
<flag name="php7-1">Support for PHP 7.1</flag>
<flag name="php7-2">Support for PHP 7.2</flag>
</use>
diff --git a/www-servers/nginx-unit/nginx-unit-1.5.ebuild b/www-servers/nginx-unit/nginx-unit-1.5.ebuild
index e1eb3635fb1c..f3124ecc86f3 100644
--- a/www-servers/nginx-unit/nginx-unit-1.5.ebuild
+++ b/www-servers/nginx-unit/nginx-unit-1.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,13 +16,12 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
MY_USE="perl python ruby"
-MY_USE_PHP="php5-6 php7-0 php7-1 php7-2"
+MY_USE_PHP="php5-6 php7-1 php7-2"
IUSE="${MY_USE} ${MY_USE_PHP}"
REQUIRED_USE="|| ( ${IUSE} ) python? ( ${PYTHON_REQUIRED_USE} )"
DEPEND="perl? ( dev-lang/perl:= )
php5-6? ( dev-lang/php:5.6[embed] )
- php7-0? ( dev-lang/php:7.0[embed] )
php7-1? ( dev-lang/php:7.1[embed] )
php7-2? ( dev-lang/php:7.2[embed] )
python? ( ${PYTHON_DEPS} )
diff --git a/www-servers/nginx-unit/nginx-unit-1.6.ebuild b/www-servers/nginx-unit/nginx-unit-1.6.ebuild
index 9f7feccf3ea6..f3124ecc86f3 100644
--- a/www-servers/nginx-unit/nginx-unit-1.6.ebuild
+++ b/www-servers/nginx-unit/nginx-unit-1.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,13 +16,12 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
MY_USE="perl python ruby"
-MY_USE_PHP="php5-6 php7-0 php7-1 php7-2"
+MY_USE_PHP="php5-6 php7-1 php7-2"
IUSE="${MY_USE} ${MY_USE_PHP}"
REQUIRED_USE="|| ( ${IUSE} ) python? ( ${PYTHON_REQUIRED_USE} )"
DEPEND="perl? ( dev-lang/perl:= )
php5-6? ( dev-lang/php:5.6[embed] )
- php7-0? ( dev-lang/php:7.0[embed] )
php7-1? ( dev-lang/php:7.1[embed] )
php7-2? ( dev-lang/php:7.2[embed] )
python? ( ${PYTHON_DEPS} )
diff --git a/www-servers/nginx-unit/nginx-unit-1.7.1.ebuild b/www-servers/nginx-unit/nginx-unit-1.7.1.ebuild
index 2bdb537bb530..f3124ecc86f3 100644
--- a/www-servers/nginx-unit/nginx-unit-1.7.1.ebuild
+++ b/www-servers/nginx-unit/nginx-unit-1.7.1.ebuild
@@ -16,13 +16,12 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
MY_USE="perl python ruby"
-MY_USE_PHP="php5-6 php7-0 php7-1 php7-2"
+MY_USE_PHP="php5-6 php7-1 php7-2"
IUSE="${MY_USE} ${MY_USE_PHP}"
REQUIRED_USE="|| ( ${IUSE} ) python? ( ${PYTHON_REQUIRED_USE} )"
DEPEND="perl? ( dev-lang/perl:= )
php5-6? ( dev-lang/php:5.6[embed] )
- php7-0? ( dev-lang/php:7.0[embed] )
php7-1? ( dev-lang/php:7.1[embed] )
php7-2? ( dev-lang/php:7.2[embed] )
python? ( ${PYTHON_DEPS} )
diff --git a/www-servers/nginx-unit/nginx-unit-1.7.ebuild b/www-servers/nginx-unit/nginx-unit-1.7.ebuild
index 9f7feccf3ea6..f3124ecc86f3 100644
--- a/www-servers/nginx-unit/nginx-unit-1.7.ebuild
+++ b/www-servers/nginx-unit/nginx-unit-1.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,13 +16,12 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
MY_USE="perl python ruby"
-MY_USE_PHP="php5-6 php7-0 php7-1 php7-2"
+MY_USE_PHP="php5-6 php7-1 php7-2"
IUSE="${MY_USE} ${MY_USE_PHP}"
REQUIRED_USE="|| ( ${IUSE} ) python? ( ${PYTHON_REQUIRED_USE} )"
DEPEND="perl? ( dev-lang/perl:= )
php5-6? ( dev-lang/php:5.6[embed] )
- php7-0? ( dev-lang/php:7.0[embed] )
php7-1? ( dev-lang/php:7.1[embed] )
php7-2? ( dev-lang/php:7.2[embed] )
python? ( ${PYTHON_DEPS} )