summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2016-11-10 01:02:47 +0100
committerSebastian Pipping <sping@gentoo.org>2016-11-10 01:12:30 +0100
commitd30c0fdb0aea529201f98a27c111edf0530aa82f (patch)
tree065871d6a5721fcc378f14f6975d5af1edd06c30 /www-servers
parentdev-python/aiohttp: move dev-python/yarl to CDEPEND (diff)
downloadgentoo-d30c0fdb0aea529201f98a27c111edf0530aa82f.tar.gz
gentoo-d30c0fdb0aea529201f98a27c111edf0530aa82f.tar.bz2
gentoo-d30c0fdb0aea529201f98a27c111edf0530aa82f.zip
www-servers/gunicorn: 19.6.0
Package-Manager: portage-2.3.2
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/gunicorn/Manifest1
-rw-r--r--www-servers/gunicorn/gunicorn-19.6.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/www-servers/gunicorn/Manifest b/www-servers/gunicorn/Manifest
index 56abf5a075cb..d6e43acc6450 100644
--- a/www-servers/gunicorn/Manifest
+++ b/www-servers/gunicorn/Manifest
@@ -1,3 +1,4 @@
DIST gunicorn-19.1.1.tar.gz 385155 SHA256 82715511fb6246fad4ba66d812eb93416ae8371b464fa88bf3867c9c177daa14 SHA512 1b42f0dadb8ced12954e821ad3dc7fad67ae6f1123218fe79e32d7089d9ae65bcd973613c226d9a16b11d7d35632990f2c9499594c7a383a79698a1c2db471de WHIRLPOOL 29c99b33b72d00dc248adedf89517804f58ee4ee36a3c9fdddb9d65ee047dd57d381d719e1ed44b7b5284f11ac703d29f3d66fd077f996de2ab9effa8fb15fda
DIST gunicorn-19.3.0.tar.gz 395381 SHA256 8bc835082882ad9a012cd790c460011e4d96bf3512d98a04d3dabbe45393a089 SHA512 8c4e0bb1bf0b35aaf9160b9b7d87890a991451fbc86186454203f3483767858944704c1ec22dd52480ce1e4693e84b62b1428dd3b67b2ae925e0475dc08fcb50 WHIRLPOOL 7a840b5878b409d89a61dcca40632448e7b5a402b0e26ba03a65f3384a9491f06c2c69279cdfcc0013e2b6d7ee0de619d17437a60990d19f674653d29c83502a
DIST gunicorn-19.4.5.tar.gz 399066 SHA256 53b58044764ad79d732af18c580b1a54b724adf4d290ec19c4ca78ab22a1ee0d SHA512 a255178a4ce7966af5883fc6c104e7c472c87ce91861caf976b52cfb0ccd90b34109130334afa6c1f6dd251a4b33b052b1f9a4f598c5cd1e7f26e332b92e9154 WHIRLPOOL 1ee0ea3b69ab10a2afa67b237a8197ff06334ab1df6b4dd84479bbc6360094c0806ace6c64a80032921321434d83a5b8831641bda966e826a5c8e3b4206eb3ac
+DIST gunicorn-19.6.0.tar.gz 404497 SHA256 813f6916d18a4c8e90efde72f419308b357692f81333cb1125f80013d22fb618 SHA512 50b69ae18acc6f60be6fc5c6f4a867d8415d32009a1f959155b58502d52403a057612e97d6c9b69ec068ee5af7b9b045952a636a5edf4713a1249492611be479 WHIRLPOOL dbe1b2e66ca0f1a19a8e235a1ca58d77cbd6f5f54d26ea9c4a4a4b2a5110a2185f3c9f378ce9297879bc4b74ba63322803b2d0a090f7b5fb669530a0e8ef1d4a
diff --git a/www-servers/gunicorn/gunicorn-19.6.0.ebuild b/www-servers/gunicorn/gunicorn-19.6.0.ebuild
new file mode 100644
index 000000000000..c1f120293951
--- /dev/null
+++ b/www-servers/gunicorn/gunicorn-19.6.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI HTTP Server for UNIX"
+HOMEPAGE="http://gunicorn.org https://pypi.python.org/pypi/gunicorn https://github.com/benoitc/gunicorn"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT PSF-2 doc? ( BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )"
+
+DOCS="README.rst"
+
+python_prepare_all() {
+ sed -ie "s/..\/bin/\/usr\/bin\//" docs/Makefile || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}