summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-07-14 07:21:22 +0200
committerHans de Graaff <graaff@gentoo.org>2018-07-14 07:21:22 +0200
commitf365a1499ac2f091c84cfe0606c0e4f77f9ce801 (patch)
tree9fc3f19535526c8984f80d062feaf13e28c630a5 /www-servers
parentwww-servers/puma: cleanup (diff)
downloadgentoo-f365a1499ac2f091c84cfe0606c0e4f77f9ce801.tar.gz
gentoo-f365a1499ac2f091c84cfe0606c0e4f77f9ce801.tar.bz2
gentoo-f365a1499ac2f091c84cfe0606c0e4f77f9ce801.zip
www-servers/puma: add 3.12.0
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/puma/Manifest1
-rw-r--r--www-servers/puma/puma-3.12.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/www-servers/puma/Manifest b/www-servers/puma/Manifest
index c3ce32748eed..f9c564c815f8 100644
--- a/www-servers/puma/Manifest
+++ b/www-servers/puma/Manifest
@@ -1,2 +1,3 @@
DIST puma-3.11.0.tar.gz 207387 BLAKE2B b95af60358a9e6877eec34b4cab80c00512e6f9c518f302d6373eee3042b4f439d655aafc719461f7d286fea565e82e6f7ad541a7b0a17d3c2f49067f3e11dd1 SHA512 55e7be6a6c8abc7c8bba4c793b9515150d989358259bbd6546cd8a52d9e6cfb0b7e20c3f813790359ae141865f991d0daadf043e884e2cbc1a1bdfabadca8a16
DIST puma-3.11.4.tar.gz 210324 BLAKE2B 16c01182f4a3adad026ab4f214945b1c5e002d2d99ef965947d982b488c3d080f50d41b175cc69181b2c953d32df6dfb63253dbd0312d594a2472f69f01aa30f SHA512 4c32c7587cab7ae0afd1e90d3de00db67fe314a700240d295303549905e3c556cba06ea41fbe6230f50328769d47272c52f9eb6460b0653fa14e336bacd120ea
+DIST puma-3.12.0.tar.gz 215213 BLAKE2B 1b142e6cc135021eccb01b2e8643d8d22f1c535723a943ae996c6607c7e771d8990ae2132fa2aad8ea44eceaf8c8f586fbb3d61a9aa2963a02d9f54c76773f5e SHA512 e8f0383de24e452735dddaf80e997cc428af2de767be31db6b47fdd5d09268fcb7ca139233311dda83c7a70db6646109e04308c076ac2bf2510766791171ddc5
diff --git a/www-servers/puma/puma-3.12.0.ebuild b/www-servers/puma/puma-3.12.0.ebuild
new file mode 100644
index 000000000000..cba158bd16e8
--- /dev/null
+++ b/www-servers/puma/puma-3.12.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="a simple, fast, threaded, and highly concurrent HTTP 1.1 server for Ruby/Rack"
+HOMEPAGE="https://puma.io/"
+SRC_URI="https://github.com/puma/puma/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~x86"
+IUSE=""
+
+DEPEND+=" dev-libs/openssl:0 test? ( net-misc/curl )"
+RDEPEND+=" dev-libs/openssl:0"
+
+ruby_add_bdepend "virtual/ruby-ssl
+ test? ( dev-ruby/rack >=dev-ruby/minitest-5.9:5 >=dev-ruby/test-unit-3.0:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' test/helper.rb || die
+
+ # Avoid test failing inconsistently
+ sed -i -e '/phased_restart_via_pumactl/,/^ end/ s:^:#:' test/test_integration.rb || die
+
+ # Avoid test that trigger a bug in ruby very easily and lead to
+ # failure. This affects all current puma versions in combination
+ # with the latest ruby versions, so we add this new version anyway
+ # while allowing these tests to fail.
+ # https://github.com/puma/puma/pull/1345
+ rm -f test/test_{persistent,puma_server,puma_server_ssl}.rb || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby -rubygems:'${RUBY}' -rubygems:' \
+ -e 's/localhost/127.0.0.1/' test/shell/* || die
+ sed -i -e '1ilog_requests' test/shell/t{1,2}_conf.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/puma_http11 extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/puma_http11
+ cp ext/puma_http11/puma_http11$(get_modname) lib/puma/ || die
+}
+
+each_ruby_test() {
+ einfo "Running test suite"
+ ${RUBY} -Ilib:.:test -e "gem 'minitest', '~>5.9'; gem 'test-unit', '~>3.0'; require 'minitest/autorun'; Dir['test/**/*test_*.rb'].each{|f| require f}" || die
+
+ einfo "Running integration tests"
+ pushd test/shell
+ #sh run.sh || die
+ popd
+}