summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-05-28 20:53:06 -0700
committerMatt Turner <mattst88@gentoo.org>2018-05-28 20:53:49 -0700
commit6a1e7d5719bb3c29707af3fb40cb3b12642f0617 (patch)
tree6caaf6866982b232dfe6f0ba8a6010e6ea18829c /x11-drivers/xf86-input-synaptics
parentwww-client/chromium: beta channel bump (67.0.3396.56) (diff)
downloadgentoo-6a1e7d5719bb3c29707af3fb40cb3b12642f0617.tar.gz
gentoo-6a1e7d5719bb3c29707af3fb40cb3b12642f0617.tar.bz2
gentoo-6a1e7d5719bb3c29707af3fb40cb3b12642f0617.zip
x11-drivers/xf86-input-synaptics: Version bump 1.9.1
Diffstat (limited to 'x11-drivers/xf86-input-synaptics')
-rw-r--r--x11-drivers/xf86-input-synaptics/Manifest1
-rw-r--r--x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-synaptics/Manifest b/x11-drivers/xf86-input-synaptics/Manifest
index 309e1b413da3..ee51ca2ae5ca 100644
--- a/x11-drivers/xf86-input-synaptics/Manifest
+++ b/x11-drivers/xf86-input-synaptics/Manifest
@@ -1 +1,2 @@
DIST xf86-input-synaptics-1.9.0.tar.bz2 501814 BLAKE2B 7720136dba4e3cb76d21a9624e7e684bc09e22ebd0bc3b53fb170bbfebc29133dcfb471df326ac7b2eec1e4d3e2a3eeef56e57f649ddcc8f4d5e66eba9bd28e8 SHA512 71171ce59136b1c85764d412f9039d6252c94bb2ba44c8c6348aef6509d12219ea17a026440b0e18d26f4d7853d4ca5713eb2404d39deebb8be82886ad57bad4
+DIST xf86-input-synaptics-1.9.1.tar.bz2 503722 BLAKE2B 5ff2f792d187ff0f3fabb1ee194f4eae1397d993627ef3a74b1c838cd611fc2834c6453b57d0dc27d7a6e0bc69b717eb1cb76c87833dd1c66b1af5ac824e1d55 SHA512 978eddd456aa7361047bc3d72e5127b24b13de29b0dddb6a0acc9f9da93931baa2b22fb5d1e6be164f629a11e5d97d753b835426435396b45b1af5eb8d546c3f
diff --git a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.1.ebuild b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.1.ebuild
new file mode 100644
index 000000000000..f9182bd3397a
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Synaptics touchpads"
+HOMEPAGE="https://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/"
+
+KEYWORDS="amd64 arm ~mips ppc ppc64 x86"
+IUSE="kernel_linux"
+
+RDEPEND="kernel_linux? ( >=dev-libs/libevdev-0.4 )
+ >=x11-base/xorg-server-1.14
+ >=x11-libs/libXi-1.2
+ >=x11-libs/libXtst-1.1.0"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.37
+ x11-base/xorg-proto"
+
+DOCS=( "README" )
+
+pkg_pretend() {
+ linux-info_pkg_setup
+ # Just a friendly warning
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "This driver requires event interface support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ echo
+ fi
+}