summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2019-02-08 17:50:33 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2019-02-08 17:50:55 +0100
commit41203ca4f7c29d28869c40c71f0ad579ddf080b0 (patch)
tree94db4cbd021262b76558ac2d086469b1b4e14ef8 /x11-misc/colord
parentx11-wm/icewm: Removed old. (diff)
downloadgentoo-41203ca4f7c29d28869c40c71f0ad579ddf080b0.tar.gz
gentoo-41203ca4f7c29d28869c40c71f0ad579ddf080b0.tar.bz2
gentoo-41203ca4f7c29d28869c40c71f0ad579ddf080b0.zip
x11-misc/colord: version bump to 1.3.5
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'x11-misc/colord')
-rw-r--r--x11-misc/colord/Manifest1
-rw-r--r--x11-misc/colord/colord-1.3.5.ebuild161
2 files changed, 162 insertions, 0 deletions
diff --git a/x11-misc/colord/Manifest b/x11-misc/colord/Manifest
index 8413f9c42425..74d5657adae5 100644
--- a/x11-misc/colord/Manifest
+++ b/x11-misc/colord/Manifest
@@ -1 +1,2 @@
DIST colord-1.3.4.tar.xz 1259256 BLAKE2B 08e8ab5dfb9ed76078f8eb7191900109ccbb7dc3eec41d6baaa7e59998488de3062c34894a802d993ab76a2c3d9bdec3a5e07ceec441e5bb5333f2af3c3d3eb8 SHA512 5556cc12cc72bceefd075274a1734b884e88b1a0777f7efde15118cf5d1597aa12c44680bc814dd230f39f39c9ea2dd309bc79170b19ca782488b90cda631937
+DIST colord-1.3.5.tar.xz 1263488 BLAKE2B de70f3f76e81d3cec826f444e4c6a1603c03b7d97fedcd04a0b9e1977d1e487d7e1327c8b2738b3cf74e9717fb6803d543786c749d3a244faa1a6480e77e3436 SHA512 a0084ad2c08ae88c8023b8bade68f6cf25e13c77a6a37ef127b2914e86b06e6a7a783f9ab3585243d975dbbe1120d5daae13bdb586aefe519bf675458683025f
diff --git a/x11-misc/colord/colord-1.3.5.ebuild b/x11-misc/colord/colord-1.3.5.ebuild
new file mode 100644
index 000000000000..e4b2be75c428
--- /dev/null
+++ b/x11-misc/colord/colord-1.3.5.ebuild
@@ -0,0 +1,161 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+VALA_USE_DEPEND="vapigen"
+
+inherit autotools bash-completion-r1 check-reqs gnome2 user systemd udev vala multilib-minimal
+
+DESCRIPTION="System service to accurately color manage input and output devices"
+HOMEPAGE="https://www.freedesktop.org/software/colord/"
+SRC_URI="https://www.freedesktop.org/software/colord/releases/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0/2" # subslot = libcolord soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+# We prefer policykit enabled by default, bug #448058
+IUSE="argyllcms examples extra-print-profiles +gusb +introspection +policykit scanner systemd +udev vala"
+REQUIRED_USE="
+ gusb? ( udev )
+ scanner? ( udev )
+ vala? ( introspection )
+"
+
+COMMON_DEPEND="
+ dev-db/sqlite:3=[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.44.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/lcms-2.6:2=[${MULTILIB_USEDEP}]
+ argyllcms? ( media-gfx/argyllcms )
+ gusb? ( >=dev-libs/libgusb-0.2.7[introspection?,${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.8:= )
+ policykit? ( >=sys-auth/polkit-0.104 )
+ scanner? (
+ media-gfx/sane-backends
+ sys-apps/dbus )
+ systemd? ( >=sys-apps/systemd-44:0= )
+ udev? (
+ virtual/udev
+ virtual/libgudev:=[${MULTILIB_USEDEP}]
+ virtual/libudev:=[${MULTILIB_USEDEP}]
+ )
+"
+RDEPEND="${COMMON_DEPEND}
+ !media-gfx/shared-color-profiles
+ !<=media-gfx/colorhug-client-0.1.13
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.35
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ extra-print-profiles? ( media-gfx/argyllcms )
+ vala? ( $(vala_depend) )
+"
+
+# FIXME: needs pre-installed dbus service files
+RESTRICT="test"
+
+# According to upstream comment in colord.spec.in, building the extra print
+# profiles requires >=4G of memory
+CHECKREQS_MEMORY="4G"
+
+pkg_pretend() {
+ use extra-print-profiles && check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+ use extra-print-profiles && check-reqs_pkg_setup
+ enewgroup colord
+ enewuser colord -1 -1 /var/lib/colord colord
+}
+
+src_prepare() {
+ # Adapt to Gentoo paths
+ sed -i -e 's/spotread/argyll-spotread/' \
+ src/sensors/cd-sensor-argyll.c \
+ configure.ac || die
+
+ eautoreconf
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ # Reverse tools require gusb
+ # bash-completion test does not work on gentoo
+ local myconf=(
+ --disable-bash-completion
+ --disable-examples
+ --disable-static
+ --enable-libcolordcompat
+ --with-daemon-user=colord
+ --localstatedir="${EPREFIX}"/var
+ $(multilib_native_use_enable argyllcms argyllcms-sensor)
+ $(multilib_native_use_enable extra-print-profiles print-profiles)
+ $(multilib_native_usex extra-print-profiles COLPROF="$(type -P argyll-colprof)" "")
+ $(use_enable gusb)
+ $(multilib_native_use_enable gusb reverse)
+ $(multilib_native_use_enable introspection)
+ $(multilib_native_use_enable policykit polkit)
+ $(multilib_native_use_enable scanner sane)
+ $(multilib_native_use_enable systemd systemd-login)
+ $(use_enable udev)
+ --with-udevrulesdir="$(get_udevdir)"/rules.d
+ $(multilib_native_use_enable vala)
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ )
+
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure "${myconf[@]}"
+}
+
+multilib_src_compile() {
+ if multilib_is_native_abi; then
+ gnome2_src_compile
+ else
+ emake -C lib/colord
+ use gusb && emake -C lib/colorhug
+ emake -C lib/compat
+ fi
+}
+
+multilib_src_test() {
+ if multilib_is_native_abi; then
+ default
+ else
+ emake -C lib/colord check
+ use gusb && emake -C lib/colorhug check
+ emake -C lib/compat check
+ fi
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi; then
+ gnome2_src_install
+ else
+ gnome2_src_install -j1 -C lib/colord
+ use gusb && gnome2_src_install -j1 -C lib/colorhug
+ gnome2_src_install -j1 -C lib/compat
+ gnome2_src_install -j1 -C contrib/session-helper install-libcolord_includeHEADERS
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ newbashcomp data/colormgr colormgr
+
+ # Ensure config and profile directories exist and /var/lib/colord/*
+ # is writable by colord user
+ keepdir /var/lib/color{,d}/icc
+ fowners colord:colord /var/lib/colord{,/icc}
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*.c
+ fi
+}