summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2015-10-18 22:13:12 +0200
committerSebastian Pipping <sping@gentoo.org>2015-10-18 22:16:01 +0200
commit6e209695817201565a08d8661b6fae31147f2cad (patch)
tree4ad8af4ce2b4fdeb3599fdc6b51575224b16abcc /x11-misc/fireflies
parentsci-geosciences/josm: Remove version 5485 (diff)
downloadgentoo-6e209695817201565a08d8661b6fae31147f2cad.tar.gz
gentoo-6e209695817201565a08d8661b6fae31147f2cad.tar.bz2
gentoo-6e209695817201565a08d8661b6fae31147f2cad.zip
x11-misc/fireflies: Install helper to /usr/bin rather than /usr/lib (bug #563206)
Package-Manager: portage-2.2.23
Diffstat (limited to 'x11-misc/fireflies')
-rw-r--r--x11-misc/fireflies/fireflies-2.08-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/fireflies/fireflies-2.08-r1.ebuild b/x11-misc/fireflies/fireflies-2.08-r1.ebuild
new file mode 100644
index 000000000000..0484e4a4c9c3
--- /dev/null
+++ b/x11-misc/fireflies/fireflies-2.08-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools multilib
+
+DESCRIPTION="Fireflies screensaver: Wicked cool eye candy"
+HOMEPAGE="https://github.com/mpcomplete/fireflies"
+SRC_URI="https://github.com/mpcomplete/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 icu"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl
+ virtual/glu
+ virtual/opengl
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ sys-devel/autoconf-archive" # for AX_CXX_BOOL macro
+
+DOCS=( ChangeLog README.md TODO )
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-confdir=/usr/share/xscreensaver/config \
+ --with-bindir="/usr/$(get_libdir)/misc/xscreensaver"
+}
+
+src_install() {
+ newbin {,${PN}-}add-xscreensaver
+
+ default
+}