summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-02-19 10:34:03 +0200
committerDavid Seifert <soap@gentoo.org>2017-02-20 00:43:38 +0100
commitc6f3235327970d5a9f8e01e681fe5b44793368e1 (patch)
tree1550364d968f37bfb1fe51f1444fe3df32976a80 /x11-misc/gbase
parentx11-misc/fpm2: EAPI bump 4 -> 6 (diff)
downloadgentoo-c6f3235327970d5a9f8e01e681fe5b44793368e1.tar.gz
gentoo-c6f3235327970d5a9f8e01e681fe5b44793368e1.tar.bz2
gentoo-c6f3235327970d5a9f8e01e681fe5b44793368e1.zip
x11-misc/gbase: EAPI bump 4 -> 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/4029
Diffstat (limited to 'x11-misc/gbase')
-rw-r--r--x11-misc/gbase/gbase-0.5-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-misc/gbase/gbase-0.5-r1.ebuild b/x11-misc/gbase/gbase-0.5-r1.ebuild
new file mode 100644
index 000000000000..edb313c3868a
--- /dev/null
+++ b/x11-misc/gbase/gbase-0.5-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="a convert program for decimal, hexadecimal, octal and binary values"
+HOMEPAGE="http://www.fluxcode.net"
+SRC_URI="http://www.fluxcode.net/files/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test" #424671
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-gtk.patch )
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ dobin ${PN}
+ einstalldocs
+}