summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/nitrogen
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/nitrogen')
-rw-r--r--x11-misc/nitrogen/Manifest1
-rw-r--r--x11-misc/nitrogen/files/nitrogen-1.5.2-gold.patch16
-rw-r--r--x11-misc/nitrogen/metadata.xml5
-rw-r--r--x11-misc/nitrogen/nitrogen-1.5.2.ebuild38
4 files changed, 60 insertions, 0 deletions
diff --git a/x11-misc/nitrogen/Manifest b/x11-misc/nitrogen/Manifest
new file mode 100644
index 000000000000..a40beeac3af4
--- /dev/null
+++ b/x11-misc/nitrogen/Manifest
@@ -0,0 +1 @@
+DIST nitrogen-1.5.2.tar.gz 307356 SHA256 60a2437ce6a6c0ba44505fc8066c1973140d4bb48e1e5649f525c7b0b8bf9fd2 SHA512 f4fdafcecb946f6918220f7562a69eb5223d4303c9bf3df4adb5dedfd8d402ee4f3fd3b1692875ede545d3e03f0ca88fa475206a839bb36677fa008a33e99551 WHIRLPOOL 6295f747e1bfb98c4cc83a6ccae2f48e77ceb10b1f4e9296c168e7f3ca846df1f7ca5639b94d7cbf2aa936ea5ed2c82de6ae18e90c3a0c16fc1e61eabf9079c2
diff --git a/x11-misc/nitrogen/files/nitrogen-1.5.2-gold.patch b/x11-misc/nitrogen/files/nitrogen-1.5.2-gold.patch
new file mode 100644
index 000000000000..81f034ab7cb8
--- /dev/null
+++ b/x11-misc/nitrogen/files/nitrogen-1.5.2-gold.patch
@@ -0,0 +1,16 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -34,10 +34,11 @@
+ PKG_CHECK_MODULES(GTK2,[gtk+-2.0 >= $GTK2_VERSION])
+ PKG_CHECK_MODULES(GTKMM2, [gtkmm-2.4 >= $GTKMM2_VERSION])
+ PKG_CHECK_MODULES(GTHREAD2, [gthread-2.0 >= $GTHREAD2_VERSION])
++PKG_CHECK_MODULES(X11, x11)
+
+
+-NITROGEN_LIBS="$GLIB2_LIBS $GTK2_LIBS $GTKMM2_LIBS $GTHREAD2_LIBS"
+-NITROGEN_CFLAGS="$GLIB2_CFLAGS $GTK2_CFLAGS $GTKMM2_CFLAGS $GTHREAD2_CFLAGS"
++NITROGEN_LIBS="$GLIB2_LIBS $GTK2_LIBS $GTKMM2_LIBS $GTHREAD2_LIBS $X11_LIBS"
++NITROGEN_CFLAGS="$GLIB2_CFLAGS $GTK2_CFLAGS $GTKMM2_CFLAGS $GTHREAD2_CFLAGS $X11_CFLAGS"
+
+ dnl do some autotools picen to get inotify
+ AC_ARG_ENABLE(inotify, [ --disable-inotify disable support for inotify watching of dirs (default: enabled)], [enable_inotify=$enableval],[enable_inotify=yes])
diff --git a/x11-misc/nitrogen/metadata.xml b/x11-misc/nitrogen/metadata.xml
new file mode 100644
index 000000000000..540f810e069d
--- /dev/null
+++ b/x11-misc/nitrogen/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>
diff --git a/x11-misc/nitrogen/nitrogen-1.5.2.ebuild b/x11-misc/nitrogen/nitrogen-1.5.2.ebuild
new file mode 100644
index 000000000000..78a895c2b093
--- /dev/null
+++ b/x11-misc/nitrogen/nitrogen-1.5.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="A background browser and setter for X"
+HOMEPAGE="http://projects.l3ib.org/nitrogen/"
+SRC_URI="http://projects.l3ib.org/${PN}/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls xinerama"
+
+RDEPEND=">=dev-cpp/gtkmm-2.10:2.4
+ >=gnome-base/librsvg-2.20:2
+ >=x11-libs/gtk+-2.10:2
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-proto/xineramaproto )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gold.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable nls) \
+ $(use_enable xinerama)
+}
+
+DOCS=( AUTHORS ChangeLog NEWS README )