summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/notify-osd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/notify-osd')
-rw-r--r--x11-misc/notify-osd/Manifest1
-rw-r--r--x11-misc/notify-osd/metadata.xml11
-rw-r--r--x11-misc/notify-osd/notify-osd-0.9.34.ebuild64
3 files changed, 76 insertions, 0 deletions
diff --git a/x11-misc/notify-osd/Manifest b/x11-misc/notify-osd/Manifest
new file mode 100644
index 000000000000..2c39fb9c113f
--- /dev/null
+++ b/x11-misc/notify-osd/Manifest
@@ -0,0 +1 @@
+DIST notify-osd-0.9.34.tar.gz 635387 SHA256 12080deeaa5e1e10b420117351c2bd5db3421b0d1efcab8ee8052c808c3aaa3c SHA512 60ca63c2041f129d5139537242c2260908cedef633df977a608e19dcb01b75b2280ec80abe2b6da5eff76621107ee9d294742abfae301bc24eaa3aa855c56ce1 WHIRLPOOL 3a1aa26ed5276e6cfe2501585effb8825bfde56cadb7a264ebf084a60f520e423498073c86ecce6621599f8c7d383962d0a40f1096c5afb8830a91c5e821171e
diff --git a/x11-misc/notify-osd/metadata.xml b/x11-misc/notify-osd/metadata.xml
new file mode 100644
index 000000000000..650c2a2edb1f
--- /dev/null
+++ b/x11-misc/notify-osd/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ayatana</herd>
+ <maintainer>
+ <email>ayatana-bugs@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">notify-osd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/notify-osd/notify-osd-0.9.34.ebuild b/x11-misc/notify-osd/notify-osd-0.9.34.ebuild
new file mode 100644
index 000000000000..5943c617e485
--- /dev/null
+++ b/x11-misc/notify-osd/notify-osd-0.9.34.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools gnome2-utils multilib savedconfig
+
+DESCRIPTION="Canonical's on-screen-display notification agent"
+HOMEPAGE="http://launchpad.net/notify-osd"
+SRC_URI="http://launchpad.net/${PN}/precise/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal"
+
+COMMON_DEPEND=">=dev-libs/dbus-glib-0.98
+ >=dev-libs/glib-2.16
+ >=x11-libs/gtk+-3.2:3
+ >=x11-libs/libnotify-0.7
+ >=x11-libs/libwnck-3
+ x11-libs/libX11
+ x11-libs/pixman
+ !x11-misc/notification-daemon
+ !x11-misc/qtnotifydaemon"
+RDEPEND="${COMMON_DEPEND}
+ !minimal? ( x11-themes/notify-osd-icons )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ gnome-base/gnome-common
+ x11-proto/xproto"
+
+RESTRICT="test" # virtualx.eclass: 1 of 1: FAIL: test-modules
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_prepare() {
+ sed -i -e 's:noinst_PROG:check_PROG:' tests/Makefile.am || die
+ restore_config src/{bubble,defaults,dnd}.c #428134
+ eautoreconf
+}
+
+src_configure() {
+ econf --libexecdir=/usr/$(get_libdir)/${PN}
+}
+
+src_install() {
+ default
+ save_config src/{bubble,defaults,dnd}.c
+ rm -f "${ED}"/usr/share/${PN}/icons/*/*/*/README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}