summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-03-21 21:43:26 +0100
committerJeroen Roovers <jer@gentoo.org>2018-03-21 21:44:19 +0100
commit3fed9abfd7e2b4b94c17d50410aab10b81c5aa76 (patch)
treebca820ffe1f4b5b9c614153054154c60d881810d /x11-misc/rofi
parentdev-python/ipython: add ~arm, bug #604532 (diff)
downloadgentoo-3fed9abfd7e2b4b94c17d50410aab10b81c5aa76.tar.gz
gentoo-3fed9abfd7e2b4b94c17d50410aab10b81c5aa76.tar.bz2
gentoo-3fed9abfd7e2b4b94c17d50410aab10b81c5aa76.zip
x11-misc/rofi: Version 1.5.1.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'x11-misc/rofi')
-rw-r--r--x11-misc/rofi/Manifest1
-rw-r--r--x11-misc/rofi/rofi-1.5.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/x11-misc/rofi/Manifest b/x11-misc/rofi/Manifest
index f99cfa182df7..9f2b9aa50d69 100644
--- a/x11-misc/rofi/Manifest
+++ b/x11-misc/rofi/Manifest
@@ -1,3 +1,4 @@
DIST rofi-1.3.1.tar.xz 211732 BLAKE2B 60a217a47c547b1e59632356f4ddcb37144364a990974cbc013c53b21eae04e9568cc39e2ba6d2ea681501582910fb685bcb865cf011be0b2f00d986f4317c3e SHA512 a96c53ad268883277c4ff0ee3267ff7fab4d4a93a982019ce19ea82771b65c32d56216d777494853bffd18481400af72ed777f88cce4b26d7d1b8980a997f6c6
DIST rofi-1.4.2.tar.xz 339316 BLAKE2B f35bd60fb490ca9158a4b022bd972169626634adc1fa386b3b37e63497004d2fb0d85a711c4f4f7f377c377188ecc578de78c0c70bf21e086bc59c809a69bd05 SHA512 9f6cdde4b169c9f5471eb40cca9ce65ee2e87f541b0a9e48ce5ccc61d65930befbf152af667436a9142b36ba40c2be17c1aacc90deeff70e7f40dcaa1f9a9c8f
DIST rofi-1.5.0.tar.xz 354232 BLAKE2B 2478902542b994ba06c4d436fa9436659366e2416e1a7a3ddd9a48e84d397faff963a4ac0c1bb1011a5f8a8440d1fc257377d28f556a60dc264b29eadadf5c7e SHA512 f24f93224f38e009307912dec19182a04b36a9ac88b26a8657d853cc040e1a59837a56a3e8ff08aa34143f455b5030c73fc28ced96123f3bc7e3943582aee81c
+DIST rofi-1.5.1.tar.xz 355912 BLAKE2B 710a35ab82bf960b331431be3cc3acfb5cc27b42d7fa8b02e8c070918679b90612d89f600a6e58215bc0a08dcb60087ea37a5498fa8c4ac39d246d5967f0b314 SHA512 32074e931199ff1529ebab8fef53d339eab09843888f862953b7d661323484ebe66d820feecc42604a16bd683a5af1ec4d1a2e7f097f408efed6cfe91c4eb5ff
diff --git a/x11-misc/rofi/rofi-1.5.1.ebuild b/x11-misc/rofi/rofi-1.5.1.ebuild
new file mode 100644
index 000000000000..b1d04b298f2c
--- /dev/null
+++ b/x11-misc/rofi/rofi-1.5.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A window switcher, run dialog and dmenu replacement"
+HOMEPAGE="https://github.com/DaveDavenport/rofi/"
+SRC_URI="${HOMEPAGE}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test windowmode"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-libs/freetype
+ x11-libs/cairo[xcb]
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libxcb
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xineramaproto
+ x11-proto/xproto
+ test? ( >=dev-libs/check-0.11 )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.15.12-Werror.patch
+ "${FILESDIR}"/${PN}-1.5.0-gtk-settings-test.patch
+)
+
+src_prepare() {
+ if use test; then
+ sed -i -e 's|"/tmp/rofi-test.pid"|"'"$T"'/rofi-test.pid"|g' test/helper-pidfile.c || die
+ fi
+
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+
+ econf \
+ $(use_enable test check) \
+ $(use_enable windowmode)
+}