summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2019-06-01 00:57:38 +0300
committerMichał Górny <mgorny@gentoo.org>2019-06-01 10:15:10 +0200
commit42a1cc501b1af28a8d17413d73a4be4ef1adafcf (patch)
treeae14bcc86d7dbe490a2df2e73aed5da5c4ac4d73 /x11-misc/x11vnc
parentx11-misc/x11vnc: fix license to GPL-2+-with-openssl-exception (diff)
downloadgentoo-42a1cc501b1af28a8d17413d73a4be4ef1adafcf.tar.gz
gentoo-42a1cc501b1af28a8d17413d73a4be4ef1adafcf.tar.bz2
gentoo-42a1cc501b1af28a8d17413d73a4be4ef1adafcf.zip
x11-misc/x11vnc: use myconf array for econf args
Package-Manager: Portage-2.3.66, Repoman-2.3.11 Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Closes: https://github.com/gentoo/gentoo/pull/12071 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'x11-misc/x11vnc')
-rw-r--r--x11-misc/x11vnc/x11vnc-0.9.16-r3.ebuild30
1 files changed, 16 insertions, 14 deletions
diff --git a/x11-misc/x11vnc/x11vnc-0.9.16-r3.ebuild b/x11-misc/x11vnc/x11vnc-0.9.16-r3.ebuild
index 644cbc1fdbcf..752f08e414d2 100644
--- a/x11-misc/x11vnc/x11vnc-0.9.16-r3.ebuild
+++ b/x11-misc/x11vnc/x11vnc-0.9.16-r3.ebuild
@@ -53,21 +53,23 @@ src_prepare() {
src_configure() {
# --without-v4l because of missing video4linux 2.x support wrt #389079
- econf \
- --without-v4l \
- --without-xkeyboard \
- --without-fbpm \
- --without-dpms \
- $(use_with crypt) \
- $(use_with fbcon fbdev) \
- $(use_with ssl) \
- $(use_with ssl crypto) \
- $(use_with xcomposite) \
- $(use_with xdamage) \
- $(use_with xfixes) \
- $(use_with xinerama) \
- $(use_with xrandr) \
+ local myconf=(
+ --without-v4l
+ --without-xkeyboard
+ --without-fbpm
+ --without-dpms
+ $(use_with crypt)
+ $(use_with fbcon fbdev)
+ $(use_with ssl)
+ $(use_with ssl crypto)
+ $(use_with xcomposite)
+ $(use_with xdamage)
+ $(use_with xfixes)
+ $(use_with xinerama)
+ $(use_with xrandr)
$(use_with zeroconf avahi)
+ )
+ econf "${myconf[@]}"
}
src_install() {