summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-12-16 08:25:45 +0100
committerJeroen Roovers <jer@gentoo.org>2015-12-16 08:26:05 +0100
commit9a0652930b0d4a35a7069c67c403e24039c41a68 (patch)
tree0c75f0ab0af193e5031ade3a4a092cb034f07fb8 /x11-misc/xfe
parentx11-terms/sakura: Version bump. (diff)
downloadgentoo-9a0652930b0d4a35a7069c67c403e24039c41a68.tar.gz
gentoo-9a0652930b0d4a35a7069c67c403e24039c41a68.tar.bz2
gentoo-9a0652930b0d4a35a7069c67c403e24039c41a68.zip
x11-misc/xfe: Version bump (bug #567808 by teidakankan).
Package-Manager: portage-2.2.26
Diffstat (limited to 'x11-misc/xfe')
-rw-r--r--x11-misc/xfe/Manifest1
-rw-r--r--x11-misc/xfe/files/xfe-1.41-sn.patch14
-rw-r--r--x11-misc/xfe/xfe-1.41.ebuild75
3 files changed, 90 insertions, 0 deletions
diff --git a/x11-misc/xfe/Manifest b/x11-misc/xfe/Manifest
index 3c4e472dd0d2..2c8f119e4c02 100644
--- a/x11-misc/xfe/Manifest
+++ b/x11-misc/xfe/Manifest
@@ -1,2 +1,3 @@
DIST xfe-1.40.1.tar.gz 2627754 SHA256 ec3d9495bb329c6199f6265dbfb514ffd3bdb8801e36ccc4e8fac6cea15bcc71 SHA512 d4d701dc84b342ca6f728073ff746d7308cc1cf1254956e41831cfa933649c7ac2ed32a55e6dc92047636e99f14d2609f5307aab5af07c700e597dd1cf4bf4cb WHIRLPOOL 00469cfe07604986b0a24fbcbb79c2174af6fc91ccaa7c08a47c31e6450ae637d3e1db002485d730f4ee241156c155754dcebd5a0d629941f101921c2825f533
DIST xfe-1.40.tar.gz 2574477 SHA256 2b476f15beff1a1ce85dd4ce6559bb7ceca78b866c63fb4986456862a36862a8 SHA512 22cf9fd60dcd4b594d7ff39ea78d10a8c71ee2433025acf32b7e69457a5e86852b54e448ebc1e3f63f39bf720767064c74c46eaf2b999c14ae76417d33272892 WHIRLPOOL 5c3ce54db8ac3c7e99f590100a493e3611ea2cad90b498d0b673d1366a85ed0280c8aa664f60f9de633192964a5cead4efee65e6eee69f65fdd0928061e07e0e
+DIST xfe-1.41.tar.gz 2752508 SHA256 d31ac9fdfa9223e54920ee8aabe20b43fa08ee4b6a5ee11a2d3c210506a3603f SHA512 eb9e1dfb02e5ae4bb9ccbf78bef8744ef61a72fb47795bb4598905c2f7ed01c65ed4443fd1b8981feb457b24daae1aa438170942eb97ec8b450c61b0742e4d2a WHIRLPOOL 9fc16836f8fb70d32b57902b504ccd438166d888da50049812f93b597e6dfa9920e357490d53f3718e4ae2b25d71977a528aeefa84d56d76d50ac7b5c85ce359
diff --git a/x11-misc/xfe/files/xfe-1.41-sn.patch b/x11-misc/xfe/files/xfe-1.41-sn.patch
new file mode 100644
index 000000000000..e4700eb71e9f
--- /dev/null
+++ b/x11-misc/xfe/files/xfe-1.41-sn.patch
@@ -0,0 +1,14 @@
+--- a/src/Properties.cpp
++++ b/src/Properties.cpp
+@@ -1169,7 +1169,11 @@
+
+ FXbool confirm = false;
+
++#ifdef STARTUP_NOTIFICATION
+ if (executable && snbutton->getCheck() != sndisable_prev)
++#else
++ if (executable)
++#endif
+ {
+ confirm = true;
+ }
diff --git a/x11-misc/xfe/xfe-1.41.ebuild b/x11-misc/xfe/xfe-1.41.ebuild
new file mode 100644
index 000000000000..aaee974bb324
--- /dev/null
+++ b/x11-misc/xfe/xfe-1.41.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PLOCALES="
+ bs ca cs da de el es_AR es_CO es fr hu it ja nl no pl pt_BR pt_PT ru sv tr
+ zh_CN zh_TW
+"
+inherit autotools eutils l10n
+
+DESCRIPTION="MS-Explorer-like minimalist file manager for X"
+HOMEPAGE="http://roland65.free.fr/xfe"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug nls startup-notification"
+
+RDEPEND="
+ media-libs/libpng:0
+ x11-libs/fox:1.6[truetype,png]
+ x11-libs/libX11
+ x11-libs/libXft
+ startup-notification? ( x11-libs/startup-notification )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
+"
+
+DOCS=( AUTHORS BUGS ChangeLog README TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.41-sn.patch
+
+ cat >po/POTFILES.skip <<-EOF
+ src/icons.cpp
+ xfe.desktop.in.in
+ xfi.desktop.in.in
+ xfp.desktop.in.in
+ xfv.desktop.in.in
+ xfw.desktop.in.in
+ EOF
+
+ # malformed LINGUAS file
+ # recent intltool expects newline for every linguas
+ sed -i \
+ -e '/^#/!s:\s\s*:\n:g' \
+ po/LINGUAS || die
+
+ # remove not selected locales
+ rm_locale() { sed -i -e "/${1}/d" po/LINGUAS || die ;}
+ l10n_for_each_disabled_locale_do rm_locale
+
+ sed -i \
+ -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' \
+ configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable startup-notification sn) \
+ --enable-minimalflags
+}