summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-05-02 12:20:34 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-05-02 12:23:56 -0700
commit4b2363beea40ed3cf8e516b4fee7415d42e45d38 (patch)
tree5ee336d32ef444cb2102d5148d912944c3e69da8 /x11-misc/xwallpaper
parentnet-libs/libtorrent-rasterbar: fix boost-1.70 compat (diff)
downloadgentoo-4b2363beea40ed3cf8e516b4fee7415d42e45d38.tar.gz
gentoo-4b2363beea40ed3cf8e516b4fee7415d42e45d38.tar.bz2
gentoo-4b2363beea40ed3cf8e516b4fee7415d42e45d38.zip
x11-misc/xwallpaper: bump to 0.5.0
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'x11-misc/xwallpaper')
-rw-r--r--x11-misc/xwallpaper/Manifest1
-rw-r--r--x11-misc/xwallpaper/xwallpaper-0.5.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/x11-misc/xwallpaper/Manifest b/x11-misc/xwallpaper/Manifest
index ce6b733525e3..75f7016b28ef 100644
--- a/x11-misc/xwallpaper/Manifest
+++ b/x11-misc/xwallpaper/Manifest
@@ -1,2 +1,3 @@
DIST xwallpaper-0.3.0.tar.gz 104300 BLAKE2B 23ec3b4ccbaf910c9ba4afbd1d9237223654a85c90b0a147141b017a9b3917316f745e1dd70a89e385110d380d5bbba8ee7c2d1ed4188d87a98ba0e94c5a7b6c SHA512 c73583fdbd573329951178d7db36fb1ae18a4294207de85dfb93e367be0ed103e8de7e2dd8ec61a0a23541457c930e8b0e5eb12dd5024808de3e02ddefb6b4a3
DIST xwallpaper-0.4.1.tar.gz 106110 BLAKE2B 13d40274910b5a82271207292ef7b5d5aeb21fe015c0f3a9780d164d805b9f212a017b4aea8cc8c92ad3a9392eb01c3ea5cddf66888ac4ec146d12109675bdd8 SHA512 febfca202d3356c5a2f584921eace61a6f16e19bf0b0812604bccb441b11a0748c997d0818fb8d9f6a37f502a0a38f13b78f7f61c2de2768a85807a8725c070c
+DIST xwallpaper-0.5.0.tar.xz 81000 BLAKE2B bb30871d24538b3fb04e1158df75bc82701ed184d3b8f60179990f60d91e03eb974ab3c72446c8f0bacbf3aa27d0cbe4446cf38e34d484a46dcaa66fcfe9682c SHA512 92cf424fb90dbdbe8e47ea7cc3650200da9f480afaef605e2ddbd7a828361f61754c2ed93c9be099c340f80eb60f8c1aa2f44004512cbe846401cb8ef73403a2
diff --git a/x11-misc/xwallpaper/xwallpaper-0.5.0.ebuild b/x11-misc/xwallpaper/xwallpaper-0.5.0.ebuild
new file mode 100644
index 000000000000..bcf9073e961d
--- /dev/null
+++ b/x11-misc/xwallpaper/xwallpaper-0.5.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Wallpaper setting utility for X"
+HOMEPAGE="https://github.com/stoeckmann/xwallpaper"
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/stoeckmann/${PN}.git"
+else
+ SRC_URI="https://github.com/stoeckmann/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="jpeg png seccomp xpm"
+
+RDEPEND="
+ x11-libs/pixman
+ x11-libs/xcb-util
+ x11-libs/xcb-util-image
+ jpeg? ( virtual/jpeg:0= )
+ png? ( media-libs/libpng:0= )
+ seccomp? ( >=sys-libs/libseccomp-2.3.1:0= )
+ xpm? ( x11-libs/libXpm )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+src_configure() {
+ local myconf=(
+ $(use_with jpeg)
+ $(use_with png)
+ $(use_with seccomp)
+ $(use_with xpm)
+ --with-randr
+ --with-zshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
+ )
+ econf "${myconf[@]}"
+}