summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-12-17 19:48:20 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-12-17 19:48:20 -0800
commit8aaaa537dec1ac45bca96d7eca5ddeaf16256bac (patch)
treeb7feb5eaf49423a20169bf8144540d9473cef695 /x11-misc/xwallpaper
parentnet-libs/wvstreams: Change dead homepage to what Debian uses (diff)
downloadgentoo-8aaaa537dec1ac45bca96d7eca5ddeaf16256bac.tar.gz
gentoo-8aaaa537dec1ac45bca96d7eca5ddeaf16256bac.tar.bz2
gentoo-8aaaa537dec1ac45bca96d7eca5ddeaf16256bac.zip
x11-misc/xwallpaper: bump to 0.4.1
The --daemon option has been fixed to properly work with sandboxing. The process is split early on so no further system calls have been added to stage 2. This version adds runtime debug support to display debug messages on standard error output. This is the same as the previous debug configure option during build. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'x11-misc/xwallpaper')
-rw-r--r--x11-misc/xwallpaper/Manifest1
-rw-r--r--x11-misc/xwallpaper/xwallpaper-0.4.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/x11-misc/xwallpaper/Manifest b/x11-misc/xwallpaper/Manifest
index fd683bc7877a..0c988e9b3a32 100644
--- a/x11-misc/xwallpaper/Manifest
+++ b/x11-misc/xwallpaper/Manifest
@@ -1,2 +1,3 @@
DIST xwallpaper-0.3.0.tar.gz 104300 BLAKE2B 23ec3b4ccbaf910c9ba4afbd1d9237223654a85c90b0a147141b017a9b3917316f745e1dd70a89e385110d380d5bbba8ee7c2d1ed4188d87a98ba0e94c5a7b6c SHA512 c73583fdbd573329951178d7db36fb1ae18a4294207de85dfb93e367be0ed103e8de7e2dd8ec61a0a23541457c930e8b0e5eb12dd5024808de3e02ddefb6b4a3
DIST xwallpaper-0.4.0.tar.gz 105879 BLAKE2B af1b2912ae35ff10c6138c72cbaab43996eddf6d2474dafe2ab7f8ea0216e71d3912a1340592c99e7f3ce3d3779bcccfe8285c48c44c6d3895cd79c73ac7d81b SHA512 43e7c047001a60badb7d81897087800eec4668dd9f0fa2ce06bc2c98d34d8e7fca8d5a922589b2836767e5cfa5c356b410ef32d60f9e0f76f899248d3c75fe98
+DIST xwallpaper-0.4.1.tar.gz 106110 BLAKE2B 13d40274910b5a82271207292ef7b5d5aeb21fe015c0f3a9780d164d805b9f212a017b4aea8cc8c92ad3a9392eb01c3ea5cddf66888ac4ec146d12109675bdd8 SHA512 febfca202d3356c5a2f584921eace61a6f16e19bf0b0812604bccb441b11a0748c997d0818fb8d9f6a37f502a0a38f13b78f7f61c2de2768a85807a8725c070c
diff --git a/x11-misc/xwallpaper/xwallpaper-0.4.1.ebuild b/x11-misc/xwallpaper/xwallpaper-0.4.1.ebuild
new file mode 100644
index 000000000000..6fdbe38a6273
--- /dev/null
+++ b/x11-misc/xwallpaper/xwallpaper-0.4.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Wallpaper setting utility for X"
+HOMEPAGE="https://github.com/stoeckmann/xwallpaper"
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/stoeckmann/${PN}.git"
+else
+ SRC_URI="https://github.com/stoeckmann/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="jpeg png seccomp xpm"
+
+RDEPEND="
+ x11-libs/pixman
+ x11-libs/xcb-util
+ x11-libs/xcb-util-image
+ jpeg? ( virtual/jpeg:0= )
+ png? ( media-libs/libpng:0= )
+ seccomp? ( >=sys-libs/libseccomp-2.3.1:0= )
+ xpm? ( x11-libs/libXpm )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+src_configure() {
+ local myconf=(
+ $(use_with jpeg)
+ $(use_with png)
+ $(use_with seccomp)
+ $(use_with xpm)
+ --with-randr
+ --with-zshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
+ )
+ econf "${myconf[@]}"
+}