summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPoncho <poncho@spahan.ch>2018-04-04 17:53:27 +0200
committerAaron Bauman <bman@gentoo.org>2018-05-24 17:46:38 -0400
commit30f3c4d7b614b5114e4364540d418a79661ee2d8 (patch)
treedb9c6ed830bc62fad3d4529edfd4f2a1904d4fd7 /x11-misc/zim
parentnet-print/hplip-plugin: Update homepage. (diff)
downloadgentoo-30f3c4d7b614b5114e4364540d418a79661ee2d8.tar.gz
gentoo-30f3c4d7b614b5114e4364540d418a79661ee2d8.tar.bz2
gentoo-30f3c4d7b614b5114e4364540d418a79661ee2d8.zip
x11-misc/zim: version bump
* run xdg_desktop_database_update * remove gnome2_icon_savelist * drop gnome-extra/zeitgeist from postinstall message Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7809
Diffstat (limited to 'x11-misc/zim')
-rw-r--r--x11-misc/zim/Manifest1
-rw-r--r--x11-misc/zim/zim-0.68.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/x11-misc/zim/Manifest b/x11-misc/zim/Manifest
index 7dce0f151193..fc8cab927643 100644
--- a/x11-misc/zim/Manifest
+++ b/x11-misc/zim/Manifest
@@ -2,3 +2,4 @@ DIST zim-0.65.tar.gz 1899614 BLAKE2B e7989d91120f2ffe0668c996b5abd61cc1cb12b2a5a
DIST zim-0.66.tar.gz 2020216 BLAKE2B 7a2af3dca2ff72dd94c605c4fa89b0d3be1413643c781aa151483445e6a029db6021ed84df797b6d9aaac05fd791fe50e4bdc9f1682d252e80f083bf37a10602 SHA512 9693dba8ee6ad915a85ca999674350b278043559ba4adf93c03c8815211ecab451a6e2dceaf62ea7048609eb86f19485f2dd77dbaaf6f2d81f97f6450bf25ca9
DIST zim-0.67.tar.gz 2034747 BLAKE2B 47e49191e699f93727f566593d616ef0da5b826dccb2f952c6220627d67f295d40e57b9e00dec8395a933a0378c0b1b05c25db7a2cb30fd4509e6ee06269c831 SHA512 0f3387a74a9d6a1e972b4ad411230b9318c58432bd853ef6d45cd535dcdef901369a70dd619b842f1e6564a4b583075865d30acb75cc7649facf5acfe43d8b94
DIST zim-0.68-rc1.tar.gz 2602967 BLAKE2B 7a1eed33e8d7f27ea287c993f1dde5e8d89cc9435f909ede5696f80ceaee454a38d0ab903313d6a07375797bd43cf48925e81be725094d4a4ce188f750fcac9e SHA512 60c2c654f6b40edcf029efb8367e18a8c4cca7fde11339f4ab9b3724f07f4041aae5740cd7a42fe3b2f836537c699ad597cef0eaec0b0511cb7c65b40ea6e04e
+DIST zim-0.68.tar.gz 2044224 BLAKE2B 5c53c3197bc5de90c38059e7323366ed5b7600ebf0b3575d81e618d972d0360f67660da4637f1e6f1459549b21525ed17183e9c2f57f8ab0b27236e36bda9666 SHA512 4ab7f2b55e37ae917a7faa0018a36cbad2534bb43146f47810479155009eb2ccbf4f8ab185d8b4cd3ba7e22a4e2fc5eb08c4bae0688186c13d31dfcab23b0048
diff --git a/x11-misc/zim/zim-0.68.ebuild b/x11-misc/zim/zim-0.68.ebuild
new file mode 100644
index 000000000000..44110e717f31
--- /dev/null
+++ b/x11-misc/zim/zim-0.68.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit xdg-utils distutils-r1 gnome2-utils virtualx
+
+DESCRIPTION="A desktop wiki"
+HOMEPAGE="http://zim-wiki.org/"
+SRC_URI="http://zim-wiki.org/downloads/${P}.tar.gz"
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pygtk[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ x11-misc/xdg-utils
+ test? (
+ dev-vcs/bzr
+ dev-vcs/git
+ dev-vcs/mercurial )"
+
+DOCS=( CHANGELOG.txt README.txt HACKING )
+PATCHES=( "${FILESDIR}"/${PN}-0.60-remove-ubuntu-theme.patch )
+
+python_prepare_all() {
+ sed -i -e "s/'USER'/'LOGNAME'/g" zim/__init__.py zim/fs.py || die
+
+ if [[ ${LINGUAS} ]]; then
+ local lingua
+ for lingua in translations/*.po; do
+ lingua=${lingua/.po}
+ lingua=${lingua/translations\/}
+ has ${lingua} ${LINGUAS} || \
+ { rm translations/${lingua}.po || die; }
+ done
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ VIRTUALX_COMMAND="${PYTHON}" virtualmake test.py
+}
+
+python_install() {
+ distutils-r1_python_install --skip-xdg-cmd
+}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+ if ! has_version ${CATEGORY}/${PN}; then
+ einfo "Please emerge these packages for additional functionality"
+ einfo " dev-lang/R"
+ einfo " dev-python/gtkspell-python"
+ einfo " dev-vcs/bzr"
+ einfo " media-gfx/graphviz"
+ einfo " media-gfx/imagemagick"
+ einfo " media-gfx/scrot"
+ einfo " media-sound/lilypond"
+ einfo " sci-visualization/gnuplot"
+ einfo " virtual/latex-base app-text/dvipng"
+ fi
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}