summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-01-02 01:24:31 +0100
committerJeroen Roovers <jer@gentoo.org>2019-01-02 01:30:22 +0100
commit37b79f072258cf93b750e7547aca41e90b6e515f (patch)
tree8feb888a7014a3831942d8e90a7a0706766b1bb1 /x11-misc
parentmedia-plugins/kodi-pvr-mythtv: 5.10.3 version bump (diff)
downloadgentoo-37b79f072258cf93b750e7547aca41e90b6e515f.tar.gz
gentoo-37b79f072258cf93b750e7547aca41e90b6e515f.tar.bz2
gentoo-37b79f072258cf93b750e7547aca41e90b6e515f.zip
x11-misc/rofi: Version 1.5.2
Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/rofi/Manifest1
-rw-r--r--x11-misc/rofi/rofi-1.5.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/x11-misc/rofi/Manifest b/x11-misc/rofi/Manifest
index eb70f8483695..35e706c37007 100644
--- a/x11-misc/rofi/Manifest
+++ b/x11-misc/rofi/Manifest
@@ -1 +1,2 @@
DIST rofi-1.5.1.tar.xz 355912 BLAKE2B 710a35ab82bf960b331431be3cc3acfb5cc27b42d7fa8b02e8c070918679b90612d89f600a6e58215bc0a08dcb60087ea37a5498fa8c4ac39d246d5967f0b314 SHA512 32074e931199ff1529ebab8fef53d339eab09843888f862953b7d661323484ebe66d820feecc42604a16bd683a5af1ec4d1a2e7f097f408efed6cfe91c4eb5ff
+DIST rofi-1.5.2.tar.xz 377732 BLAKE2B 560c5a4d30d143cbb5ca9030086d614a8f56a5e17b75c1b3f3a2e57bbd16de304b733bc4fd6093e716c993051e238811e9e65ffbf165d2ae4723f0bde1b15b42 SHA512 8fbbcaa040148d204878380f7cb96fa31228f72b68a97a5bcf8d8cd69740f6b185f5e5d2bc2e1d35e267a84b21576eb356c33be827fd1b767460665493360c16
diff --git a/x11-misc/rofi/rofi-1.5.2.ebuild b/x11-misc/rofi/rofi-1.5.2.ebuild
new file mode 100644
index 000000000000..ffb4b7ff5d39
--- /dev/null
+++ b/x11-misc/rofi/rofi-1.5.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A window switcher, run dialog and dmenu replacement"
+HOMEPAGE="https://github.com/DaveDavenport/rofi/"
+SRC_URI="${HOMEPAGE}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test windowmode"
+
+RDEPEND="
+ dev-libs/glib:2
+ gnome-base/librsvg:2
+ media-libs/freetype
+ x11-libs/cairo[xcb]
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libxcb
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-base/xorg-proto
+ test? ( >=dev-libs/check-0.11 )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.15.12-Werror.patch
+ "${FILESDIR}"/${PN}-1.5.0-gtk-settings-test.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+
+ econf \
+ $(use_enable test check) \
+ $(use_enable windowmode)
+}