summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-06-30 13:24:26 -0400
committerTim Harder <radhermit@gentoo.org>2018-06-30 13:34:31 -0400
commit93757f0eb4a3e92596a21bd887ae765a64369f2a (patch)
tree1d664742ee687b7b88d8c2fe318324a981261860 /x11-misc
parentnet-proxy/sshuttle: version bump to 0.78.4 (diff)
downloadgentoo-93757f0eb4a3e92596a21bd887ae765a64369f2a.tar.gz
gentoo-93757f0eb4a3e92596a21bd887ae765a64369f2a.tar.bz2
gentoo-93757f0eb4a3e92596a21bd887ae765a64369f2a.zip
x11-misc/sxhkd: version bump to 0.5.9
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/sxhkd/Manifest1
-rw-r--r--x11-misc/sxhkd/sxhkd-0.5.9.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/x11-misc/sxhkd/Manifest b/x11-misc/sxhkd/Manifest
index e42ffe856387..f23b5b65b996 100644
--- a/x11-misc/sxhkd/Manifest
+++ b/x11-misc/sxhkd/Manifest
@@ -1,2 +1,3 @@
DIST sxhkd-0.5.7.tar.gz 34472 BLAKE2B 7fad813c20786c4010f62422f9dc134f5b867ae02c3135c497d298915f2ffdc911c6684da40c57ba1b4cb0616864ef894e88898bde06600a72884991968d0201 SHA512 b977c79f2f8ef311b1bbe5bab21ae60c5689d1069552368573bc9aad55e58df4abff51ccdcf74b5e7c72cdee6077da67636f45a390f0fffb1a5e34b478579a18
DIST sxhkd-0.5.8.tar.gz 34566 BLAKE2B e8133dff70441a7383a3f0cc62d63a76552d26b8e30954b6127cd5fe3f9bd7b15ad030a73f6654b5c8c24edae3570f685bbec3df7431c358498abab714814c5d SHA512 59b38a77e7fd4b23cb109a1365514f39d23ae5bd1b467355ad894d3a861627fd0fc5c5fb556176161c6580c719a4032cf516f60eb3023dc30bf09ae362e4e094
+DIST sxhkd-0.5.9.tar.gz 34649 BLAKE2B e07d9a7a99cd3ab1436ece589a57023de87c6a1e74ef509e9bfc9db3bcda9680f826dc2edad1474004775cf307b9280dc60e18060a803deb801022c004bf0e8c SHA512 32ee7261b4fa10d5a62a7fa61e689977d12afd654e81123711bda1f006e4b6baa7524352086037594e6ef1989dd8fcb6eddc1114085ee91546a69f6d1146924e
diff --git a/x11-misc/sxhkd/sxhkd-0.5.9.ebuild b/x11-misc/sxhkd/sxhkd-0.5.9.ebuild
new file mode 100644
index 000000000000..a185c8b35f77
--- /dev/null
+++ b/x11-misc/sxhkd/sxhkd-0.5.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs systemd
+
+DESCRIPTION="Simple X hotkey daemon"
+HOMEPAGE="https://github.com/baskerville/sxhkd/"
+SRC_URI="https://github.com/baskerville/sxhkd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/libxcb
+ x11-libs/xcb-util-keysyms"
+DEPEND="${RDEPEND}
+ x11-libs/xcb-util"
+
+src_compile() {
+ emake CC="$(tc-getCC)" PREFIX=/usr
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+ systemd_dounit contrib/systemd/${PN}.service
+}