summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-06-13 10:59:06 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2020-06-13 11:04:24 +0200
commit80332b22e81f0a4ea49fa7515c9388758e8d6667 (patch)
tree2b2e774a708eeb352290177f1332ece5baa45718 /x11-plugins
parentx11-plugins/wmapm: fix build with -fno-common (diff)
downloadgentoo-80332b22e81f0a4ea49fa7515c9388758e8d6667.tar.gz
gentoo-80332b22e81f0a4ea49fa7515c9388758e8d6667.tar.bz2
gentoo-80332b22e81f0a4ea49fa7515c9388758e8d6667.zip
x11-plugins/wmrecord: fix build with -fno-common
Closes: https://bugs.gentoo.org/726206 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmrecord/files/wmrecord-1.0.5.3-fno-common.patch29
-rw-r--r--x11-plugins/wmrecord/wmrecord-1.0.5.3-r2.ebuild4
2 files changed, 32 insertions, 1 deletions
diff --git a/x11-plugins/wmrecord/files/wmrecord-1.0.5.3-fno-common.patch b/x11-plugins/wmrecord/files/wmrecord-1.0.5.3-fno-common.patch
new file mode 100644
index 000000000000..a70b5f87b0ee
--- /dev/null
+++ b/x11-plugins/wmrecord/files/wmrecord-1.0.5.3-fno-common.patch
@@ -0,0 +1,29 @@
+diff -Naur wmrecord-1.0.5.orig/wmgeneral/wmgeneral.c wmrecord-1.0.5/wmgeneral/wmgeneral.c
+--- wmrecord-1.0.5.orig/wmgeneral/wmgeneral.c 1999-07-05 20:40:04.000000000 +0200
++++ wmrecord-1.0.5/wmgeneral/wmgeneral.c 2020-06-13 10:57:57.237900077 +0200
+@@ -66,6 +66,9 @@
+ char *Geometry = "";
+ GC NormalGC;
+ Pixmap pixmask;
++Display *display;
++Window Root, iconwin, win;
++XpmIcon wmgen;
+
+ /*****************/
+ /* Mouse Regions */
+diff -Naur wmrecord-1.0.5.orig/wmgeneral/wmgeneral.h wmrecord-1.0.5/wmgeneral/wmgeneral.h
+--- wmrecord-1.0.5.orig/wmgeneral/wmgeneral.h 1999-06-01 15:46:55.000000000 +0200
++++ wmrecord-1.0.5/wmgeneral/wmgeneral.h 2020-06-13 10:57:51.055895156 +0200
+@@ -36,9 +36,9 @@
+ /* Global variable */
+ /*******************/
+
+-Display *display;
+-Window Root, iconwin, win;
+-XpmIcon wmgen;
++extern Display *display;
++extern Window Root, iconwin, win;
++extern XpmIcon wmgen;
+
+ /***********************/
+ /* Function Prototypes */
diff --git a/x11-plugins/wmrecord/wmrecord-1.0.5.3-r2.ebuild b/x11-plugins/wmrecord/wmrecord-1.0.5.3-r2.ebuild
index 4be4f50aa084..565cf6323752 100644
--- a/x11-plugins/wmrecord/wmrecord-1.0.5.3-r2.ebuild
+++ b/x11-plugins/wmrecord/wmrecord-1.0.5.3-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,6 +22,8 @@ KEYWORDS="~ppc x86"
S="${WORKDIR}/${PN}-1.0.5"
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+
src_prepare() {
default
#prevent auto-stripping of binaries. Closes bug #252112