summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2016-07-05 15:16:32 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2016-07-05 15:17:49 +0200
commitde05dc37029c7ca63eb69809f730a7caffc9fd4d (patch)
treeb79f3aa807b60f72b480c920a3ccde6a3304b590 /x11-plugins
parentdev-scheme/scheme48: clean vulnerable versions bug #513088 (diff)
downloadgentoo-de05dc37029c7ca63eb69809f730a7caffc9fd4d.tar.gz
gentoo-de05dc37029c7ca63eb69809f730a7caffc9fd4d.tar.bz2
gentoo-de05dc37029c7ca63eb69809f730a7caffc9fd4d.zip
x11-plugins/wmudmount: fix xdg sandbox issue, bug #587870
Reported by Toralf Förster <toralf.foerster@gmx.de> Also bump EAPI Package-Manager: portage-2.3.0
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmudmount/wmudmount-2.2-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-plugins/wmudmount/wmudmount-2.2-r1.ebuild b/x11-plugins/wmudmount/wmudmount-2.2-r1.ebuild
new file mode 100644
index 000000000000..9e2f5e8329a2
--- /dev/null
+++ b/x11-plugins/wmudmount/wmudmount-2.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils gnome2-utils xdg
+
+DESCRIPTION="A filesystem mounter that uses udisks to handle notification and mounting"
+HOMEPAGE="http://sourceforge.net/projects/wmudmount/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome-keyring libnotify"
+
+RDEPEND="sys-fs/udisks:2
+ >=x11-libs/gtk+-3.8.0:3
+ gnome-keyring? ( gnome-base/libgnome-keyring )
+ libnotify? ( >=x11-libs/libnotify-0.7 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ || ( media-gfx/imagemagick[png] media-gfx/graphicsmagick[imagemagick,png] )"
+
+DOCS="ChangeLog"
+
+src_configure() {
+ econf \
+ $(use_with libnotify) \
+ $(use_with gnome-keyring)
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }