summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-terms/root-tail
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-terms/root-tail')
-rw-r--r--x11-terms/root-tail/Manifest1
-rw-r--r--x11-terms/root-tail/files/root-tail-1.2-kde.patch125
-rw-r--r--x11-terms/root-tail/metadata.xml7
-rw-r--r--x11-terms/root-tail/root-tail-1.2-r3.ebuild47
4 files changed, 180 insertions, 0 deletions
diff --git a/x11-terms/root-tail/Manifest b/x11-terms/root-tail/Manifest
new file mode 100644
index 000000000000..f4fdde8447ee
--- /dev/null
+++ b/x11-terms/root-tail/Manifest
@@ -0,0 +1 @@
+DIST root-tail-1.2.tar.gz 20805 SHA256 08fb829cc0edd533aaf2af7bcf12d877a6ff51d60c59be48ba354c5940b80691
diff --git a/x11-terms/root-tail/files/root-tail-1.2-kde.patch b/x11-terms/root-tail/files/root-tail-1.2-kde.patch
new file mode 100644
index 000000000000..750edf2fefa0
--- /dev/null
+++ b/x11-terms/root-tail/files/root-tail-1.2-kde.patch
@@ -0,0 +1,125 @@
+diff -bBurN root-tail-1.2/config.h root-tail-my/config.h
+--- root-tail-1.2/config.h 2004-07-30 23:32:39.000000000 +0400
++++ root-tail-my/config.h 2005-02-23 13:02:48.878912688 +0300
+@@ -15,3 +15,4 @@
+
+ #define VERSION "1.2"
+
++#define KDE
+diff -bBurN root-tail-1.2/root-tail.c root-tail-my/root-tail.c
+--- root-tail-1.2/root-tail.c 2004-07-30 23:33:20.000000000 +0400
++++ root-tail-my/root-tail.c 2005-02-23 13:02:37.599627400 +0300
+@@ -148,6 +148,11 @@
+ regex_t *transformre;
+ #endif
+
++#ifdef KDE
++#define ATOM(a) XInternAtom(disp, #a, False)
++
++int screen, ScreenWidth, ScreenHeight;
++#endif
+
+ /* prototypes */
+ void list_files (int);
+@@ -227,7 +232,7 @@
+ return Color.pixel;
+ }
+
+-#ifndef USE_TOON_GET_ROOT_WINDOW
++#if !defined(USE_TOON_GET_ROOT_WINDOW) && !defined(KDE)
+ static void
+ find_root_window (Display *display, int screen_number)
+ {
+@@ -280,14 +285,91 @@
+ fprintf (stderr, "Can't query tree on root window 0x%lx", root);
+ }
+ }
+-#endif /* USE_TOON_GET_ROOT_WINDOW */
++#elif defined(KDE)
++static Window find_subwindow(Window win, int w, int h) {
++ unsigned int i, j;
++ Window troot, parent, *children;
++ unsigned int n;
++
++ /* search subwindows with same size as display or work area */
++
++ for (i=0; i<10; i++) {
++ XQueryTree(disp, win, &troot, &parent, &children, &n);
++
++ for (j=0; j<n; j++) {
++ XWindowAttributes attrs;
++
++ if (XGetWindowAttributes(disp, children[j], &attrs)) {
++ /* Window must be mapped and same size as display or work space */
++ if (attrs.map_state != 0 &&
++ ((attrs.width == ScreenWidth && attrs.height == ScreenHeight) ||
++ (attrs.width == w && attrs.height == h))) {
++ win = children[j];
++ break;
++ }
++ }
++ }
++
++ XFree(children);
++ if (j == n) break;
++ }
++
++ return win;
++}
++
++static void
++find_root_window (Display *display, int screen_number)
++{
++ Atom type;
++ int format, i;
++ unsigned long nitems, bytes;
++ unsigned int n;
++ root = RootWindow(display, screen_number);
++ Window win = root;
++ Window troot, parent, *children;
++ unsigned char *buf = NULL;
++
++ /* some window managers set __SWM_VROOT to some child of root window */
++
++ XQueryTree(display, root, &troot, &parent, &children, &n);
++ for (i=0; i<(int)n; i++) {
++ if (XGetWindowProperty(display, children[i], ATOM(__SWM_VROOT),
++ 0, 1, False, XA_WINDOW, &type, &format, &nitems, &bytes,
++ &buf) == Success && type == XA_WINDOW) {
++ win = * (Window *) buf;
++ XFree(buf);
++ XFree(children);
++ fprintf(stderr, "torsmo: drawing to window from __SWM_VROOT property\n");
++ root=win;
++ return;
++ }
++
++ if (buf) {
++ XFree(buf);
++ buf = 0;
++ }
++ }
++ XFree(children);
++
++ /* get subwindows from root */
++ win = find_subwindow(root, -1, -1);
++
++ win = find_subwindow(win, width, height);
++
++ if (buf) { XFree(buf); buf = 0; }
++
++ root=win;
++}
++#endif /* USE_TOON_GET_ROOT_WINDOW && KDE*/
+
+ void
+ InitWindow (void)
+ {
+ XGCValues gcv;
+ unsigned long gcm;
++#ifndef KDE
+ int screen, ScreenWidth, ScreenHeight;
++#endif
+ struct logfile_entry *e;
+
+ if (!(disp = XOpenDisplay (dispname)))
diff --git a/x11-terms/root-tail/metadata.xml b/x11-terms/root-tail/metadata.xml
new file mode 100644
index 000000000000..91f4e72fb544
--- /dev/null
+++ b/x11-terms/root-tail/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-terms/root-tail/root-tail-1.2-r3.ebuild b/x11-terms/root-tail/root-tail-1.2-r3.ebuild
new file mode 100644
index 000000000000..628cc3bf252b
--- /dev/null
+++ b/x11-terms/root-tail/root-tail-1.2-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Terminal to display (multiple) log files on the root window"
+HOMEPAGE="http://oldhome.schmorp.de/marc/root-tail.html"
+SRC_URI="http://oldhome.schmorp.de/marc/data/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="kde debug"
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libX11"
+DEPEND="x11-misc/imake
+ app-text/rman
+ x11-misc/gccmakedep
+ x11-libs/libX11
+ x11-proto/xproto"
+
+src_prepare() {
+ use kde && epatch "${FILESDIR}"/${P}-kde.patch
+}
+
+src_configure() {
+ xmkmf -a
+}
+
+src_compile() {
+ sed -i 's:/usr/X11R6/bin:/usr/bin:' Makefile || die "sed Makefile failed"
+ use debug && append-flags -DDEBUG
+ emake \
+ CC=$(tc-getCC) \
+ CCOPTIONS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install.man || die "make install failed"
+ dodoc Changes README
+}