summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-04-10 15:48:49 +0200
committerJeroen Roovers <jer@gentoo.org>2019-04-10 15:49:18 +0200
commit76344fabfd15a262985f3705851b374c60187717 (patch)
tree4832a6738e9ee39108cc6214661056964ce56525 /x11-terms
parentwww-apps/piwigo: 2.9.5 bump (diff)
downloadgentoo-76344fabfd15a262985f3705851b374c60187717.tar.gz
gentoo-76344fabfd15a262985f3705851b374c60187717.tar.bz2
gentoo-76344fabfd15a262985f3705851b374c60187717.zip
x11-terms/rxvt-unicode: Add IUSE="utmp wtmp"
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Bug: https://bugs.gentoo.org/683008 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/rxvt-unicode/metadata.xml50
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9.22-r2.ebuild89
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild42
3 files changed, 135 insertions, 46 deletions
diff --git a/x11-terms/rxvt-unicode/metadata.xml b/x11-terms/rxvt-unicode/metadata.xml
index 7d1c93339ec7..fe671825fc57 100644
--- a/x11-terms/rxvt-unicode/metadata.xml
+++ b/x11-terms/rxvt-unicode/metadata.xml
@@ -1,29 +1,29 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>jer@gentoo.org</email>
- <name>Jeroen Roovers</name>
- </maintainer>
- <use>
- <flag name="256-color">Enable 256 color support</flag>
- <flag name="alt-font-width">Calculate the font width using a different method</flag>
- <flag name="blink">Enable blinking text</flag>
- <flag name="buffer-on-clear">Store visible output to history buffer when clearing the screen with ctrl-l.
- Read https://bbs.archlinux.org/viewtopic.php?id=129302</flag>
- <flag name="fading-colors">Enable colors fading when off focus</flag>
- <flag name="focused-urgency">Enable the urgent flag when a terminal window is focused</flag>
- <flag name="font-styles">Enable support for bold and italic fonts</flag>
- <flag name="iso14755">Enable ISO-14755 support</flag>
- <flag name="mousewheel">Enable scrolling via mouse wheel or buttons 4 and 5</flag>
- <flag name="perl">Enable perl script support. You can still disable this at runtime with -pe ""</flag>
- <flag name="pixbuf">Enable transparency support using gtk's pixbuf</flag>
- <flag name="secondary-wheel">Support for wheel scrolling on secondary screens (like mutt).
- Read http://lists.schmorp.de/pipermail/rxvt-unicode/2011q4/001491.html</flag>
- <flag name="unicode3">Use 21 instead of 16 bits to represent unicode characters</flag>
- <flag name="wcwidth">Enable wide char width support</flag>
- </use>
- <upstream>
- <remote-id type="cpe">cpe:/a:rxvt-unicode:rxvt-unicode</remote-id>
- </upstream>
+<maintainer type="person">
+<email>jer@gentoo.org</email>
+<name>Jeroen Roovers</name>
+</maintainer>
+<use>
+<flag name="256-color">Enable 256 color support</flag>
+<flag name="alt-font-width">Calculate the font width using a different method</flag>
+<flag name="blink">Enable blinking text</flag>
+<flag name="buffer-on-clear">Store visible output to history buffer when clearing the screen with ctrl-l. Read https://bbs.archlinux.org/viewtopic.php?id=129302</flag>
+<flag name="fading-colors">Enable colors fading when off focus</flag>
+<flag name="focused-urgency">Enable the urgent flag when a terminal window is focused</flag>
+<flag name="font-styles">Enable support for bold and italic fonts</flag>
+<flag name="iso14755">Enable ISO-14755 support</flag>
+<flag name="mousewheel">Enable scrolling via mouse wheel or buttons 4 and 5</flag>
+<flag name="perl">Enable perl script support. You can still disable this at runtime with -pe ""</flag>
+<flag name="pixbuf">Enable transparency support using gtk's pixbuf</flag>
+<flag name="secondary-wheel">Support for wheel scrolling on secondary screens (like mutt). Read http://lists.schmorp.de/pipermail/rxvt-unicode/2011q4/001491.html</flag>
+<flag name="unicode3">Use 21 instead of 16 bits to represent unicode characters</flag>
+<flag name="utmp">Enable utmp support</flag>
+<flag name="wcwidth">Enable wide char width support</flag>
+<flag name="wtmp">Enable wtmp support</flag>
+</use>
+<upstream>
+<remote-id type="cpe">cpe:/a:rxvt-unicode:rxvt-unicode</remote-id>
+</upstream>
</pkgmetadata>
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9.22-r2.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9.22-r2.ebuild
new file mode 100644
index 000000000000..ffbed292e804
--- /dev/null
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9.22-r2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools desktop
+
+DESCRIPTION="rxvt clone with xft and unicode support"
+HOMEPAGE="http://software.schmorp.de/pkg/rxvt-unicode.html"
+SRC_URI="http://dist.schmorp.de/rxvt-unicode/Attic/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="
+ 256-color blink fading-colors +font-styles iso14755 +mousewheel +perl
+ pixbuf startup-notification unicode3 +utmp +wtmp xft
+"
+RESTRICT="test"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.7-r6:=
+ media-libs/fontconfig
+ x11-libs/libX11
+ x11-libs/libXrender
+ kernel_Darwin? ( dev-perl/Mac-Pasteboard )
+ perl? ( dev-lang/perl:= )
+ pixbuf? ( x11-libs/gdk-pixbuf x11-libs/gtk+:2 )
+ startup-notification? ( x11-libs/startup-notification )
+ xft? ( x11-libs/libXft )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-9.06-case-insensitive-fs.patch
+ "${FILESDIR}"/${PN}-9.21-xsubpp.patch
+)
+DOCS=(
+ Changes
+ README.FAQ
+ doc/README.xvt
+ doc/changes.txt
+ doc/etc/${PN}.term{cap,info}
+ doc/rxvt-tabbed
+)
+
+src_prepare() {
+ default
+
+ # kill the rxvt-unicode terminfo file - #192083
+ sed -i -e "/rxvt-unicode.terminfo/d" doc/Makefile.in || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ # --enable-everything goes first: the order of the arguments matters
+ econf --enable-everything \
+ $(use_enable 256-color) \
+ $(use_enable blink text-blink) \
+ $(use_enable fading-colors fading) \
+ $(use_enable font-styles) \
+ $(use_enable iso14755) \
+ $(use_enable mousewheel) \
+ $(use_enable perl) \
+ $(use_enable pixbuf) \
+ $(use_enable startup-notification) \
+ $(use_enable unicode3) \
+ $(use_enable utmp) \
+ $(use_enable wtmp) \
+ $(use_enable xft)
+}
+
+src_compile() {
+ default
+
+ sed -i \
+ -e 's/RXVT_BASENAME = "rxvt"/RXVT_BASENAME = "urxvt"/' \
+ "${S}"/doc/rxvt-tabbed || die
+}
+
+src_install() {
+ default
+
+ make_desktop_entry urxvt rxvt-unicode utilities-terminal \
+ "System;TerminalEmulator"
+}
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild
index 9a25833630ec..376b8036d825 100644
--- a/x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools cvs eutils
+EAPI=7
+inherit autotools cvs desktop vcs-clean
DESCRIPTION="rxvt clone with xft and unicode support"
HOMEPAGE="http://software.schmorp.de/pkg/rxvt-unicode.html"
@@ -15,13 +15,13 @@ SLOT="0"
KEYWORDS=""
IUSE="
256-color blink fading-colors +font-styles iso14755 +mousewheel +perl
- pixbuf startup-notification xft unicode3
+ pixbuf startup-notification unicode3 +utmp +wtmp xft
"
RESTRICT="test"
RDEPEND="
+ >=sys-libs/ncurses-5.7-r6:=
media-libs/fontconfig
- sys-libs/ncurses:*
x11-libs/libX11
x11-libs/libXrender
kernel_Darwin? ( dev-perl/Mac-Pasteboard )
@@ -35,30 +35,31 @@ DEPEND="
virtual/pkgconfig
x11-base/xorg-proto
"
-
-S=${WORKDIR}/${PN}
-PATCHES=(
- "${FILESDIR}"/${PN}-9.06-case-insensitive-fs.patch
- "${FILESDIR}"/${PN}-9.21-xsubpp.patch
-
+DOCS=(
+ Changes
+ README.FAQ
+ doc/README.xvt
+ doc/changes.txt
+ doc/etc/${PN}.term{cap,info}
+ doc/rxvt-tabbed
)
+S=${WORKDIR}/${PN}
src_prepare() {
ecvs_clean
-
- # kill the rxvt-unicode terminfo file - #192083
- sed -i -e "/rxvt-unicode.terminfo/d" doc/Makefile.in || die
+ eapply \
+ "${FILESDIR}"/${PN}-9.06-case-insensitive-fs.patch \
+ "${FILESDIR}"/${PN}-9.21-xsubpp.patch
eapply_user
+ # kill the rxvt-unicode terminfo file - #192083
+ sed -i -e "/rxvt-unicode.terminfo/d" doc/Makefile.in || die "sed failed"
+
eautoreconf
}
src_configure() {
- local myconf=''
-
- use iso14755 || myconf='--disable-iso14755'
-
# --enable-everything goes first: the order of the arguments matters
econf --enable-everything \
$(use_enable 256-color) \
@@ -71,6 +72,8 @@ src_configure() {
$(use_enable pixbuf) \
$(use_enable startup-notification) \
$(use_enable unicode3) \
+ $(use_enable utmp) \
+ $(use_enable wtmp) \
$(use_enable xft)
}
@@ -85,9 +88,6 @@ src_compile() {
src_install() {
default
- dodoc \
- README.FAQ Changes doc/README* doc/changes.txt doc/etc/* doc/rxvt-tabbed
-
make_desktop_entry urxvt rxvt-unicode utilities-terminal \
"System;TerminalEmulator"
}