summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-04-22 08:05:00 +0200
committerMichał Górny <mgorny@gentoo.org>2019-04-22 08:05:24 +0200
commitd68b93e49592b9a879f4316de6a7102bf4e071ba (patch)
tree828881292e2ce66197c8213873d1f7d0c29ef039 /x11-wm/afterstep/afterstep-2.2.12.ebuild
parentgames-roguelike/rogue: Remove last-rited pkg (diff)
downloadgentoo-d68b93e49592b9a879f4316de6a7102bf4e071ba.tar.gz
gentoo-d68b93e49592b9a879f4316de6a7102bf4e071ba.tar.bz2
gentoo-d68b93e49592b9a879f4316de6a7102bf4e071ba.zip
x11-wm/afterstep: Remove last-rited pkg
Closes: https://bugs.gentoo.org/681294 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'x11-wm/afterstep/afterstep-2.2.12.ebuild')
-rw-r--r--x11-wm/afterstep/afterstep-2.2.12.ebuild124
1 files changed, 0 insertions, 124 deletions
diff --git a/x11-wm/afterstep/afterstep-2.2.12.ebuild b/x11-wm/afterstep/afterstep-2.2.12.ebuild
deleted file mode 100644
index 522dd4266352..000000000000
--- a/x11-wm/afterstep/afterstep-2.2.12.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit autotools eutils flag-o-matic
-
-DESCRIPTION="A feature rich NeXTish window manager"
-HOMEPAGE="http://www.afterstep.org/"
-SRC_URI="ftp://ftp.afterstep.org/stable/AfterStep-${PV}.tar.bz2
- mirror://sourceforge/${PN}/AfterStep-${PV}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="alsa debug dbus gif gtk jpeg cpu_flags_x86_mmx nls png svg tiff xinerama"
-
-RDEPEND="
- media-libs/freetype
- sys-libs/readline:0=
- x11-libs/libICE
- x11-libs/libXext
- x11-libs/libSM
- x11-libs/libXmu
- x11-libs/libXt
- x11-libs/libX11
- x11-libs/libXpm
- x11-libs/libXrender
- alsa? ( media-libs/alsa-lib )
- dbus? ( sys-apps/dbus )
- jpeg? ( virtual/jpeg:= )
- gif? ( >=media-libs/giflib-4.1.0 )
- gtk? ( x11-libs/gtk+:2 )
- png? ( media-libs/libpng:0= )
- svg? ( gnome-base/librsvg:2 )
- tiff? ( media-libs/tiff:0 )
- xinerama? ( x11-libs/libXinerama )
-"
-DEPEND="
- ${RDEPEND}
- x11-base/xorg-proto
- !!media-libs/libafterimage
-"
-
-S="${WORKDIR}/${PN}-devel-${PV}"
-
-src_prepare() {
- sed -i -e '/^install:/s:install.alternative ::' Makefile.in || die
- sed -i -e '/CFLAGS="-O3"/d' libAfter{Base,Image}/configure || die
- sed -i -e '/STRIP_BINARIES/s:-s::' autoconf/configure.in || die #252119
- sed -i -e '/--with-builtin-gif/s/$with_gif/no/' autoconf/configure.in || die #253259
- sed -i -e 's/install.bin install.alternative/install.bin/' src/afterstep/Makefile.in || die #568694
- epatch "${FILESDIR}"/${P}-gcc5.patch #574184
-
- pushd autoconf >/dev/null
- eautoreconf
- cp autoconf/config.h.in ./ || die
- cp configure ../ || die
- popd >/dev/null
-
- pushd libAfterBase >/dev/null
- eautoreconf
- popd >/dev/null
-}
-
-src_configure() {
- local myconf
-
- use debug && myconf="--enable-gdb --enable-warn --enable-gprof
- --enable-audit --enable-trace --enable-trace-x"
-
- # Explanation of configure options
- # ================================
- # --with-helpcommand="xterm -e man" - Avoid installing xiterm
- # --with-xpm - Contained in xfree
- # --disable-availability - So we can use complete paths for menuitems
- # --enable-ascp - The AfterStep ControlPanel is abandoned
- # LDCONFIG - bug #265841
-
- LDCONFIG=/bin/true econf \
- $(use_enable alsa) \
- $(use_enable cpu_flags_x86_mmx mmx-optimization) \
- $(use_enable nls i18n) \
- $(use_enable xinerama) \
- $(use_with dbus dbus1) \
- $(use_with gif) \
- $(use_with gtk) \
- $(use_with jpeg) \
- $(use_with png) \
- $(use_with tiff) \
- $(use_with svg) \
- --with-helpcommand="xterm -e man" \
- --disable-availability \
- --disable-staticlibs \
- --enable-ascp=no \
- ${myconf}
-}
-
-src_compile() {
- # gcc: ../libAfterConf/libAfterConf.a: No such file or directory
- # make[1]: *** [PrintDesktopEntries] Error 1
- emake -j1
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- # Create a symlink from MonitorWharf to Wharf
- rm "${D}"/usr/bin/MonitorWharf
- dosym /usr/bin/Wharf /usr/bin/MonitorWharf
-
- # Handle the documentation
- dodoc ChangeLog INSTALL NEW* README* TEAM
- cp -pPR TODO "${D}"/usr/share/doc/${PF}/
- dodir /usr/share/doc/${PF}/html
- cp -pPR doc/* "${D}"/usr/share/doc/${PF}/html
- rm "${D}"/usr/share/doc/${PF}/html/{Makefile*,afterstepdoc.in}
-
- insinto /usr/share/xsessions
- newins AfterStep.desktop.final AfterStep.desktop
-
- # For desktop managers like GDM or KDE
- exeinto /etc/X11/Sessions
- doexe "${FILESDIR}"/${PN}
-}