summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-09-30 22:09:25 +0200
committerPacho Ramos <pacho@gentoo.org>2018-09-30 22:10:14 +0200
commit15fc092d167cf65a470c0561de771b233351f694 (patch)
tree35d8b51405a9808b7d952901d769329a84c4a081 /x11-wm
parentx11-themes/e-gtk-theme: new package (diff)
downloadgentoo-15fc092d167cf65a470c0561de771b233351f694.tar.gz
gentoo-15fc092d167cf65a470c0561de771b233351f694.tar.bz2
gentoo-15fc092d167cf65a470c0561de771b233351f694.zip
x11-wm/mutter: Fix non-wayland build (#667244 by Denis Descheneaux)
Signed-off-by: Pacho Ramos <pacho@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/mutter/files/3.26.2-non-wayland-build.patch33
-rw-r--r--x11-wm/mutter/mutter-3.26.2-r1.ebuild3
2 files changed, 36 insertions, 0 deletions
diff --git a/x11-wm/mutter/files/3.26.2-non-wayland-build.patch b/x11-wm/mutter/files/3.26.2-non-wayland-build.patch
new file mode 100644
index 000000000000..a2a8d356e07e
--- /dev/null
+++ b/x11-wm/mutter/files/3.26.2-non-wayland-build.patch
@@ -0,0 +1,33 @@
+From 6cc48d8cbbf11fa82ec78cac0b29d52f05eabb60 Mon Sep 17 00:00:00 2001
+From: Ting-Wei Lan <lantw@src.gnome.org>
+Date: Sun, 24 Dec 2017 17:55:14 +0800
+Subject: [PATCH] build: Fix non-wayland builds
+
+meta_dnd_wayland_handle_end_modal is not available on non-wayland build.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=791916
+---
+ src/compositor/compositor.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/compositor/compositor.c b/src/compositor/compositor.c
+index 51d22bc17..aa49347c9 100644
+--- a/src/compositor/compositor.c
++++ b/src/compositor/compositor.c
+@@ -419,11 +419,13 @@ meta_end_modal_for_plugin (MetaCompositor *compositor,
+ meta_backend_ungrab_device (backend, META_VIRTUAL_CORE_POINTER_ID, timestamp);
+ meta_backend_ungrab_device (backend, META_VIRTUAL_CORE_KEYBOARD_ID, timestamp);
+
++#ifdef HAVE_WAYLAND
+ if (meta_is_wayland_compositor ())
+ {
+ meta_dnd_wayland_handle_end_modal (compositor);
+ meta_display_sync_wayland_input_focus (display);
+ }
++#endif
+ }
+
+ static void
+--
+2.18.0
+
diff --git a/x11-wm/mutter/mutter-3.26.2-r1.ebuild b/x11-wm/mutter/mutter-3.26.2-r1.ebuild
index 71a77b248294..209182f780be 100644
--- a/x11-wm/mutter/mutter-3.26.2-r1.ebuild
+++ b/x11-wm/mutter/mutter-3.26.2-r1.ebuild
@@ -81,6 +81,9 @@ DEPEND="${RDEPEND}
PATCHES=(
# Lots of patches from gnome-3-26 branch on top of 3.26.2
"${WORKDIR}"/patches/
+
+ # Fix non-wayland builds, bug #667244
+ "${FILESDIR}"/${PV}-non-wayland-build.patch
)
src_prepare() {