summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2018-05-31 18:46:57 +0200
committerChema Alonso Josa <nimiux@gentoo.org>2018-05-31 18:46:57 +0200
commit1e775b40de919fcfae5136f0b3981fc811a7ba80 (patch)
tree800af3b337c99e1742dd5da3b6370da9d4a4e6ce /x11-wm
parentsys-fs/zfs-kmod: Remove reiser4 blocker from 9999 ebuilds (diff)
downloadgentoo-1e775b40de919fcfae5136f0b3981fc811a7ba80.tar.gz
gentoo-1e775b40de919fcfae5136f0b3981fc811a7ba80.tar.bz2
gentoo-1e775b40de919fcfae5136f0b3981fc811a7ba80.zip
x11-wm/stumpwm: Bump version to 18.05
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/stumpwm/Manifest1
-rw-r--r--x11-wm/stumpwm/stumpwm-18.05.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/x11-wm/stumpwm/Manifest b/x11-wm/stumpwm/Manifest
index 86244f097dff..1f6eb268fc1f 100644
--- a/x11-wm/stumpwm/Manifest
+++ b/x11-wm/stumpwm/Manifest
@@ -1 +1,2 @@
DIST stumpwm-1.0.1_rc.tar.gz 197530 BLAKE2B 2883ee8a0f75d3c673f6b6f65675c98e9fad8ef181b3ed9cf8bbd5eed7c0d63f3f48d021d056265d4e6c14dd0594bfe3a36492cd9bcdf2b3379d2aa62eba1f67 SHA512 3ba68987e61bdb46fde9c6bbed82b630be1db3272bdfb844a9d7abf3f810e94e560a28d4951308cab5af1f93b35710b10bb1a1a35450a8445a1b959888266df2
+DIST stumpwm-18.05.tar.gz 199467 BLAKE2B d532a531b7ceec7a80be66563dc2f36a6f1957d1e0f014ccf61cac1edf23073370dbe7cf3d7004f6dab144a88a4b54360e82ce7b13bdbc40cba59adfcb8e8af1 SHA512 a28c0af3a82670c0f31a5839227301672cc0706c47fb353355f90f791944556fb6125f3fa4d8547e6fbcf4817cdac5b0fe47de2dbae3a304d631a895af6ddb35
diff --git a/x11-wm/stumpwm/stumpwm-18.05.ebuild b/x11-wm/stumpwm/stumpwm-18.05.ebuild
new file mode 100644
index 000000000000..1da69a1a8997
--- /dev/null
+++ b/x11-wm/stumpwm/stumpwm-18.05.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit common-lisp-3 autotools elisp-common xdg-utils versionator
+
+DESCRIPTION="Stumpwm is a Window Manager written entirely in Common Lisp."
+HOMEPAGE="https://stumpwm.github.io/"
+SRC_URI="https://github.com/stumpwm/stumpwm/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="contrib doc emacs"
+
+RESTRICT="strip mirror"
+
+RDEPEND="dev-lisp/alexandria
+ dev-lisp/cl-ppcre
+ dev-lisp/clx
+ >=dev-lisp/sbcl-1.3.0
+ emacs? ( virtual/emacs app-emacs/slime )"
+DEPEND="${RDEPEND}
+ sys-apps/texinfo
+ doc? ( virtual/texi2dvi )"
+
+PDEPEND="contrib? ( x11-wm/stumpwm-contrib )"
+
+SITEFILE=70${PN}-gentoo.el
+CLPKGDIR="${CLSOURCEROOT}/${CLPACKAGE}"
+
+install_docs() {
+ local pdffile="${PN}.pdf"
+
+ texi2pdf -o "${pdffile}" "${PN}.texi.in" && dodoc "${pdffile}" || die
+ cp "${FILESDIR}/README.Gentoo" . && sed -i "s:@VERSION@:${PV}:" README.Gentoo || die
+ dodoc AUTHORS NEWS README.md README.Gentoo
+ doinfo "${PN}.info"
+ docinto examples
+ dodoc sample-stumpwmrc.lisp
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ xdg_environment_reset
+ econf --with-lisp=sbcl
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ dobin stumpwm
+ make_session_desktop StumpWM /usr/bin/stumpwm
+
+ common-lisp-install-sources *.lisp
+ common-lisp-install-asdf
+ # Fix ASDF dir
+ sed -i -e "/(:directory/c\ (:directory \"${CLPKGDIR}\")" \
+ "${D}${CLPKGDIR}/load-stumpwm.lisp" || die
+ use doc && install_docs
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}