summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2016-07-14 12:27:55 +0800
committerJason Zaman <perfinion@gentoo.org>2016-07-14 12:27:55 +0800
commit9f8ea77498fedffdb1964ed9ccb1b2f134e453a2 (patch)
treeb471cb184d2d785314568298f69440713de05ce2 /xfce-extra/xfce4-alsa-plugin
parentapp-emulation/lxd: Revbump to add missing dep (diff)
downloadgentoo-9f8ea77498fedffdb1964ed9ccb1b2f134e453a2.tar.gz
gentoo-9f8ea77498fedffdb1964ed9ccb1b2f134e453a2.tar.bz2
gentoo-9f8ea77498fedffdb1964ed9ccb1b2f134e453a2.zip
xfce-extra/xfce4-alsa-plugin: Initial commit, ebuild by me
Package-Manager: portage-2.2.28
Diffstat (limited to 'xfce-extra/xfce4-alsa-plugin')
-rw-r--r--xfce-extra/xfce4-alsa-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-alsa-plugin/metadata.xml11
-rw-r--r--xfce-extra/xfce4-alsa-plugin/xfce4-alsa-plugin-0.1.1.ebuild34
3 files changed, 46 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-alsa-plugin/Manifest b/xfce-extra/xfce4-alsa-plugin/Manifest
new file mode 100644
index 000000000000..367d82e6b872
--- /dev/null
+++ b/xfce-extra/xfce4-alsa-plugin/Manifest
@@ -0,0 +1 @@
+DIST xfce4-alsa-plugin-0.1.1.tar.gz 126701 SHA256 38a6b5aeb1664a0bb7ee49cc8b77070f0219362784281b6b55ec8afdb88a2956 SHA512 05273467944a08dd87455fcf20da0292899ace7254afcd2eb141c8d3f10996ad8ee08c6e61abb0178f65d52b066b0804e05a579d0a7f7e65b46fe5c4fd744fd7 WHIRLPOOL 3402886fb90a81622ba1eddccd36a76daeddb0722a88bf23c9bbe9ec2ac97503f3e77abb70572ac0dcf36997ab1d23f2362c3286db7f4bdd30ff1a3f6fbfff21
diff --git a/xfce-extra/xfce4-alsa-plugin/metadata.xml b/xfce-extra/xfce4-alsa-plugin/metadata.xml
new file mode 100644
index 000000000000..0838a771d6db
--- /dev/null
+++ b/xfce-extra/xfce4-alsa-plugin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">equeim/xfce4-alsa-plugin</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/xfce-extra/xfce4-alsa-plugin/xfce4-alsa-plugin-0.1.1.ebuild b/xfce-extra/xfce4-alsa-plugin/xfce4-alsa-plugin-0.1.1.ebuild
new file mode 100644
index 000000000000..d1b29c851ee9
--- /dev/null
+++ b/xfce-extra/xfce4-alsa-plugin/xfce4-alsa-plugin-0.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+PYTHON_REQ_USE='threads(+)' # required by waf
+
+inherit python-any-r1 vala waf-utils
+
+DESCRIPTION="Simple ALSA volume control for xfce4-panel"
+HOMEPAGE="https://github.com/equeim/xfce4-alsa-plugin"
+SRC_URI="https://github.com/equeim/${PN}/archive/0.1.1.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib
+ xfce-base/xfce4-panel
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-util/intltool
+ dev-lang/vala"
+
+pkg_setup() { python-any-r1_pkg_setup; }
+
+src_prepare() {
+ vala_src_prepare --ignore-use
+ eapply_user
+}