summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-05-04 19:57:15 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-05-04 19:57:15 +0200
commita78bbc4236ed08c205b57be153c900f9f6e7d32c (patch)
tree85555d0ac918349e1a82714e1efbc670279020d2 /xfce-extra/xfce4-diskperf-plugin
parentsys-apps/portage: version bump to 2.3.36 (diff)
downloadgentoo-a78bbc4236ed08c205b57be153c900f9f6e7d32c.tar.gz
gentoo-a78bbc4236ed08c205b57be153c900f9f6e7d32c.tar.bz2
gentoo-a78bbc4236ed08c205b57be153c900f9f6e7d32c.zip
xfce-extra/xfce4-diskperf-plugin: Add patch to avoid name clash, bug 611418
Patch by Nico R. Closes: https://bugs.gentoo.org/611418 Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'xfce-extra/xfce4-diskperf-plugin')
-rw-r--r--xfce-extra/xfce4-diskperf-plugin/files/xfce4-diskperf-plugin-2.6.1-majorminor.patch58
-rw-r--r--xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.6.1.ebuild2
2 files changed, 60 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-diskperf-plugin/files/xfce4-diskperf-plugin-2.6.1-majorminor.patch b/xfce-extra/xfce4-diskperf-plugin/files/xfce4-diskperf-plugin-2.6.1-majorminor.patch
new file mode 100644
index 000000000000..c0515f1558be
--- /dev/null
+++ b/xfce-extra/xfce4-diskperf-plugin/files/xfce4-diskperf-plugin-2.6.1-majorminor.patch
@@ -0,0 +1,58 @@
+From: Nico R. <n-roeser@gmx.net>
+Date: Sun, 28 Jan 2018 15:15:07 +0100
+Subject: [PATCH] work around glibc namespace pollution
+
+---
+ panel-plugin/devperf.c | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/panel-plugin/devperf.c b/panel-plugin/devperf.c
+index 29bcb87..95d2f0e 100644
+--- a/panel-plugin/devperf.c
++++ b/panel-plugin/devperf.c
+@@ -69,7 +69,7 @@ static int DevGetPerfData1 (dev_t p_iDevice, struct devperf_t *p_poPerf)
+ iMinorNo = minor(p_iDevice);
+ struct timeval oTimeStamp;
+ FILE *pF;
+- unsigned int major, minor, rsect, wsect, ruse, wuse, use;
++ unsigned int majorNo, minorNo, rsect, wsect, ruse, wuse, use;
+ int running;
+ char acStats[128];
+ int c, n;
+@@ -80,10 +80,10 @@ static int DevGetPerfData1 (dev_t p_iDevice, struct devperf_t *p_poPerf)
+ return (-1);
+ }
+ while (1) {
+- n = fscanf (pF, "%u %u", &major, &minor);
++ n = fscanf (pF, "%u %u", &majorNo, &minorNo);
+ if (n != 2)
+ goto Error;
+- if ((major != iMajorNo) || (minor != iMinorNo)) {
++ if ((majorNo != iMajorNo) || (minorNo != iMinorNo)) {
+ while ((c = fgetc (pF)) && (c != '\n')); /* Goto next line */
+ continue;
+ }
+@@ -126,7 +126,7 @@ static int DevGetPerfData2 (dev_t p_iDevice, struct devperf_t *p_poPerf)
+ iMinorNo = p_iDevice & 0xFF;
+ struct timeval oTimeStamp;
+ FILE *pF;
+- unsigned int major, minor, rsect, wsect, ruse, wuse, use;
++ unsigned int majorNo, minorNo, rsect, wsect, ruse, wuse, use;
+ int running;
+ int c, n;
+
+@@ -138,9 +138,9 @@ static int DevGetPerfData2 (dev_t p_iDevice, struct devperf_t *p_poPerf)
+ while ((c = fgetc (pF)) && (c != '\n')); /* Skip the header line */
+ while ((n = fscanf (pF,
+ "%u %u %*u %*s %*u %*u %u %u %*u %*u %u %u %d %u %*u",
+- &major, &minor, &rsect, &ruse, &wsect,
++ &majorNo, &minorNo, &rsect, &ruse, &wsect,
+ &wuse, &running, &use)) == 8)
+- if ((major == iMajorNo) && (minor == iMinorNo)) {
++ if ((majorNo == iMajorNo) && (minorNo == iMinorNo)) {
+ fclose (pF);
+ gettimeofday (&oTimeStamp, 0);
+ p_poPerf->timestamp_ns =
+--
+2.16.1
+
diff --git a/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.6.1.ebuild b/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.6.1.ebuild
index ebebf4412337..54497d9226f2 100644
--- a/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.6.1.ebuild
+++ b/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.6.1.ebuild
@@ -23,6 +23,8 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS ChangeLog NEWS README )
+PATCHES=( "${FILESDIR}/${P}-majorminor.patch" )
+
pkg_preinst() {
gnome2_icon_savelist
}