summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-04-09 16:28:19 +0200
committerMichał Górny <mgorny@gentoo.org>2019-04-09 16:33:24 +0200
commite0c3af9f0d0fd5bd0a3757b43fec0d14cc5081ee (patch)
tree1a3d931b848f308d979c7791533b3074df3e6d3b /xfce-extra/xfce4-places-plugin
parentxfce-extra/xfce4-notes-plugin: Bump to EAPI 7, port off xfconf (diff)
downloadgentoo-e0c3af9f0d0fd5bd0a3757b43fec0d14cc5081ee.tar.gz
gentoo-e0c3af9f0d0fd5bd0a3757b43fec0d14cc5081ee.tar.bz2
gentoo-e0c3af9f0d0fd5bd0a3757b43fec0d14cc5081ee.zip
xfce-extra/xfce4-places-plugin: Bump to EAPI 7, port off xfconf
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-places-plugin')
-rw-r--r--xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.7.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.7.0-r1.ebuild b/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.7.0-r1.ebuild
new file mode 100644
index 000000000000..7a8330de60d8
--- /dev/null
+++ b/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.7.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A panel plug-in to provide quick access to files, folders and removable media"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-places-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="libnotify"
+
+RDEPEND=">=dev-libs/glib-2.28:2
+ >=x11-libs/gtk+-2.20:2
+ x11-libs/libX11:=
+ >=xfce-base/exo-0.6:=
+ >=xfce-base/libxfce4ui-4.8:=
+ >=xfce-base/libxfce4util-4.8:=
+ >=xfce-base/xfce4-panel-4.8:=
+ >=xfce-base/xfconf-4.8:=
+ libnotify? ( >=x11-libs/libnotify-0.7:= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable libnotify notifications)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}