summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /xfce-extra/xfce4-vala
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'xfce-extra/xfce4-vala')
-rw-r--r--xfce-extra/xfce4-vala/Manifest1
-rw-r--r--xfce-extra/xfce4-vala/metadata.xml8
-rw-r--r--xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r1.ebuild41
-rw-r--r--xfce-extra/xfce4-vala/xfce4-vala-4.10.3.ebuild41
4 files changed, 91 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-vala/Manifest b/xfce-extra/xfce4-vala/Manifest
new file mode 100644
index 000000000000..0dfa5463b1be
--- /dev/null
+++ b/xfce-extra/xfce4-vala/Manifest
@@ -0,0 +1 @@
+DIST xfce4-vala-4.10.3.tar.bz2 88023 SHA256 07a8f2b7c09fcdd3d86e0c52adea3c58ca011d0142a93997a01b4af77260ae7b SHA512 ef5d6c67d53edc428ed10e59c21a1264a0d6d06efbea531a15f2eb1309e632e3cd275657aeb01c5723f437b9c319b922055598f97b0ee7db45853beef4f4d987 WHIRLPOOL 8fbb909f3177e2bba8108d7a509c6c49171125596d72fc5484360dd3cb66ec2be0706ab3c084c92a12a1fdbe3355986e12763bf2be4a6fcf908b4e52ff65ee1f
diff --git a/xfce-extra/xfce4-vala/metadata.xml b/xfce-extra/xfce4-vala/metadata.xml
new file mode 100644
index 000000000000..008cf479f615
--- /dev/null
+++ b/xfce-extra/xfce4-vala/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r1.ebuild b/xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r1.ebuild
new file mode 100644
index 000000000000..bd49af06a7ce
--- /dev/null
+++ b/xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+MY_VALA_VERSION=0.26
+VALA_MIN_API_VERSION=${MY_VALA_VERSION}
+VALA_MAX_API_VERSION=${MY_VALA_VERSION}
+VALA_USE_DEPEND=vapigen
+inherit xfconf vala
+
+DESCRIPTION="Vala bindings for the Xfce desktop environment"
+HOMEPAGE="http://wiki.xfce.org/vala-bindings"
+SRC_URI="mirror://xfce/src/bindings/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+RDEPEND="$(vala_depend)
+ >=xfce-base/exo-0.10
+ >=xfce-base/garcon-0.2
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfce4-panel-4.10
+ >=xfce-base/xfconf-4.10"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+ XFCONF=(
+ --with-vala-api=${MY_VALA_VERSION}
+ )
+}
+
+src_prepare() {
+ xfconf_src_prepare
+ vala_src_prepare
+}
diff --git a/xfce-extra/xfce4-vala/xfce4-vala-4.10.3.ebuild b/xfce-extra/xfce4-vala/xfce4-vala-4.10.3.ebuild
new file mode 100644
index 000000000000..62e810f3dc26
--- /dev/null
+++ b/xfce-extra/xfce4-vala/xfce4-vala-4.10.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+MY_VALA_VERSION=0.20
+VALA_MIN_API_VERSION=${MY_VALA_VERSION}
+VALA_MAX_API_VERSION=${MY_VALA_VERSION}
+VALA_USE_DEPEND=vapigen
+inherit xfconf vala
+
+DESCRIPTION="Vala bindings for the Xfce desktop environment"
+HOMEPAGE="http://wiki.xfce.org/vala-bindings"
+SRC_URI="mirror://xfce/src/bindings/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="$(vala_depend)
+ >=xfce-base/exo-0.10
+ >=xfce-base/garcon-0.2
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfce4-panel-4.10
+ >=xfce-base/xfconf-4.10"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+ XFCONF=(
+ --with-vala-api=${MY_VALA_VERSION}
+ )
+}
+
+src_prepare() {
+ xfconf_src_prepare
+ vala_src_prepare
+}