summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-10-08 10:50:11 +0200
committerPacho Ramos <pacho@gentoo.org>2016-10-08 11:50:14 +0200
commit90296a306c1785fa1988d32ca66f11bb108fad5e (patch)
treea6f87a3320e12b4de0bde621e2d9d8c8d1ad5c63 /xfce-extra/xfce4-vala
parentapp-misc/pdfpc: Support vala:0.32 (diff)
downloadgentoo-90296a306c1785fa1988d32ca66f11bb108fad5e.tar.gz
gentoo-90296a306c1785fa1988d32ca66f11bb108fad5e.tar.bz2
gentoo-90296a306c1785fa1988d32ca66f11bb108fad5e.zip
xfce-extra/xfce4-vala: Support vala:0.32
Package-Manager: portage-2.3.1
Diffstat (limited to 'xfce-extra/xfce4-vala')
-rw-r--r--xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r3.ebuild b/xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r3.ebuild
new file mode 100644
index 000000000000..7d2f914e3619
--- /dev/null
+++ b/xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+MY_VALA_VERSION=0.32
+VALA_MIN_API_VERSION=${MY_VALA_VERSION}
+VALA_MAX_API_VERSION=${MY_VALA_VERSION}
+VALA_USE_DEPEND=vapigen
+inherit xfconf vala
+
+DESCRIPTION="Vala bindings for the Xfce desktop environment"
+HOMEPAGE="https://wiki.xfce.org/vala-bindings"
+SRC_URI="mirror://xfce/src/bindings/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="$(vala_depend)
+ >=xfce-base/exo-0.10
+ >=xfce-base/garcon-0.2
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfce4-panel-4.10
+ >=xfce-base/xfconf-4.10"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+ XFCONF=(
+ --with-vala-api=${MY_VALA_VERSION}
+ )
+}
+
+src_prepare() {
+ xfconf_src_prepare
+ vala_src_prepare
+}