summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-02-01 22:03:00 +0100
committerPacho Ramos <pacho@gentoo.org>2016-02-01 22:05:06 +0100
commitbd2f768fdde28bca3636031add0bd1217b9ca52e (patch)
treee1378d14bca89b3e1f9187907dbc7ca9fc51e29b /xfce-extra/xfce4-vala
parentmedia-gfx/shotwell: Support vala-0.30 (diff)
downloadgentoo-bd2f768fdde28bca3636031add0bd1217b9ca52e.tar.gz
gentoo-bd2f768fdde28bca3636031add0bd1217b9ca52e.tar.bz2
gentoo-bd2f768fdde28bca3636031add0bd1217b9ca52e.zip
xfce-extra/xfce4-vala: Support vala-0.30
Package-Manager: portage-2.2.27
Diffstat (limited to 'xfce-extra/xfce4-vala')
-rw-r--r--xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r2.ebuild b/xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r2.ebuild
new file mode 100644
index 000000000000..d97a01bc0809
--- /dev/null
+++ b/xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+MY_VALA_VERSION=0.30
+VALA_MIN_API_VERSION=${MY_VALA_VERSION}
+VALA_MAX_API_VERSION=${MY_VALA_VERSION}
+VALA_USE_DEPEND=vapigen
+inherit xfconf vala
+
+DESCRIPTION="Vala bindings for the Xfce desktop environment"
+HOMEPAGE="https://wiki.xfce.org/vala-bindings"
+SRC_URI="mirror://xfce/src/bindings/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="$(vala_depend)
+ >=xfce-base/exo-0.10
+ >=xfce-base/garcon-0.2
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfce4-panel-4.10
+ >=xfce-base/xfconf-4.10"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+ XFCONF=(
+ --with-vala-api=${MY_VALA_VERSION}
+ )
+}
+
+src_prepare() {
+ xfconf_src_prepare
+ vala_src_prepare
+}