summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-09-24 18:16:54 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-24 18:29:31 +0200
commit3cd65a4f0bfac27c31b4e52dacd0eb660756a07e (patch)
tree44eb1467fb55088b5dbfc929ed4092c141f4d81e /xfce-extra/xfce4-weather-plugin
parentdev-util/squashdelta: Bump to 0.1.1 (bugfix/refactor) (diff)
downloadgentoo-3cd65a4f0bfac27c31b4e52dacd0eb660756a07e.tar.gz
gentoo-3cd65a4f0bfac27c31b4e52dacd0eb660756a07e.tar.bz2
gentoo-3cd65a4f0bfac27c31b4e52dacd0eb660756a07e.zip
xfce-extra/xfce4-weather-plugin: Bump to 0.9.0 (GTK+3 port)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-weather-plugin')
-rw-r--r--xfce-extra/xfce4-weather-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.9.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-weather-plugin/Manifest b/xfce-extra/xfce4-weather-plugin/Manifest
index fad9cadb7e77..b3a8139ef373 100644
--- a/xfce-extra/xfce4-weather-plugin/Manifest
+++ b/xfce-extra/xfce4-weather-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-weather-plugin-0.8.10.tar.bz2 2991350 BLAKE2B c3c71952a196d49068bac9c1de0695d2845db6931cfe220caf5ebb88919eb40fa0fc9c9a6dc640adbd82fa284449daf6ac537aaf5d258108083b2e63d8288610 SHA512 e40f794e824cc48038ece0c1336eed21b2e28091b86a4b76099c092c2e45abc5041d010d286f64fc483e8ad7c496127152df86330187afbd0872506d89f37c35
+DIST xfce4-weather-plugin-0.9.0.tar.bz2 2953904 BLAKE2B 6d8cf9b4d58b538b89ff72149e065d744f38333de9636baf0209bd49db130a3a0dd035a4c5c216bbd41302511a2784fff1d0ea90722d1d0409a44de0cfcb17aa SHA512 2a6fbeceb99d809cc4a928d0d53f92c7c638adbdc78d39dc2857b3506fb4287291702f078b547752176e0d2660a6365b62a7d8459ab88bea744dee28268e326a
diff --git a/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.9.0.ebuild b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.9.0.ebuild
new file mode 100644
index 000000000000..07104d920809
--- /dev/null
+++ b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.9.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="A weather plug-in for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="upower"
+
+RDEPEND=">=dev-libs/glib-2.42
+ dev-libs/libxml2:=
+ >=net-libs/libsoup-2.42:=[ssl]
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfce4-panel-4.12:=
+ upower? ( || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils ) )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ # For GEONAMES_USERNAME, read README file and ask ssuominen@!
+ local myconf=(
+ $(use_enable upower)
+ GEONAMES_USERNAME=Gentoo
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}