summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pydns/Manifest1
-rw-r--r--dev-python/pydns/pydns-2.3.6-r1.ebuild52
2 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/pydns/Manifest b/dev-python/pydns/Manifest
index 7d6690ee4213..28bc0e3b2cf2 100644
--- a/dev-python/pydns/Manifest
+++ b/dev-python/pydns/Manifest
@@ -1,3 +1,2 @@
DIST py3dns-3.1.1.tar.gz 29981 BLAKE2B b8f1aaeb95764f4d332ec05a367557a24fdd9171e98349668995687052cbd392169a76aaf24e3d29c94ca1c232f04842b84a2320eab5e553de12c278af23975c SHA512 5f22ba12db502f997be4c2479697cc21fe15aac218da1d347bd400a3ab73d86ad32b57740292a10eacb73e07eba977f67b881e59be16f902afab47053efd6c6e
DIST py3dns-3.2.1.tar.gz 30691 BLAKE2B 336ed91a3bf8b33db258667ac96eba6df361bb2a8f24c433dbc6754ea32a7284ce0463c392c1392538eed9d8bf9ea3f09400bc08f1970a7c96c52bf072606718 SHA512 22f16c571f9fad02a70a8e0bbbfd802f4f9af23946edb78e15f69f23e57411369274945a1dea5603acae1fc1eb404e5445207c541afb7864a60b92dc4d5477b3
-DIST pydns-2.3.6.tar.gz 28220 BLAKE2B 81d48c57bc90641c2e1667a951e3af3dc75dc1055e6f3f7b45e57d66bb1d391fc55ef0fa9fd261821de22c9119564cfc2b5a18f7a9780fe708b676c427824261 SHA512 261598c085c7d9f7adf5ce881814e444cdcf48a946dc17db467268ab6164f6045c204507cc58eff8e6f826b9786715ad2a9e766a72193ac8666969913180954b
diff --git a/dev-python/pydns/pydns-2.3.6-r1.ebuild b/dev-python/pydns/pydns-2.3.6-r1.ebuild
deleted file mode 100644
index 39a11692e28b..000000000000
--- a/dev-python/pydns/pydns-2.3.6-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python module for DNS (Domain Name Service)"
-HOMEPAGE="http://pydns.sourceforge.net/ https://pypi.org/project/pydns/"
-SRC_URI="http://downloads.sourceforge.net/project/pydns/pydns/${P}/${P}.tar.gz"
-
-LICENSE="CNRI"
-SLOT="2"
-KEYWORDS="amd64 hppa ~ia64 ~ppc ~sparc x86"
-IUSE="examples"
-
-DEPEND="!dev-python/pydns:0
- virtual/libiconv"
-RDEPEND=""
-
-# Funny a dns package attempts to use the network on tests
-# Await the day that gentoo chills out on such a blanket law.
-RESTRICT=test
-
-python_prepare_all() {
- # Fix encodings (should be utf-8 but is latin1).
- local i
- for i in DNS/{Lib,Type}.py; do
- iconv -f ISO-8859-1 -t UTF-8 "${i}" > "${i}.utf8" || die
- mv -f "${i}.utf8" "${i}" || die
- done
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local test
- for test in tests/{test.py,test[2-5].py,testsrv.py}
- do
- "${PYTHON}" $test || die
- done
-}
-
-python_install_all() {
- if use examples; then
- docinto examples
- dodoc -r tests/. tools/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}