summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/mousepad/Manifest1
-rw-r--r--app-editors/mousepad/mousepad-0.5.6.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-editors/mousepad/Manifest b/app-editors/mousepad/Manifest
index 4fe301720c6c..b4fb13f76949 100644
--- a/app-editors/mousepad/Manifest
+++ b/app-editors/mousepad/Manifest
@@ -1 +1,2 @@
DIST mousepad-0.5.5.tar.bz2 891263 BLAKE2B a75930385f9087f6294811c91b2a162d2e9ca2e945ec84efdfd932806211ee105d2ac2835122c2de4ea519b6728959478147d11df75ff3b00324c262983046a0 SHA512 5c6d6d048fe8a08c04ddeff7adb7d621d9beac631dd58fe5778cc8236e06ddb4ab50380eaebf4236c655b6d26058242024d5d3bbb1772607ab1f10744f8936f1
+DIST mousepad-0.5.6.tar.bz2 916738 BLAKE2B 59506a5eb362259889e580de52ed3135c339da4148dc1c99d7c7e6aee04d776f7ef67959a54aabfa29b7b174279f205cdaa0932199b407528019def24c4915c4 SHA512 24e974f793fd8660d39fc00156f8f8f07bae44133c6f58d705b1665f0b8d333f2248a6780b48794edb56e7faf7f206069a7866f76cbf91f6ce6b8b2ac7121f34
diff --git a/app-editors/mousepad/mousepad-0.5.6.ebuild b/app-editors/mousepad/mousepad-0.5.6.ebuild
new file mode 100644
index 000000000000..1dee543de886
--- /dev/null
+++ b/app-editors/mousepad/mousepad-0.5.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="GTK+-based editor for the Xfce Desktop Environment"
+HOMEPAGE="https://git.xfce.org/apps/mousepad/about/"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND=">=dev-libs/glib-2.52
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/gtksourceview-4.0.0:4"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --enable-gtksourceview4
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}