summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/PEAR-DB/Manifest1
-rw-r--r--dev-php/PEAR-DB/PEAR-DB-1.8.2.ebuild13
-rw-r--r--dev-php/PEAR-DB/PEAR-DB-1.9.2-r1.ebuild26
3 files changed, 26 insertions, 14 deletions
diff --git a/dev-php/PEAR-DB/Manifest b/dev-php/PEAR-DB/Manifest
index 11d3bacbaeca..e85a89df0deb 100644
--- a/dev-php/PEAR-DB/Manifest
+++ b/dev-php/PEAR-DB/Manifest
@@ -1,2 +1 @@
-DIST DB-1.8.2.tgz 131693 SHA256 51a4ad2bd3a5ec3590591013620bc81a89bc871d299599d4152681f5d2b1f125 SHA512 0af79e037964962d6e517d28aa6908de011ea8e1effd35c3f5250462e4a58e4253671f830171bb59f11a491957c44d2732f667cca9351a3bebb7595dc92f3055 WHIRLPOOL 0c2f51ba24b20f3a11020556a0fbff5155fce95961a33ae1e7367407909af9177965a2c9f7b6ec0cc90572f907cbeb312fe4bd8e83875facbdb1ca7afcf5d316
DIST DB-1.9.2.tgz 133795 SHA256 09a32b3eb7242accd61a8d8270596ab7486d2d63d2612ad51def696f7f2bd1b1 SHA512 126bbbb847a24c20731f1e5f4a549e9d7e0651a760f10c49cfc7550f80dd8b05f3560bc80110bcaab9e79dcbb714c6113948f14a727f7f4087a23178b3db0afa WHIRLPOOL 594d8a425b250a5501f1ffcff2e7cb19ddb88d70eaeff0749b0ad564dd2e9b7a90a94a0b4757e99a72631449965cfa8d7fc6d2c5beea78201822b1e05b1cdf41
diff --git a/dev-php/PEAR-DB/PEAR-DB-1.8.2.ebuild b/dev-php/PEAR-DB/PEAR-DB-1.8.2.ebuild
deleted file mode 100644
index eab4fd73d9c9..000000000000
--- a/dev-php/PEAR-DB/PEAR-DB-1.8.2.ebuild
+++ /dev/null
@@ -1,13 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit php-pear-r1
-
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
-
-DESCRIPTION="Database abstraction layer for PHP"
-LICENSE="PHP-3"
-SLOT="0"
-IUSE=""
diff --git a/dev-php/PEAR-DB/PEAR-DB-1.9.2-r1.ebuild b/dev-php/PEAR-DB/PEAR-DB-1.9.2-r1.ebuild
new file mode 100644
index 000000000000..ef5e7305e352
--- /dev/null
+++ b/dev-php/PEAR-DB/PEAR-DB-1.9.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="Database abstraction layer for PHP"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE="test"
+DEPEND="test? ( dev-php/PEAR-PEAR )"
+
+DOCS=( doc/TESTERS doc/IDEAS doc/MAINTAINERS doc/STATUS )
+
+src_test() {
+ # Requires the "pear" executable from dev-php/PEAR-PEAR, and also
+ # a working version of the cli SAPI eselected.
+ pear run-tests tests || die
+
+ # The command succeeds regardless of whether or not the test suite
+ # passed, but this file is only written when there was a failure.
+ [[ -f run-tests.log ]] && die "test suite failed"
+}