summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/albert/Manifest2
-rw-r--r--x11-misc/albert/albert-0.14.21.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/x11-misc/albert/Manifest b/x11-misc/albert/Manifest
index 4234b5fd5b10..b50d0be9837f 100644
--- a/x11-misc/albert/Manifest
+++ b/x11-misc/albert/Manifest
@@ -6,3 +6,5 @@ DIST albert-0.14.18-plugins.tar.gz 538138 BLAKE2B baa48198aabf0d5f4ffad46ce9243a
DIST albert-0.14.18.tar.gz 84883 BLAKE2B 706312cc3f29aaf9309c7cddb0f22aec2324560f78ed5a5418f6984e0a037b779d38be3d607c2fe287654b02db4aa125505b0716fc431e7bf679f108fa190555 SHA512 47110ba711b76d5d202a0b42c8442a5a242ca67869094bcb31daa5ca760b05e1b0ccdfbd88d5fdf3d23bb2838e3d4efbaf1a45733ae7612b0941360c2dfe5654
DIST albert-0.14.19-plugins.tar.gz 538257 BLAKE2B 74736ac5be02f98aa38b865499c264911da64d600dddfb11c90f4b701a56723648c48eb82e035fa751f2640749a2ce9c6fbf39fee44421f8e52023c05f2986b2 SHA512 b0f511e7ecaa48a40b0b3ec770946f9198f9649af1e9c1f428608140761ac5a7c6393932ac34ad093f2299134f623d83f6f10a313f497b1a37223eb7660b2b50
DIST albert-0.14.19.tar.gz 85203 BLAKE2B 3997b337fe3957d1e1ccdb62250085f70be462b93ebb68e65e70d2f83b30b2eea840983bbec76bc81a0d045a1600d1c1cc4c2ca2bb0933b6832e45373744a82a SHA512 bb3130aa93edb92008fa66ea527675d4cee89dff587ae07f6983c315be7c8bc2461491a771ba817de2d113c1eee98b3a7eb2d0b5e228811db06a28bef2e7bf30
+DIST albert-0.14.21-plugins.tar.gz 538315 BLAKE2B 84c482bd2c9a7dfe38927da4531727a361014d0a8f6e4da923904253d5a322c37837f9eb7873621fd55581be7b0c1c7149b005f7729606444a9fc8b8e96b70fd SHA512 ae680b3ea8292c49858d029a16fb3ee6b5c33a96351afb9e962538ebb4d39fd5b862fe6da5592b03bfdc3c9622671a0d1140d6924e36ea2b67842490ffd102b0
+DIST albert-0.14.21.tar.gz 85541 BLAKE2B c8ddf61f3f001e92b3c889c8a3b748cb45ccf06896c990f1937484917496cb78510c17b479e61af8fbfc13c2ddc84ede7f70de15e09246c7dca4876eb644b910 SHA512 dc1e1121abb3534d32775cd8c8e3b832c037e997588b7e0d7356d933f6a1d15c669c3f0362c9c2bfb37256d80cef4175c9c8d22a095b5191453a44e0f20f9cc6
diff --git a/x11-misc/albert/albert-0.14.21.ebuild b/x11-misc/albert/albert-0.14.21.ebuild
new file mode 100644
index 000000000000..e4a6b9e780d4
--- /dev/null
+++ b/x11-misc/albert/albert-0.14.21.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PLUGINS_HASH="67a7a34734c4665dcb1a504432de5d2e5a56ac90"
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="Desktop agnostic launcher"
+HOMEPAGE="https://albertlauncher.github.io/"
+# plugins is a git submodule. the hash is taken from the submodule reference in the ${PV} tag.
+SRC_URI="https://github.com/albertlauncher/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+https://github.com/albertlauncher/plugins/archive/${PLUGINS_HASH}.tar.gz -> ${P}-plugins.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+RDEPEND="
+ dev-cpp/muParser
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ x11-libs/libXext
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ mv "${WORKDIR}"/plugins-${PLUGINS_HASH}/* "${S}"/plugins/ || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DEBUG=$(usex debug)
+ -DBUILD_PYTHON=OFF #plugin directory is empty causing build failure
+ -DBUILD_VIRTUALBOX=OFF #plugin needs virtualbox installed to build, untested
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}