summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/supernova/Manifest2
-rw-r--r--app-admin/supernova/supernova-2.0.9.ebuild52
-rw-r--r--app-admin/supernova/supernova-2.1.0.ebuild51
3 files changed, 0 insertions, 105 deletions
diff --git a/app-admin/supernova/Manifest b/app-admin/supernova/Manifest
index 086efab3bfb6..4a18c5b41f6c 100644
--- a/app-admin/supernova/Manifest
+++ b/app-admin/supernova/Manifest
@@ -1,3 +1 @@
-DIST supernova-2.0.9.tar.gz 22877 BLAKE2B 02bb230c8392946bf43faedb19d8b5660a144f07b9ee4c3638f3211dcd25d2336c6a032a9c0b1006cc01ab61ea9d8e3769704ba034b676f0b115b32b39855b20 SHA512 8270f871efcf7c8741078e4658dd8413796a14bd9eb43514beb8b120462db757a5324c5c3c9e4988d8725ec9b903e7743c6ae336dd5f73536e1e0df456ba54a9
-DIST supernova-2.1.0.tar.gz 23196 BLAKE2B 70d41d42c8504075657aa869c666d6e8ec079c62535276a12e49687a139eec54d068ced7ee1f2bc18c8da708ec50edb11e2bdcdf324a36b9c309c3e134887e6d SHA512 fa4f6b3f0a3b5a19c309b507ce8c356a929c8a8cf805c45d58a8f4c1bc36f508a0d04477570cf79e7660e94d803df8a02e67206465e75eb3452e43cb6ca186aa
DIST supernova-2.2.0.tar.gz 24068 BLAKE2B 129c077baf9b415851f3c17eb5a9870ff2d8109a54c424d9039204620b6dd68d8f17183b5c52d863882bd2586ed03b7d1c397f70f337bfba9e9c8255b6feb578 SHA512 436ec13dfaf5ff7cadacc1dedc3545a579784cfce3b0c7925cc0d877ba76a4c865ad3687ae8ae22fdb11d880282dd555f9a9d709c005ad024299a34607fd8063
diff --git a/app-admin/supernova/supernova-2.0.9.ebuild b/app-admin/supernova/supernova-2.0.9.ebuild
deleted file mode 100644
index 1ddd3b07ee06..000000000000
--- a/app-admin/supernova/supernova-2.0.9.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="novaclient wrapper for multiple nova environments"
-HOMEPAGE="https://github.com/rackerhacker/supernova"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc examples test"
-
-CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="
- ${CDEPEND}
- doc? ( >=dev-python/mkdocs-0.14.0[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-RDEPEND="
- ${CDEPEND}
- dev-python/click[${PYTHON_USEDEP}]
- dev-python/configobj[${PYTHON_USEDEP}]
- >=dev-python/keyring-0.9.2[${PYTHON_USEDEP}]
- dev-python/python-novaclient[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-
-python_compile_all() {
- if use doc; then
- mkdocs build || die "docs failed to build"
- fi
-}
-
-python_test() {
- distutils_install_for_testing
- cd "${TEST_DIR}"/lib || die
- py.test || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( site/. )
- use examples && local EXAMPLES=( example_configs/. )
-
- distutils-r1_python_install_all
-
- newbashcomp contrib/${PN}-completion.bash ${PN}
-}
diff --git a/app-admin/supernova/supernova-2.1.0.ebuild b/app-admin/supernova/supernova-2.1.0.ebuild
deleted file mode 100644
index 148043720999..000000000000
--- a/app-admin/supernova/supernova-2.1.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="novaclient wrapper for multiple nova environments"
-HOMEPAGE="https://github.com/rackerhacker/supernova"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc examples test"
-
-CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="
- ${CDEPEND}
- doc? ( >=dev-python/mkdocs-0.14.0[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-RDEPEND="
- ${CDEPEND}
- dev-python/click[${PYTHON_USEDEP}]
- dev-python/configobj[${PYTHON_USEDEP}]
- >=dev-python/keyring-0.9.2[${PYTHON_USEDEP}]
- dev-python/python-novaclient[${PYTHON_USEDEP}]
- dev-python/rackspace-novaclient[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-
-python_compile_all() {
- if use doc; then
- mkdocs build || die "docs failed to build"
- fi
-}
-
-python_test() {
- py.test || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( site/. )
- use examples && local EXAMPLES=( example_configs/. )
-
- distutils-r1_python_install_all
-
- newbashcomp contrib/${PN}-completion.bash ${PN}
-}