summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-irc/ngircd/Manifest1
-rw-r--r--net-irc/ngircd/files/ngircd.init.d21
-rw-r--r--net-irc/ngircd/ngircd-20.3.ebuild80
-rw-r--r--net-irc/ngircd/ngircd-23.ebuild85
4 files changed, 0 insertions, 187 deletions
diff --git a/net-irc/ngircd/Manifest b/net-irc/ngircd/Manifest
index 0afd7e03c56b..098b7eb75b20 100644
--- a/net-irc/ngircd/Manifest
+++ b/net-irc/ngircd/Manifest
@@ -1,2 +1 @@
-DIST ngircd-20.3.tar.gz 479982 SHA256 55d7c74c6df790b11a68c07f39836d581965087efb618d3e9a6bec855364c2f9 SHA512 8bc36a66e893873fade6dcadb07bf561fb25156714ba30168cf2e399e50f4dd80592fd7fcdb6c8d1083fa7c5e839b0da3a27ed4ce2041a2c5ab2b9581def948c WHIRLPOOL 379ef30a2e23dfc3a523d85e9f2c1531b8079d0880b5f46b9cdb803af873fc943d25186ebc0b9294da26140b46a37a4ebd2b86f3c7cf17acd3a802e4a395dd1e
DIST ngircd-23.tar.gz 517686 SHA256 99b8b67a975a9ae9b81c96bdee02133a10f515c718825d34cedcb64f1fc95e73 SHA512 714fbb4af12335e62c615fa1e8de9c7366c4c6da6af9b334019ba900dce072067f7b08199de8c96aad5dd4b9b786b57d536ba9dc92c62b37d2ae11960dbd01b1 WHIRLPOOL 06e1b3a9675277c980898118e71e9a6c08de998c93919f431ecd7505f64dc57617beef885aae5e5c72b27cd1df3c89204dbc2101c1f4a30970fceb78a7825441
diff --git a/net-irc/ngircd/files/ngircd.init.d b/net-irc/ngircd/files/ngircd.init.d
deleted file mode 100644
index 7f0668272600..000000000000
--- a/net-irc/ngircd/files/ngircd.init.d
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-depend() {
- need net
- provide ircd
-}
-
-start() {
- ebegin "Starting ngIRCd"
- start-stop-daemon --start --quiet --exec /usr/sbin/ngircd
- eend $?
-}
-
-stop() {
- ebegin "Stopping ngIRCd"
- start-stop-daemon --stop --quiet --exec /usr/sbin/ngircd
- eend $?
-}
diff --git a/net-irc/ngircd/ngircd-20.3.ebuild b/net-irc/ngircd/ngircd-20.3.ebuild
deleted file mode 100644
index 1a7281c86a61..000000000000
--- a/net-irc/ngircd/ngircd-20.3.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit autotools-utils eutils user
-
-DESCRIPTION="A IRC server written from scratch"
-HOMEPAGE="http://ngircd.barton.de/"
-SRC_URI="ftp://ngircd.barton.de/pub/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 x86 ~x64-macos"
-IUSE="debug gnutls ident ipv6 pam ssl tcpd zlib"
-
-RDEPEND="
- ident? ( net-libs/libident )
- ssl? (
- gnutls? ( net-libs/gnutls )
- !gnutls? ( dev-libs/openssl )
- )
- pam? ( virtual/pam )
- tcpd? ( sys-apps/tcp-wrappers )
- zlib? ( sys-libs/zlib )
-"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4
-"
-
-RESTRICT="test"
-
-src_configure() {
- if ! use prefix; then
- sed -i \
- -e "s:;ServerUID = 65534:ServerUID = ngircd:" \
- -e "s:;ServerGID = 65534:ServerGID = nogroup:" \
- doc/sample-ngircd.conf.tmpl || die
- fi
-
- local myeconfargs=(
- --docdir="${EPREFIX}"/usr/share/doc/${PF}
- --sysconfdir="${EPREFIX}"/etc/ngircd
- $(use_enable ipv6)
- $(use_with zlib)
- $(use_with tcpd tcp-wrappers)
- $(use_with ident)
- $(use_with pam)
- $(use_enable debug)
- $(use_enable debug sniffer)
- )
-
- if use ssl; then
- myeconfargs+=(
- $(use_with !gnutls openssl)
- $(use_with gnutls)
- )
- else
- myeconfargs+=(
- --without-gnutls
- --without-ssl
- )
- fi
-
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
-
- newinitd "${FILESDIR}"/ngircd.init.d ngircd
-}
-
-pkg_postinst() {
- if ! use prefix; then
- enewuser ngircd
- chown ngircd "${ROOT}"/etc/ngircd/ngircd.conf
- fi
-}
diff --git a/net-irc/ngircd/ngircd-23.ebuild b/net-irc/ngircd/ngircd-23.ebuild
deleted file mode 100644
index 6e71ce910f30..000000000000
--- a/net-irc/ngircd/ngircd-23.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit autotools-utils eutils user
-
-DESCRIPTION="An IRC server written from scratch"
-HOMEPAGE="http://ngircd.barton.de/"
-SRC_URI="http://ngircd.barton.de/pub/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x64-macos"
-IUSE="debug gnutls iconv ident ipv6 libressl pam ssl tcpd zlib"
-
-RDEPEND="
- iconv? ( virtual/libiconv )
- ident? ( net-libs/libident )
- pam? ( virtual/pam )
- ssl? (
- !gnutls? (
- !libressl? ( dev-libs/openssl:0 )
- )
- gnutls? ( net-libs/gnutls )
- libressl? ( dev-libs/libressl )
- )
- tcpd? ( sys-apps/tcp-wrappers )
- zlib? ( sys-libs/zlib )
-"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4
-"
-
-RESTRICT="test"
-
-src_configure() {
- if ! use prefix; then
- sed -i \
- -e "s:;ServerUID = 65534:ServerUID = ngircd:" \
- -e "s:;ServerGID = 65534:ServerGID = nogroup:" \
- doc/sample-ngircd.conf.tmpl || die
- fi
-
- local myeconfargs=(
- --docdir="${EPREFIX}"/usr/share/doc/${PF}
- --sysconfdir="${EPREFIX}"/etc/ngircd
- $(use_enable debug sniffer)
- $(use_enable debug)
- $(use_enable ipv6)
- $(use_with iconv)
- $(use_with ident)
- $(use_with pam)
- $(use_with tcpd tcp-wrappers)
- $(use_with zlib)
- )
-
- if use ssl; then
- myeconfargs+=(
- $(use_with !gnutls openssl)
- $(use_with gnutls)
- )
- else
- myeconfargs+=(
- --without-gnutls
- --without-openssl
- )
- fi
-
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
-
- newinitd "${FILESDIR}"/ngircd.init.d ngircd
-}
-
-pkg_postinst() {
- if ! use prefix; then
- enewuser ngircd
- chown ngircd "${ROOT}"/etc/ngircd/ngircd.conf
- fi
-}