summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/perl/files/perl-patchlevel-manifest.patch10
-rw-r--r--dev-lang/perl/perl-5.24.1_rc4.ebuild6
2 files changed, 13 insertions, 3 deletions
diff --git a/dev-lang/perl/files/perl-patchlevel-manifest.patch b/dev-lang/perl/files/perl-patchlevel-manifest.patch
new file mode 100644
index 000000000000..3592ae0ee1ba
--- /dev/null
+++ b/dev-lang/perl/files/perl-patchlevel-manifest.patch
@@ -0,0 +1,10 @@
+--- a/MANIFEST
++++ b/MANIFEST
+@@ -4678,6 +4678,7 @@
+ pad.h Scratchpad headers
+ parser.h parser object header
++patchlevel-gentoo.h Gentoo's Perl patch level
+ patchlevel.h The current patch level of perl
+ perlapi.c Perl API functions
+ perlapi.h Perl API function declarations
+ perl.c main()
diff --git a/dev-lang/perl/perl-5.24.1_rc4.ebuild b/dev-lang/perl/perl-5.24.1_rc4.ebuild
index 47bd73ddc2a5..e560ac1a57b1 100644
--- a/dev-lang/perl/perl-5.24.1_rc4.ebuild
+++ b/dev-lang/perl/perl-5.24.1_rc4.ebuild
@@ -215,7 +215,6 @@ src_prepare_update_patchlevel_h() {
# it under the same terms as Perl itself.
local patchdir="${WORKDIR}/patches"
local prefix
- local patchoutput="patchlevel-gentoo.h"
[[ -f ${patchdir}/series ]] || return 0
@@ -253,8 +252,9 @@ do
# label: prepend to the hold space
:prepend x; H; d;
'
-done < "${WORKDIR}"/patches/series > "${S}/${patchoutput}"
-echo "${patchoutput}" >> "${S}/MANIFEST"
+done < "${WORKDIR}"/patches/series > "${S}/patchlevel-gentoo.h"
+
+ eapply "${FILESDIR}/perl-patchlevel-manifest.patch"
}
src_prepare() {