summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mate-base/mate-panel/Manifest1
-rw-r--r--mate-base/mate-panel/mate-panel-1.22.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/mate-base/mate-panel/Manifest b/mate-base/mate-panel/Manifest
index 26e787b7ee94..bdbee217e306 100644
--- a/mate-base/mate-panel/Manifest
+++ b/mate-base/mate-panel/Manifest
@@ -1 +1,2 @@
DIST mate-panel-1.18.7.tar.xz 1943216 BLAKE2B c811a299d612e11827f6531f3093addfeeb5a8f18449f76dba0f70233f072bd2666bb4cd8b39111da298fbdd966f5b7f21b37ce3fe4870129da0563faabc5a2f SHA512 6de91f16f5ade7873d2baf3d813bd77304723f27629474fdf37aa9c590b5fcb31452f5b117b52926dd53a38e9f8edd964c654fd29c8271131c6901eec46b5a31
+DIST mate-panel-1.22.0.tar.xz 2251040 BLAKE2B 6a4da6080cec2fc7858c711fa0a2c7497f4d03a1e22394f481925be32b17f7905920d4155ca75b9bf0d6bbf4af078aac77abc99e6d5a22e84bf453e2290ba032 SHA512 078c6dcdc17970a7a7fab9a218eaf2c8cd6c4074c0c23ff4ce7ccf57e007d0afcbe797be4ad4c9d2c16d9033cc554cc5a979ec61dc721514db939a5e60de456b
diff --git a/mate-base/mate-panel/mate-panel-1.22.0.ebuild b/mate-base/mate-panel/mate-panel-1.22.0.ebuild
new file mode 100644
index 000000000000..0243a59e92ad
--- /dev/null
+++ b/mate-base/mate-panel/mate-panel-1.22.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="The MATE panel"
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+
+IUSE="X +introspection"
+
+COMMON_DEPEND="
+ dev-libs/atk
+ >=dev-libs/dbus-glib-0.80:0
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libmateweather-1.17.0
+ dev-libs/libxml2:2
+ >=gnome-base/dconf-0.13.4
+ >=gnome-base/librsvg-2.36.2:2
+ >=mate-base/mate-desktop-1.17.0
+ >=mate-base/mate-menus-1.10.0
+ >=sys-apps/dbus-1.1.2
+ >=x11-libs/cairo-1
+ >=x11-libs/gdk-pixbuf-2.7.1:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ x11-libs/libICE
+ x11-libs/libSM
+ >=x11-libs/libwnck-3.0:3[introspection?]
+ x11-libs/libX11
+ >=x11-libs/pango-1.15.4:0[introspection?]
+ x11-libs/libXau
+ >=x11-libs/libXrandr-1.3
+ virtual/libintl
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ >=dev-lang/perl-5:=
+ dev-util/gdbus-codegen
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure \
+ --libexecdir=/usr/libexec/mate-applets \
+ --disable-deprecation-flags \
+ $(use_with X x) \
+ $(use_enable introspection)
+}