summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/tomahawk/Manifest1
-rw-r--r--media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-cmakepolicy.patch37
-rw-r--r--media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-findtaglib.patch244
-rw-r--r--media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-fix-warning.patch26
-rw-r--r--media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-qt-5.15.patch140
-rw-r--r--media-sound/tomahawk/metadata.xml11
-rw-r--r--media-sound/tomahawk/tomahawk-0.9.0_pre20181030.ebuild86
-rw-r--r--profiles/package.mask7
8 files changed, 0 insertions, 552 deletions
diff --git a/media-sound/tomahawk/Manifest b/media-sound/tomahawk/Manifest
deleted file mode 100644
index 9ff5a58e9902..000000000000
--- a/media-sound/tomahawk/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST tomahawk-0.9.0_pre20181030.tar.gz 9875208 BLAKE2B aa0b3955ab0308df5ff4d9fead1106bb26c12594fd958c0d43ff72da4d47de42dc4f96d64f3594828ee6200108b610a600b2b764e09b2e88c8412b22b7d6e605 SHA512 de08dc2873975c4278e36ef01ae516d106edc235ac8cf79dab8cc2338dd47cae3102aa6461c98146ca0ff3c68e1a507168a302a051103482f6636f5cdab97202
diff --git a/media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-cmakepolicy.patch b/media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-cmakepolicy.patch
deleted file mode 100644
index 7ddf116eeccc..000000000000
--- a/media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-cmakepolicy.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 663981b4dd28fca6cac0b079bed26c411e7d1722 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Fri, 25 Jan 2019 21:13:05 +0100
-Subject: [PATCH] Fix build with <cmake-3.10
-
----
- CMakeLists.txt | 8 ++++++--
- 1 file changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index b44d2ee43..9422a808e 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -2,14 +2,18 @@ PROJECT( tomahawk )
- CMAKE_MINIMUM_REQUIRED( VERSION 2.8.12 )
- CMAKE_POLICY(SET CMP0017 NEW)
- CMAKE_POLICY(SET CMP0022 NEW)
--CMAKE_POLICY(SET CMP0075 NEW)
-+IF(POLICY CMP0075)
-+ CMAKE_POLICY(SET CMP0075 NEW)
-+ENDIF()
-
- # TODO:
- # Update to NEW and fix things up
- CMAKE_POLICY(SET CMP0023 NEW)
-
- # Let AUTOMOC and AUTOUIC process generated files
--CMAKE_POLICY(SET CMP0071 NEW)
-+IF(POLICY CMP0071)
-+ CMAKE_POLICY(SET CMP0071 NEW)
-+ENDIF()
-
- # TODO:
- # Disable automatic qtmain linking
---
-2.20.1
-
diff --git a/media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-findtaglib.patch b/media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-findtaglib.patch
deleted file mode 100644
index 9a53e0d69020..000000000000
--- a/media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-findtaglib.patch
+++ /dev/null
@@ -1,244 +0,0 @@
-From 7c7b57e295aebcca9b09d8c5798e172cb8fd179c Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Mon, 13 Jul 2020 02:11:06 +0200
-Subject: [PATCH] Import FindTaglib.cmake from ECM 5.72.0
-
-This version of ECM gained a module that is overriding Tomahawk's own, but
-variables are incompatible. Use the updated ECM module until we can depend
-on the necessary ECM version itself.
-
-Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
----
- CMakeLists.txt | 2 +-
- CMakeModules/CheckTagLibFileName.cmake | 5 +-
- CMakeModules/FindTaglib.cmake | 173 +++++++++++++------------
- src/libtomahawk/CMakeLists.txt | 4 +-
- 4 files changed, 93 insertions(+), 91 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 9422a808e..2f1e72238 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -213,7 +213,7 @@ macro_optional_find_package(Lucene++ 3.0.0)
- macro_log_feature(LUCENEPP_FOUND "Lucene++" "The open-source, C++ search engine" "https://github.com/luceneplusplus/LucenePlusPlus/" TRUE "" "Lucene++ is used for indexing the collection")
-
- macro_optional_find_package(Taglib 1.8.0)
--macro_log_feature(TAGLIB_FOUND "TagLib" "Audio Meta-Data Library" "http://developer.kde.org/~wheeler/taglib.html" TRUE "" "taglib is needed for reading meta data from audio files")
-+macro_log_feature(Taglib_FOUND "TagLib" "Audio Meta-Data Library" "http://developer.kde.org/~wheeler/taglib.html" TRUE "" "taglib is needed for reading meta data from audio files")
- include( CheckTagLibFileName )
- check_taglib_filename( COMPLEX_TAGLIB_FILENAME )
-
-diff --git a/CMakeModules/CheckTagLibFileName.cmake b/CMakeModules/CheckTagLibFileName.cmake
-index e5b3706c9..7828dcf34 100644
---- a/CMakeModules/CheckTagLibFileName.cmake
-+++ b/CMakeModules/CheckTagLibFileName.cmake
-@@ -1,9 +1,8 @@
- # taglib changed filenames to be a char/wchar struct on some platforms, need to check for it
- macro (CHECK_TAGLIB_FILENAME TAGLIB_FILENAME_COMPLEX)
- include (CheckCXXSourceCompiles)
-- set (CMAKE_REQUIRED_FLAGS ${TAGLIB_CFLAGS})
-- set (CMAKE_REQUIRED_INCLUDES ${TAGLIB_INCLUDES})
-- set (CMAKE_REQUIRED_LIBRARIES ${TAGLIB_LIBRARIES})
-+ set (CMAKE_REQUIRED_INCLUDES ${Taglib_INCLUDE_DIRS})
-+ set (CMAKE_REQUIRED_LIBRARIES ${Taglib_LIBRARIES})
- check_cxx_source_compiles(
- "#include <tfile.h>
- int main()
-diff --git a/CMakeModules/FindTaglib.cmake b/CMakeModules/FindTaglib.cmake
-index d4ada2592..ad14c79cd 100644
---- a/CMakeModules/FindTaglib.cmake
-+++ b/CMakeModules/FindTaglib.cmake
-@@ -1,87 +1,90 @@
--# - Try to find the Taglib library
--# Once done this will define
-+#.rst:
-+# FindTaglib
-+# ----------
- #
--# TAGLIB_FOUND - system has the taglib library
--# TAGLIB_CFLAGS - the taglib cflags
--# TAGLIB_LIBRARIES - The libraries needed to use taglib
--
--# Copyright (c) 2006, Laurent Montel, <montel@kde.org>
-+# Try to find the Taglib library.
- #
--# Redistribution and use is allowed according to the terms of the BSD license.
--# For details see the accompanying COPYING-CMAKE-SCRIPTS file.
--
--IF(TAGLIB_FOUND)
-- MESSAGE(STATUS "Using manually specified taglib locations")
--ELSE()
--
-- if(NOT TAGLIB_MIN_VERSION)
-- set(TAGLIB_MIN_VERSION "1.6")
-- endif(NOT TAGLIB_MIN_VERSION)
--
-- if(NOT WIN32)
-- find_program(TAGLIBCONFIG_EXECUTABLE NAMES taglib-config PATHS
-- ${BIN_INSTALL_DIR}
-- )
-- endif(NOT WIN32)
--
-- #reset vars
-- set(TAGLIB_LIBRARIES)
-- set(TAGLIB_CFLAGS)
--
--# MESSAGE( STATUS "PATHS: ${PATHS}")
-- # if taglib-config has been found
-- if(TAGLIBCONFIG_EXECUTABLE)
--
-- exec_program(${TAGLIBCONFIG_EXECUTABLE} ARGS --version RETURN_VALUE _return_VALUE OUTPUT_VARIABLE TAGLIB_VERSION)
--
-- if(TAGLIB_VERSION VERSION_LESS "${TAGLIB_MIN_VERSION}")
-- message(STATUS "TagLib version not found: version searched :${TAGLIB_MIN_VERSION}, found ${TAGLIB_VERSION}")
-- set(TAGLIB_FOUND FALSE)
-- else(TAGLIB_VERSION VERSION_LESS "${TAGLIB_MIN_VERSION}")
--
-- exec_program(${TAGLIBCONFIG_EXECUTABLE} ARGS --libs RETURN_VALUE _return_VALUE OUTPUT_VARIABLE TAGLIB_LIBRARIES)
--
-- exec_program(${TAGLIBCONFIG_EXECUTABLE} ARGS --cflags RETURN_VALUE _return_VALUE OUTPUT_VARIABLE TAGLIB_CFLAGS)
--
-- if(TAGLIB_LIBRARIES AND TAGLIB_CFLAGS)
-- set(TAGLIB_FOUND TRUE)
--# message(STATUS "Found taglib: ${TAGLIB_LIBRARIES}")
-- endif(TAGLIB_LIBRARIES AND TAGLIB_CFLAGS)
-- string(REGEX REPLACE " *-I" ";" TAGLIB_INCLUDES "${TAGLIB_CFLAGS}")
-- endif(TAGLIB_VERSION VERSION_LESS "${TAGLIB_MIN_VERSION}")
-- mark_as_advanced(TAGLIB_CFLAGS TAGLIB_LIBRARIES TAGLIB_INCLUDES)
--
-- else(TAGLIBCONFIG_EXECUTABLE)
--
-- include(FindLibraryWithDebug)
-- include(FindPackageHandleStandardArgs)
--
-- find_path(TAGLIB_INCLUDES
-- NAMES
-- tag.h
-- PATH_SUFFIXES taglib
-- PATHS
-- ${INCLUDE_INSTALL_DIR}
-- )
--
-- find_library_with_debug(TAGLIB_LIBRARIES
-- WIN32_DEBUG_POSTFIX d
-- NAMES tag
-- PATHS
-- ${LIB_INSTALL_DIR}
-- )
--
-- find_package_handle_standard_args(Taglib DEFAULT_MSG
-- TAGLIB_INCLUDES TAGLIB_LIBRARIES)
-- endif(TAGLIBCONFIG_EXECUTABLE)
--ENDIF()
--
--if(TAGLIB_FOUND)
-- if(NOT Taglib_FIND_QUIETLY AND TAGLIBCONFIG_EXECUTABLE)
-- message(STATUS "Found TagLib: ${TAGLIB_LIBRARIES}")
-- endif(NOT Taglib_FIND_QUIETLY AND TAGLIBCONFIG_EXECUTABLE)
--else(TAGLIB_FOUND)
-- if(Taglib_FIND_REQUIRED)
-- message(FATAL_ERROR "Could not find Taglib")
-- endif(Taglib_FIND_REQUIRED)
--endif(TAGLIB_FOUND)
-+# This will define the following variables:
-+#
-+# ``Taglib_FOUND``
-+# True if the system has the taglib library of at least the minimum
-+# version specified by the version parameter to find_package()
-+# ``Taglib_INCLUDE_DIRS``
-+# The taglib include dirs for use with target_include_directories
-+# ``Taglib_LIBRARIES``
-+# The taglib libraries for use with target_link_libraries()
-+# ``Taglib_VERSION``
-+# The version of taglib that was found
-+#
-+# If ``Taglib_FOUND`` is TRUE, it will also define the following imported
-+# target:
-+#
-+# ``Taglib::Taglib``
-+# The Taglib library
-+#
-+# Since 5.72.0
-+#
-+# SPDX-FileCopyrightText: 2006 Laurent Montel <montel@kde.org>
-+# SPDX-FileCopyrightText: 2019 Heiko Becker <heirecka@exherbo.org>
-+# SPDX-FileCopyrightText: 2020 Elvis Angelaccio <elvis.angelaccio@kde.org>
-+# SPDX-License-Identifier: BSD-3-Clause
-+
-+find_package(PkgConfig QUIET)
-+
-+pkg_search_module(PC_TAGLIB QUIET taglib)
-+
-+find_path(Taglib_INCLUDE_DIRS
-+ NAMES tag.h
-+ PATH_SUFFIXES taglib
-+ HINTS ${PC_TAGLIB_INCLUDEDIR}
-+)
-+
-+find_library(Taglib_LIBRARIES
-+ NAMES tag
-+ HINTS ${PC_TAGLIB_LIBDIR}
-+)
-+
-+set(Taglib_VERSION ${PC_TAGLIB_VERSION})
-+
-+if (Taglib_INCLUDE_DIRS AND NOT Taglib_VERSION)
-+ if(EXISTS "${Taglib_INCLUDE_DIRS}/taglib.h")
-+ file(READ "${Taglib_INCLUDE_DIRS}/taglib.h" TAGLIB_H)
-+
-+ string(REGEX MATCH "#define TAGLIB_MAJOR_VERSION[ ]+[0-9]+" TAGLIB_MAJOR_VERSION_MATCH ${TAGLIB_H})
-+ string(REGEX MATCH "#define TAGLIB_MINOR_VERSION[ ]+[0-9]+" TAGLIB_MINOR_VERSION_MATCH ${TAGLIB_H})
-+ string(REGEX MATCH "#define TAGLIB_PATCH_VERSION[ ]+[0-9]+" TAGLIB_PATCH_VERSION_MATCH ${TAGLIB_H})
-+
-+ string(REGEX REPLACE ".*_MAJOR_VERSION[ ]+(.*)" "\\1" TAGLIB_MAJOR_VERSION "${TAGLIB_MAJOR_VERSION_MATCH}")
-+ string(REGEX REPLACE ".*_MINOR_VERSION[ ]+(.*)" "\\1" TAGLIB_MINOR_VERSION "${TAGLIB_MINOR_VERSION_MATCH}")
-+ string(REGEX REPLACE ".*_PATCH_VERSION[ ]+(.*)" "\\1" TAGLIB_PATCH_VERSION "${TAGLIB_PATCH_VERSION_MATCH}")
-+
-+ set(Taglib_VERSION "${TAGLIB_MAJOR_VERSION}.${TAGLIB_MINOR_VERSION}.${TAGLIB_PATCH_VERSION}")
-+ endif()
-+endif()
-+
-+include(FindPackageHandleStandardArgs)
-+find_package_handle_standard_args(Taglib
-+ FOUND_VAR
-+ Taglib_FOUND
-+ REQUIRED_VARS
-+ Taglib_LIBRARIES
-+ Taglib_INCLUDE_DIRS
-+ VERSION_VAR
-+ Taglib_VERSION
-+)
-+
-+if (Taglib_FOUND AND NOT TARGET Taglib::Taglib)
-+ add_library(Taglib::Taglib UNKNOWN IMPORTED)
-+ set_target_properties(Taglib::Taglib PROPERTIES
-+ IMPORTED_LOCATION "${Taglib_LIBRARIES}"
-+ INTERFACE_INCLUDE_DIRECTORIES "${Taglib_INCLUDE_DIRS}"
-+ )
-+endif()
-+
-+mark_as_advanced(Taglib_LIBRARIES Taglib_INCLUDE_DIRS)
-+
-+include(FeatureSummary)
-+set_package_properties(Taglib PROPERTIES
-+ URL "https://taglib.org/"
-+ DESCRIPTION "A library for reading and editing the meta-data of audio formats"
-+)
-diff --git a/src/libtomahawk/CMakeLists.txt b/src/libtomahawk/CMakeLists.txt
-index 348d6b1dd..e0a342f0e 100644
---- a/src/libtomahawk/CMakeLists.txt
-+++ b/src/libtomahawk/CMakeLists.txt
-@@ -533,8 +533,8 @@ TARGET_LINK_LIBRARIES(${TOMAHAWK_LIBRARY} PRIVATE
- )
-
- # TagLib
--TARGET_LINK_LIBRARIES(${TOMAHAWK_LIBRARY} LINK_PUBLIC ${TAGLIB_LIBRARIES})
--TARGET_INCLUDE_DIRECTORIES(${TOMAHAWK_LIBRARY} PUBLIC ${TAGLIB_INCLUDES})
-+TARGET_LINK_LIBRARIES(${TOMAHAWK_LIBRARY} LINK_PUBLIC ${Taglib_LIBRARIES})
-+TARGET_INCLUDE_DIRECTORIES(${TOMAHAWK_LIBRARY} PUBLIC ${Taglib_INCLUDE_DIRS})
-
- INSTALL( TARGETS ${TOMAHAWK_LIBRARY}
- EXPORT TomahawkLibraryDepends
---
-2.27.0
-
diff --git a/media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-fix-warning.patch b/media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-fix-warning.patch
deleted file mode 100644
index 8e02e8e300c3..000000000000
--- a/media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-fix-warning.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From cd5444573eec73a564263c20220ba0562cc655c5 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Thu, 8 Nov 2018 15:10:56 +0100
-Subject: [PATCH] Fix "control reaches end of non-void function" in
- DelegateConfigWrapper
-
-Thanks-to: Fabian Vogt <fabian@ritter-vogt.de>
----
- src/libtomahawk/accounts/DelegateConfigWrapper.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/libtomahawk/accounts/DelegateConfigWrapper.cpp b/src/libtomahawk/accounts/DelegateConfigWrapper.cpp
-index e78b64aec..875016ca1 100644
---- a/src/libtomahawk/accounts/DelegateConfigWrapper.cpp
-+++ b/src/libtomahawk/accounts/DelegateConfigWrapper.cpp
-@@ -247,6 +247,7 @@ DelegateConfigWrapper::getTestConfigMessage( int code )
- case Tomahawk::Accounts::ConfigTestResultAccountExpired:
- return tr( "Your account has expired." );
- }
-+ return QString();
- }
-
-
---
-2.19.1
-
diff --git a/media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-qt-5.15.patch b/media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-qt-5.15.patch
deleted file mode 100644
index f07b746a03f7..000000000000
--- a/media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-qt-5.15.patch
+++ /dev/null
@@ -1,140 +0,0 @@
-From 4fb44c931be648d61ef3c8d10426b34de1b2a53b Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Fri, 8 May 2020 23:55:43 +0200
-Subject: [PATCH] Fix build with Qt 5.15 (missing QPainterPath)
-
----
- src/libtomahawk/utils/AnimatedSpinner.cpp | 1 +
- src/libtomahawk/utils/TomahawkUtilsGui.cpp | 1 +
- src/libtomahawk/widgets/DropDownButton.cpp | 2 ++
- src/libtomahawk/widgets/HoverControls.cpp | 1 +
- src/libtomahawk/widgets/SourceTreePopupDialog.cpp | 1 +
- src/libtomahawk/widgets/searchlineedit/SearchButton.cpp | 9 +++++----
- src/tomahawk/widgets/AccountsPopupWidget.cpp | 1 +
- src/tomahawk/widgets/SlideSwitchButton.cpp | 1 +
- src/tomahawk/widgets/SocialWidget.cpp | 3 ++-
- 9 files changed, 15 insertions(+), 5 deletions(-)
-
-diff --git a/src/libtomahawk/utils/AnimatedSpinner.cpp b/src/libtomahawk/utils/AnimatedSpinner.cpp
-index b4778cbe9..a705cfaa2 100644
---- a/src/libtomahawk/utils/AnimatedSpinner.cpp
-+++ b/src/libtomahawk/utils/AnimatedSpinner.cpp
-@@ -28,6 +28,7 @@
- #include <QApplication>
- #include <QHideEvent>
- #include <QPainter>
-+#include <QPainterPath>
- #include <QPaintEvent>
- #include <QShowEvent>
-
-diff --git a/src/libtomahawk/utils/TomahawkUtilsGui.cpp b/src/libtomahawk/utils/TomahawkUtilsGui.cpp
-index b35799723..d2733d4a7 100644
---- a/src/libtomahawk/utils/TomahawkUtilsGui.cpp
-+++ b/src/libtomahawk/utils/TomahawkUtilsGui.cpp
-@@ -32,6 +32,7 @@
-
- #include <QLayout>
- #include <QPainter>
-+#include <QPainterPath>
- #include <QPixmap>
- #include <QBitmap>
- #include <QPalette>
-diff --git a/src/libtomahawk/widgets/DropDownButton.cpp b/src/libtomahawk/widgets/DropDownButton.cpp
-index 74aa344d1..106e8b882 100644
---- a/src/libtomahawk/widgets/DropDownButton.cpp
-+++ b/src/libtomahawk/widgets/DropDownButton.cpp
-@@ -19,6 +19,8 @@
- #include "DropDownButton.h"
-
- #include <QMouseEvent>
-+#include <QPaintEvent>
-+#include <QPainterPath>
-
- #include "Artist.h"
- #include "Album.h"
-diff --git a/src/libtomahawk/widgets/HoverControls.cpp b/src/libtomahawk/widgets/HoverControls.cpp
-index 3e31bf236..0b6b20aa8 100644
---- a/src/libtomahawk/widgets/HoverControls.cpp
-+++ b/src/libtomahawk/widgets/HoverControls.cpp
-@@ -27,6 +27,7 @@
- #include <QPixmap>
- #include <QPaintEvent>
- #include <QPainter>
-+#include <QPainterPath>
-
- using namespace Tomahawk;
-
-diff --git a/src/libtomahawk/widgets/SourceTreePopupDialog.cpp b/src/libtomahawk/widgets/SourceTreePopupDialog.cpp
-index 807eb354a..1379c9c53 100644
---- a/src/libtomahawk/widgets/SourceTreePopupDialog.cpp
-+++ b/src/libtomahawk/widgets/SourceTreePopupDialog.cpp
-@@ -22,6 +22,7 @@
- #include <QApplication>
- #include <QPaintEvent>
- #include <QPainter>
-+#include <QPainterPath>
- #include <QDialogButtonBox>
- #include <QVBoxLayout>
- #include <QHBoxLayout>
-diff --git a/src/libtomahawk/widgets/searchlineedit/SearchButton.cpp b/src/libtomahawk/widgets/searchlineedit/SearchButton.cpp
-index 1d9f1c4bd..97c5406f2 100644
---- a/src/libtomahawk/widgets/searchlineedit/SearchButton.cpp
-+++ b/src/libtomahawk/widgets/searchlineedit/SearchButton.cpp
-@@ -19,10 +19,11 @@
-
- #include "SearchButton.h"
-
--#include <qcompleter.h>
--#include <qevent.h>
--#include <qlineedit.h>
--#include <qpainter.h>
-+#include <QCompleter>
-+#include <QEvent>
-+#include <QLineEdit>
-+#include <QPainter>
-+#include <QPainterPath>
-
- SearchButton::SearchButton(QWidget *parent)
- : QAbstractButton(parent)
-diff --git a/src/tomahawk/widgets/AccountsPopupWidget.cpp b/src/tomahawk/widgets/AccountsPopupWidget.cpp
-index cb5739b97..ffd5dcaa1 100644
---- a/src/tomahawk/widgets/AccountsPopupWidget.cpp
-+++ b/src/tomahawk/widgets/AccountsPopupWidget.cpp
-@@ -24,6 +24,7 @@
-
- #include <QDebug>
- #include <QPainter>
-+#include <QPainterPath>
- #include <QPaintEvent>
- #include <QVBoxLayout>
-
-diff --git a/src/tomahawk/widgets/SlideSwitchButton.cpp b/src/tomahawk/widgets/SlideSwitchButton.cpp
-index 3c61b4987..103562e00 100644
---- a/src/tomahawk/widgets/SlideSwitchButton.cpp
-+++ b/src/tomahawk/widgets/SlideSwitchButton.cpp
-@@ -24,6 +24,7 @@
-
- #include <QMouseEvent>
- #include <QPainter>
-+#include <QPainterPath>
- #include <QPropertyAnimation>
- #include <QStyleOptionButton>
- #include <QPixmap>
-diff --git a/src/tomahawk/widgets/SocialWidget.cpp b/src/tomahawk/widgets/SocialWidget.cpp
-index f0901279d..b43f44c5d 100644
---- a/src/tomahawk/widgets/SocialWidget.cpp
-+++ b/src/tomahawk/widgets/SocialWidget.cpp
-@@ -29,8 +29,9 @@
- #include "Source.h"
- #include "Track.h"
-
--#include <QPainter>
- #include <QDialog>
-+#include <QPainter>
-+#include <QPainterPath>
- #include <QPropertyAnimation>
-
- #define ARROW_HEIGHT 6
---
-2.26.2
-
diff --git a/media-sound/tomahawk/metadata.xml b/media-sound/tomahawk/metadata.xml
deleted file mode 100644
index 602a023a5bef..000000000000
--- a/media-sound/tomahawk/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>kde@gentoo.org</email>
- <name>Gentoo KDE Project</name>
- </maintainer>
- <use>
- <flag name="telepathy">Enable support for the real-time communication framework telepathy</flag>
- </use>
-</pkgmetadata>
diff --git a/media-sound/tomahawk/tomahawk-0.9.0_pre20181030.ebuild b/media-sound/tomahawk/tomahawk-0.9.0_pre20181030.ebuild
deleted file mode 100644
index 442d0f525b7b..000000000000
--- a/media-sound/tomahawk/tomahawk-0.9.0_pre20181030.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-COMMIT=777b31219179b43f56c7b95857d2fbd7f33199aa
-inherit cmake xdg-utils
-
-DESCRIPTION="Multi-source social music player"
-HOMEPAGE="https://github.com/tomahawk-player/tomahawk"
-SRC_URI="https://github.com/${PN}-player/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3 BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="telepathy xmpp"
-
-BDEPEND="
- dev-qt/linguist-tools:5
-"
-COMMON_DEPEND="
- app-crypt/qca:2[qt5(+)]
- dev-cpp/lucene++
- dev-cpp/sparsehash
- dev-libs/boost:=
- dev-libs/qtkeychain:=[qt5(+)]
- >=dev-libs/quazip-0.7.2[qt5(+)]
- dev-qt/qtcore:5
- dev-qt/qtdbus:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtsql:5
- dev-qt/qtsvg:5
- dev-qt/qtwebkit:5
- dev-qt/qtwidgets:5
- dev-qt/qtx11extras:5
- dev-qt/qtxml:5
- kde-frameworks/extra-cmake-modules:5
- kde-frameworks/attica:5
- >=media-libs/liblastfm-1.1.0_pre20150206
- >=media-libs/taglib-1.8.0
- media-video/vlc:=[flac,dvbpsi,ffmpeg,mp3]
- >=net-libs/gnutls-3.2:=
- x11-libs/libX11
- telepathy? ( >=net-libs/telepathy-qt-0.9.7-r1[qt5(+)] )
- xmpp? ( >=net-libs/jreen-1.3.0[qt5(+)] )
-"
-DEPEND="${COMMON_DEPEND}
- dev-qt/designer:5
- dev-qt/qtconcurrent:5
-"
-RDEPEND="${COMMON_DEPEND}
- app-crypt/qca:2[ssl]
-"
-
-S="${WORKDIR}/${PN}-${COMMIT}"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-warning.patch"
- "${FILESDIR}/${P}-cmakepolicy.patch" # bug 674826
- "${FILESDIR}/${P}-qt-5.15.patch" # git master
- "${FILESDIR}/${P}-findtaglib.patch" # pending upstream
-)
-
-src_configure() {
- local mycmakeargs=(
- -DWITH_CRASHREPORTER=OFF
- -DBUILD_TESTS=OFF
- -DBUILD_TOOLS=OFF
- -DBUILD_HATCHET=OFF
- -DWITH_TelepathyQt=$(usex telepathy)
- -DWITH_Jreen=$(usex xmpp)
- )
-
- [[ ${PV} != *9999* ]] && mycmakeargs+=( -DBUILD_RELEASE=ON )
-
- cmake_src_configure
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index e53345f67b6d..3a7cbd138fa7 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -249,13 +249,6 @@ media-libs/qt-gstreamer
# Masked for removal in 30 days.
kde-apps/ktp-call-ui
-# Andreas Sturmlechner <asturm@gentoo.org> (2020-12-26)
-# Depends on deprecated dev-qt/qtwebkit, abandoned upstream.
-# Alternatives: Plenty. media-sound/cantata, media-sound/clementine,
-# media-sound/elisa, media-sound/strawberry, media-sound/yarock, ...
-# Masked for removal in 30 days.
-media-sound/tomahawk
-
# Andrew Savchenko <bircoph@gentoo.org> (2020-12-26)
# All docs and socket library functionality are merged back into single
# app-admin/clsync package using USE="apidoc doc socket-library" starting