summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/gdal/files/gdal-2.3.0-curl.patch15
-rw-r--r--sci-libs/gdal/gdal-2.3.0-r1.ebuild1
2 files changed, 16 insertions, 0 deletions
diff --git a/sci-libs/gdal/files/gdal-2.3.0-curl.patch b/sci-libs/gdal/files/gdal-2.3.0-curl.patch
new file mode 100644
index 000000000000..1cd33243f42b
--- /dev/null
+++ b/sci-libs/gdal/files/gdal-2.3.0-curl.patch
@@ -0,0 +1,15 @@
+diff -urNd gdal-2.3.1/port/cpl_vsil_curl.cpp gdal-2.3.1-curl/port/cpl_vsil_curl.cpp
+--- gdal-2.3.1/port/cpl_vsil_curl.cpp 2018-06-24 01:10:23.000000000 +1000
++++ gdal-2.3.1-curl/port/cpl_vsil_curl.cpp 2018-07-13 01:29:31.326347717 +1000
+@@ -8617,8 +8617,10 @@
+ if( poFSHandler )
+ poFSHandler->ClearCache();
+ }
+-
++#if !defined(HAVE_CURL) || defined(CPL_MULTIPROC_STUB)
++#else
+ VSICurlStreamingClearCache();
++#endif
+ }
+
+ #endif /* HAVE_CURL */
diff --git a/sci-libs/gdal/gdal-2.3.0-r1.ebuild b/sci-libs/gdal/gdal-2.3.0-r1.ebuild
index 8aacbcb83c78..2ddaa49d4146 100644
--- a/sci-libs/gdal/gdal-2.3.0-r1.ebuild
+++ b/sci-libs/gdal/gdal-2.3.0-r1.ebuild
@@ -81,6 +81,7 @@ PATCHES=(
"${FILESDIR}/${PN}-2.2.3-soname.patch"
"${FILESDIR}/${PN}-2.2.3-bashcomp-path.patch" # bug 641866
"${FILESDIR}/${PN}-2.2.3-goocast.patch" # bug 656252
+ "${FILESDIR}/${PN}-2.3.0-curl.patch" # bug 659840
)
src_prepare() {