summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-nds/yp-tools/yp-tools-4.2.2-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-nds/yp-tools/yp-tools-4.2.2-r2.ebuild b/net-nds/yp-tools/yp-tools-4.2.2-r2.ebuild
new file mode 100644
index 000000000000..314678603f58
--- /dev/null
+++ b/net-nds/yp-tools/yp-tools-4.2.2-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit systemd
+
+DESCRIPTION="Network Information Service tools"
+HOMEPAGE="http://www.linux-nis.org/nis/"
+SRC_URI="http://www.linux-nis.org/download/yp-tools/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls"
+
+DEPEND="
+ net-libs/libtirpc
+ net-libs/libnsl:0=
+"
+RDEPEND=${DEPEND}
+# uses always libtirpc if present
+
+RESTRICT=test # do not compile
+
+src_configure () {
+ econf \
+ --disable-static \
+ --sysconfdir=/etc/yp \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ insinto /etc/yp
+ doins etc/nicknames
+
+ systemd_dounit "${FILESDIR}/domainname.service"
+ systemd_install_serviced "${FILESDIR}"/domainname.service.conf
+}