summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/nano/metadata.xml3
-rw-r--r--app-editors/nano/nano-3.2.ebuild4
-rw-r--r--app-editors/nano/nano-4.2.ebuild4
-rw-r--r--app-editors/nano/nano-4.3.ebuild4
-rw-r--r--app-editors/nano/nano-9999.ebuild4
5 files changed, 11 insertions, 8 deletions
diff --git a/app-editors/nano/metadata.xml b/app-editors/nano/metadata.xml
index ba70fb9893e9..add7f71937d3 100644
--- a/app-editors/nano/metadata.xml
+++ b/app-editors/nano/metadata.xml
@@ -35,5 +35,8 @@ perhaps providing other extra functionality.
Disable all fancy features, including ones that otherwise have a dedicated
USE flag (such as spelling).
</flag>
+ <flag name="split-usr">
+ Enable this if /bin and /usr/bin are separate directories
+ </flag>
</use>
</pkgmetadata>
diff --git a/app-editors/nano/nano-3.2.ebuild b/app-editors/nano/nano-3.2.ebuild
index ef6555432c21..9c28db49f39f 100644
--- a/app-editors/nano/nano-3.2.ebuild
+++ b/app-editors/nano/nano-3.2.ebuild
@@ -18,7 +18,7 @@ HOMEPAGE="https://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Basics_
LICENSE="GPL-3"
SLOT="0"
-IUSE="debug justify +magic minimal ncurses nls slang +spell static unicode"
+IUSE="debug justify +magic minimal ncurses nls slang +spell +split-usr static unicode"
LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0=[unicode?]
sys-libs/ncurses:0=[static-libs(+)]
@@ -79,5 +79,5 @@ src_install() {
"${ED%/}"/etc/nanorc || die
fi
- dosym ../../bin/nano /usr/bin/nano
+ use split-usr && dosym ../../bin/nano /usr/bin/nano
}
diff --git a/app-editors/nano/nano-4.2.ebuild b/app-editors/nano/nano-4.2.ebuild
index cbab8247c5c8..9bef974a5c32 100644
--- a/app-editors/nano/nano-4.2.ebuild
+++ b/app-editors/nano/nano-4.2.ebuild
@@ -18,7 +18,7 @@ HOMEPAGE="https://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Basics_
LICENSE="GPL-3"
SLOT="0"
-IUSE="debug justify +magic minimal ncurses nls slang +spell static unicode"
+IUSE="debug justify +magic minimal ncurses nls slang +spell +split-usr static unicode"
LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0=[unicode?]
sys-libs/ncurses:0=[static-libs(+)]
@@ -76,5 +76,5 @@ src_install() {
"${ED}"/etc/nanorc || die
fi
- dosym ../../bin/nano /usr/bin/nano
+ use split-usr && dosym ../../bin/nano /usr/bin/nano
}
diff --git a/app-editors/nano/nano-4.3.ebuild b/app-editors/nano/nano-4.3.ebuild
index 232301c01447..9934461b7d4e 100644
--- a/app-editors/nano/nano-4.3.ebuild
+++ b/app-editors/nano/nano-4.3.ebuild
@@ -18,7 +18,7 @@ HOMEPAGE="https://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Basics_
LICENSE="GPL-3"
SLOT="0"
-IUSE="debug justify +magic minimal ncurses nls slang +spell static unicode"
+IUSE="debug justify +magic minimal ncurses nls slang +spell +split-usr static unicode"
LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0=[unicode?]
sys-libs/ncurses:0=[static-libs(+)]
@@ -76,5 +76,5 @@ src_install() {
"${ED}"/etc/nanorc || die
fi
- dosym ../../bin/nano /usr/bin/nano
+ use split-usr && dosym ../../bin/nano /usr/bin/nano
}
diff --git a/app-editors/nano/nano-9999.ebuild b/app-editors/nano/nano-9999.ebuild
index 232301c01447..9934461b7d4e 100644
--- a/app-editors/nano/nano-9999.ebuild
+++ b/app-editors/nano/nano-9999.ebuild
@@ -18,7 +18,7 @@ HOMEPAGE="https://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Basics_
LICENSE="GPL-3"
SLOT="0"
-IUSE="debug justify +magic minimal ncurses nls slang +spell static unicode"
+IUSE="debug justify +magic minimal ncurses nls slang +spell +split-usr static unicode"
LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0=[unicode?]
sys-libs/ncurses:0=[static-libs(+)]
@@ -76,5 +76,5 @@ src_install() {
"${ED}"/etc/nanorc || die
fi
- dosym ../../bin/nano /usr/bin/nano
+ use split-usr && dosym ../../bin/nano /usr/bin/nano
}